Wprowadzenie

Dokument zawiera pomoc kontekstową dla programu „NNR-Pro Nadzorowanie Niezgodności/Reklamacji”. Pomoc kontekstowa prezentuje w trakcie pracy programu, informacje opisujące aktualnie wyświetlane okno programu. Dodatkowe informacje dotyczące między innymi: instalacji programu, konfiguracji, archiwizacji bazy danych, zasad obsługi (w tym prezentacja interfejsu użytkownika) oraz rozwiązywania problemów można znaleźć w podręczniku użytkownika.
Zobacz też: informacje ogólne
Copyright © DMS-Komputery, 2005..


Informacje ogólne

Program „NNR-Pro Nadzorowanie Niezgodności/Reklamacji” jest narzędziem ułatwiającym obsługę oraz monitorowanie procesu usunięcia niezgodności / rozpatrzenia reklamacji. Program NNR-Pro składa się z dwóch podstawowych modułów, z których każdy dokumentuje inny kierunek zgłoszeń tj:
  • modułu „Zgłoszenia przychodzące / reklamacje klientów”, w którym w rejestrze zgłoszeń przychodzących, zawarte są informacje o otrzymanych zgłoszeniach reklamacyjnych klientów oraz wykrytych niezgodnościach,
  • modułu „Zgłoszenia wychodzące / reklamacje do dostawców”, który umożliwia przygotowanie zgłoszenia reklamacyjnego do dostawcy, kooperanta albo serwisu producenta, a w dzienniku zgłoszeń wychodzących zawiera informacje o zgłoszeniach przekazanych dostawcom, kooperantom lub do serwisu producenta.
Jeśli przyczyna powstania niezgodności (reklamacji) tkwi po stronie naszego dostawcy (kooperanta), w programie NNR-Pro można przypisać jako działanie zmierzające do wyeliminowania niezgodności (rozwiązania problemu generującego reklamację), adekwatny zapis dziennika zgłoszeń wychodzących.
W rejestrze zgłoszeń przychodzących oprogramowanie umożliwia dokumentowanie działań związanych z procesem reklamacji w formie tradycyjnej (wyłącznie nadzorowanie reklamacji) lub w formie adekwatnej do standardu opisanego w Normie ISO 9001 (nadzorowanie niezgodności zaistniałych w systemie zarządzania jakością).
Aktualnie w ramach formy tradycyjnej dokumentacja działań może odnosić się do jednego z poniższych wariantów zgłoszeń reklamacyjnych:
  • reklamacji wadliwego towaru (wariant ogólny),
  • reklamacji wadliwego towaru u partnera handlowego,
  • zgłoszenia błędu w oprogramowaniu.
Lista wariantów nie jest zamknięta i może być rozbudowana o nowe warianty.
Forma przystosowana do wymagań Normy ISO 9001 umożliwia nadzorowanie
  • zgłoszeń dotyczących niezgodności zewnętrznych przekazanych:
    • protokołem reklamacyjnym,
    • protokołem niezgodności dostawy,
    • innym dokumentem zewnętrznym
  • oraz zgłoszeń dotyczących niezgodności wewnętrznych przekazanych:
    • raportem z audytu SZJ (NA-SZJ),
    • raportem z audytu procesu (NA-procesu),
    • raportem z audytu wyrobu (NA-wyrobu),
    • notatką ze spotkania kierownictwa,
    • kartą braków,
    • innym dokumentem wewnętrznym.
Ponadto program NNR-Pro, w formie przystosowanej do wymagań Normy ISO 9001, umożliwia opracowanie dokumentacji opisującej rozwiązanie problemu metodą 8D i wydrukowanie raportu 8D (ang. 8D Report).
Dodatkowy moduł analiz pozwala na sumaryczną ocenę zgromadzonych w bazie danych programu NNR-Pro, informacji i wyciągnięcie ogólniejszych wniosków, np. na podstawie wyliczanych w raportach wskaźników efektywności (KPI). Moduł analiz umożliwia przygotowanie np. raportu informującego o podziale kosztów reklamacji w rozbiciu na sprawców uchybienia, raportu z informacją o zgłoszeniach przeterminowanych w rozbiciu na osoby odpowiedzialne lub raportu informującego o ilości reklamowanej w rozbiciu na wyroby. Lista analiz nie jest zamknięta i może być rozbudowana.
Program udostępniany jest w dowolnej kombinacji modułów, form dokumentacji i wariantów, co pozwala na uzyskanie oprogramowania optymalnie dostosowanego do charakteru gromadzonych i przetwarzanych danych.
Rodzaj wyświetlanej dokumentacji można wybrać poprzez menu programu wybierając kolejno polecenia Aplikacja → Dokumentacja a następnie Rejestr zgłoszeń przychodzących lub Dziennik zgłoszeń wychodzących. Można też ustalić domyślny dokument wyświetlany w chwili uruchomienia programu NNR-Pro (zobacz podręcznik użytkownika -> Konfiguracja uzupełniająca - uruchamianie programu).


Rejestr zgłoszeń przychodzących

Rejestr zgłoszeń przychodzących zawiera informacje o otrzymanych zgłoszeniach reklamacyjnych klientów oraz wykrytych niezgodnościach. Rejestr zgłoszeń przychodzących może być wyświetlony w jednej z dwóch form:
  • listy zestawów zgłoszeń, w której zgłoszenia prezentowane są w ramach zestawów do jakich zgłoszenie zostało przypisane podczas rejestracji, Rejestr zgłoszeń przychodzących - zestawy
  • listy zgłoszeń, w której zgłoszenia prezentowane są niezależnie od zestawów do jakich zgłoszenie zostało przypisane podczas rejestracji. Rejestr zgłoszeń przychodzących - zgłoszenia
By przypisać zgłoszenie do zestawu, należy je zarejestrować wówczas, gdy aktywną formą wyświetlania rejestru zgłoszeń przychodzących jest lista zestawów zgłoszeń. Po rozpoczęciu edycji informacji o zestawie i przeniesieniu skupienia do tabeli znajdującej się na zakładce /Specyfikacja zgłoszeń/, można wywołać operację rejestracji zgłoszenia. Wprowadzenie danych o zgłoszeniu może odbywać się bezpośrednio w wierszu tabeli albo na formularzu zawierającym panel edycji, identyczny z panelem prezentującym pełne dane podczas wyświetlania rejestru zgłoszeń przychodzących, gdy aktywną formą wyświetlania rejestru jest lista zgłoszeń.
Jeśli zgłoszenie jest rejestrowane wówczas, gdy aktywną formą wyświetlania rejestru zgłoszeń przychodzących jest lista zgłoszeń, program automatycznie tworzy nowy zestaw, do którego przypisane zostanie rejestrowane zgłoszenie. Utworzony zestaw będzie więc zawierał informacje tylko o jednym zgłoszeniu. Jeśli jednak po zakończeniu rejestracji zgłoszenia zmieniona zostanie forma wyświetlania rejestru zgłoszeń przychodzących z listy zgłoszeń na listę zestawów zgłoszeń, można do zestawu dołączyć informacje o kolejnych zgłoszeniach.
Na przedstawionych wyżej rysunkach pola otoczone czerwonym owalem o blado-czerwonym wypełnieniu oraz wszystkie pola bloku zawierającego informacje o zgłaszającym (nazwa bloku otoczona jest czerwonym owalem o blado-czerwonym wypełnieniu), przedstawiają identyczne informacje w każdej z form wyświetlania rejestru zgłoszeń przychodzących a ich edycja może być wykonywana w dowolnej z tych form wyświetlania rejestru.
Okno zakresu udostępnianych zapisów
W trakcie przeglądania rejestru zgłoszeń przychodzących można zmienić formę wyświetlania rejestru, o ile nie jest aktywna operacja chwilowo blokująca operacje zmiany formy wyświetlania (np. operacja edycji zapisu rejestru), np. naciskając klawisz [F12]. To w jakiej formie rejestr zgłoszeń zostanie wyświetlony po otwarciu dokumentu, zależy od stanu pola wyboru zatytułowanego Wyświetlaj zestawy (na rysunku obok pole wraz z nazwą otoczone są czerwonym owalem o blado-czerwonym wypełnieniu). Poprzez zaznaczenie bądź nie pola wyboru, można wybrać odpowiednią formę wyświetlania rejestru zgłoszeń po jego otwarciu.
Ponadto przed wyświetleniem rejestru można wskazać jakie zapisy będą widoczne. Ustalony zakres udostępnianej dokumentacji obejmuje rok i miesiąc wprowadzenia zapisów do rejestru, status zapisów stwierdzający czy zgłoszenia lub zestawy zgłoszeń (w zależności od aktywnej formy wyświetlania rejestru) zostały rozpatrzone oraz dane osoby odpowiedzialnej za zgłoszenie (gdy rejestr wyświetlany jest jako lista zgłoszeń) lub dane osoby odpowiedzialnej za zestaw zgłoszeń (gdy rejestr wyświetlany jest jako lista zestawów zgłoszeń). Jeśli wybrana zostanie opcja wyboru osoby odpowiedzialnej ale dane tej osoby nie zostaną wskazane, wyświetlony zostanie rejestr zawierający wyłącznie zapisy dotyczące zgłoszeń (gdy rejestr wyświetlany jest jako lista zgłoszeń) lub zestawów zgłoszeń (gdy rejestr wyświetlany jest jako lista zestawów zgłoszeń), którym nie zostały przypisane dane osoby odpowiedzialnej.
Uwaga: w programie NNR-Pro można przypisać dane osoby odpowiedzialnej za zastaw zgłoszeń i niezależnie, dla każdego ze zgłoszeń należących do zestawu dane osoby odpowiedzialnej za to zgłoszenie.
Ustalony zakres udostępnianej dokumentacji obowiązuje do czasu zamknięcia rejestru zgłoszeń przychodzących, tzn. by np. wyświetlić zapisy dotyczące zgłoszeń, za które odpowiedzialna jest inna osoba należy zamknąć i ponownie otworzyć rejestr zgłoszeń.
Oprócz ustalenia zakresu udostępnianej dokumentacji, można zawęzić listę wyświetlanych zapisów poprzez określenie dodatkowych warunków, jakie muszą spełniać wyświetlane zapisy rejestru zgłoszeń przychodzących (warunków filtrowania). Warunki filtrowania mogą być na bieżąco aktualizowane w trakcie wyświetlania rejestru zgłoszeń. By określić warunki filtrowania należy uwidocznić panel warunków filtrowania (np. naciskając sekwencję klawiszy [Ctrl] + [F]), wprowadzić warunki filtrowania i włączyć filtr. Po każdorazowej zmianie warunków filtrowania należy „poinformować” program NNR-Pro o zakończeniu zmiany warunków filtrowania np. naciskając sekwencję klawiszy [Ctrl] + [R]. Warunki filtrowania są nakładane tzn. wyświetlona informacja musi spełniać wszystkie wprowadzone warunki.
Jednym z warunków filtrowania jest identyfikator pomocniczy. Identyfikator pomocniczy opisuje rodzaj i treść informacji jaką muszą zawierać wyświetlane zapisy. Przykładowo można wyszukać wszystkie zapisy dotyczące zgłoszeń, dla których podaje się numer reklamacji klienta (występuje np. podczas rejestracji zgłoszeń dotyczących reklamacji wadliwego towaru u partnera handlowego) i numer ten jest identyczny z numerem wynikającym z zadanej treści informacji.
Okno wyboru bieżącego wariantu zapisów Istnieje również możliwość wyselekcjonowania zapisów dotyczących wybranych sposobów rejestracji zgłoszeń a co za tym idzie np. wydrukowania osobnych rejestrów dotyczących niezgodności zewnętrznych i niezgodności wewnętrznych, niezgodności wykrytych podczas audytu Systemu Zarządzania Jakością albo audytu procesu itp.. Warunki selekcji można swobodnie ustalać, co pozwala na np. uzyskanie wydruków rejestru zgłoszeń przychodzących odpowiadających bieżącym potrzebom (przykładowo wynikającym z konieczności udokumentowania spełnienia wymagań opisanych w Księdze jakości lub ogólniej, wymagań Normy ISO 9001).
W tabeli rejestru zgłoszeń przychodzących jak również w tabelach wyświetlających dodatkowe informacje odnoszące się do zapisu rejestru np. specyfikacji zgłoszeń, informacje dotyczące zapisów anulowanych wyświetlane są czcionką przekreśloną.
Operacja rejestracji nowego zestawu gdy rejestr wyświetlany jest w postaci listy zestawów zgłoszeń lub rejestracji nowego zgłoszenia gdy rejestr wyświetlany jest w postaci listy zgłoszeń, może być wywołana poprzez wybranie kolejno poleceń menu „Dokument” → „Wprowadzenie wpisu” a następnie „Rejestracja reklamacji” lub „Rejestracja niezgodności”. Alternatywnie można wykorzystać skróty klawiaturowe przypisane poleceniom rejestracji: klawisz [Ins] dla rejestracji reklamacji oraz sekwencja klawiszy [Shift] + [Ins] dla rejestracji niezgodności. Ostatnim sposobem wywołania operacji rejestracji jest kliknięcie na przycisku paska narzędziowego, dedykowanym operacji wprowadzenia. Jeśli przycisk zostanie kliknięty podczas naciśnięcia klawisza [Shift], wywołana zostanie operacja rejestracji niezgodności a w pozostałych sytuacjach, operacja rejestracji reklamacji.
Określenie rodzaju zgłoszenia reklamacyjnego Rejestrację poprzedza wybór wariantu reklamacji lub rodzaju dokumentu jakim przekazano niezgodność. Lista aktywnych wariantów reklamacji oraz możliwość rejestracji niezgodności uzależniona jest od posiadanej wersji programu NNR-Pro.
W przypadku zgłoszeń dotyczących reklamacji należy wskazać jedną z dostępnych w programie zwyczajowych form dokumentowania reklamacji. Okno wyboru rodzaju zgłoszeń reklamacyjnych oprócz opcji wyboru, zawiera przełącznik (na rysunku obok pole przełącznika wraz z nazwą otoczone są czerwonym owalem o blado-czerwonym wypełnieniu) określający czy wybór ma zostać zapamiętany. Od stanu tego przełącznika zależy sposób działania programu po naciśnięciu klawisza [Ins] lub kliknięciu przycisku paska narzędziowego dedykowanego operacji rejestracji. Początkowo takie wywołanie operacji rejestracji, wyświetla okno wyboru wariantu zgłoszeń reklamacyjnych. Jeśli jednak podczas wyboru rodzaju zgłoszenia reklamacyjnego, zostanie zaznaczona opcja zapamiętania wyboru, wówczas wywołanie kolejnej operacji rejestracji pomija wyświetlenie okna wyboru. Rejestracja rozpocznie się na formularzu odpowiadającym rodzajowi zgłoszenia reklamacyjnego wskazanego w chwili zaznaczenia przełącznika wyboru. Jeśli zamierzamy rejestrować zgłoszenie reklamacyjne dla innego wariantu, operację rejestracji należy wywołać z menu programu. Można przywrócić początkowe działanie klawisza skrótu oraz przycisku paska narzędziowego, wywołując z menu programu polecenie „Rejestracja reklamacji” gdy naciśnięte są klawisze [Shift] i [Ctrl]. Przywrócenie początkowego działania klawisza skrótu oraz przycisku paska narzędziowego, nastąpi po zamknięciu okna wyboru (zarówno poprzez akceptację jak i anulowanie wyboru) o ile nie zostanie zaznaczony przełącznik określający czy wybór ma zostać zapamiętany,
Określenie rodzaju dokumentu jakim przekazano zgłoszenie dotyczące niezgodności W przypadku zgłoszeń dotyczących niezgodności, należy wskazać rodzaj dokumentu jakim zgłoszenie dotyczące niezgodności zostało przekazane. Dlatego przed rozpoczęciem operacji rejestracji, zawsze wyświetlane jest okno umożliwiające dokonanie wyboru rodzaju dokumentu. Rejestracja (edycja) zgłoszeń dotyczących niezgodności wykorzystuje formę dokumentowania przystosowaną do wymagań Normy ISO 9001. Jeśli posiadana wersja programu NNR-Pro nie ma aktywnych funkcjonalności dotyczących rejestracji jednego z wariantów reklamacji, wywołanie operacji rejestracji niezgodności za pomocą skrótu klawiaturowego lub przycisku paska narzędziowego, nie wymaga korzystania z klawisza [Shift].


Rejestr zgłoszeń przychodzących - zestawy zgłoszeń

Ta forma wyświetlania rejestru zgłoszeń przychodzących umożliwia przyglądanie zgłoszeń w podziale na zestawy, do których zgłoszenie zostało przypisane. W programie NNR-Pro każde zgłoszenie przypisane jest do konkretnego zestawu (jeśli zgłoszenie wprowadzone zostało gdy rejestr zgłoszeń przychodzących wyświetlany był w formie listy zgłoszeń, program NNR-Pro utworzy nowy zestaw i dołączy do niego wprowadzone zgłoszenie). Wyświetlenie rejestru zgłoszeń przychodzących w postaci listy zestawów zgłoszeń jest korzystne w przypadku gdy zamierzamy zarejestrować np.: komplet zgłoszeń dostarczonych jednocześnie, które dotyczą tego samego klienta albo wszystkie niezgodności wykryte podczas danego audytu udokumentowane jednym raportem z audytu itp.
Informacje o zgłoszeniach ujętych w zestawie zawiera tabela znajdująca się na zakładce /Specyfikacja zgłoszeń/ (zobacz Zestaw zgłoszeń przychodzących). By przypisać nowe zgłoszenie do zestawu należy je dołączyć do specyfikacji zgłoszeń, tzn uaktywnić tryb edycji zestawu, a następnie z menu podręcznego tabeli wywołać operację rejestracji zgłoszenia. Zestaw może zawierać wyłącznie zgłoszenia jednego wariantu zgłoszeń reklamacyjnych (zob. Zwyczajowa forma dokumentowania) lub niezgodności (zob. Forma dokumentowania przystosowana do wymagań Normy ISO 9001). Szczegółowe informacje o zgłoszeniu można wyświetlić wskazując zgłoszenie w specyfikacji zgłoszeń i np. naciskając klawisz [F3].
Ten widok rejestru zgłoszeń przychodzących, oprócz standardowych operacji edycyjnych związanych z wprowadzeniem, poprawieniem oraz anulowaniem zapisu dotyczącego zestawu zgłoszeń, udostępnia dodatkowe operacje takie jak:

  • zatwierdzenie zestawu

    Operacja umożliwia określanie zestawów, które są np. zrealizowane. Dla zestawów zatwierdzonych nie są dostępne operacje edycyjne (zarówno samego zestawu jak i zgłoszeń do niego należących). Edycję można przywrócić, korzystając z polecenia „Odwołanie zatwierdzenia zestawu”.

  • odwołanie zatwierdzenia zestawu

    Wycofuje operację zatwierdzenia zestawu zgłoszeń, przywracając możliwość edycji.

  • zamknięcie zestawu

    Operacja umożliwia określanie zestawów, które są np. zrealizowane i nie będą nigdy aktualizowane. Dla zestawów zamkniętych nie są dostępne operacje edycyjne (zarówno samego zestawu jak i zgłoszeń do niego należących). Operacji zamknięcia nie można wycofać.
a także dodatkowe operacje nieedycyjne takie jak:

  • wybierz wariant zapisów

    Umożliwia wyselekcjonowania zapisów dotyczących wybranych sposobów rejestracji zgłoszeń a co za tym idzie np. wyświetlenia a następnie wydrukowania osobnych rejestrów dotyczących niezgodności zewnętrznych i niezgodności wewnętrznych, niezgodności wykrytych podczas audytu Systemu Zarządzania Jakością albo audytu procesu itp.. Warunki selekcji można swobodnie ustalać, co pozwala na np. uzyskanie wydruków rejestru zgłoszeń przychodzących odpowiadających bieżącym potrzebom (przykładowo wynikającym z konieczności udokumentowania spełnienia wymagań opisanych w Księdze jakości lub ogólniej, wymagań Normy ISO 9001).

  • raporty - analiza danych

    Polecenie wyświetla okno wyboru raportu, który ma być wygenerowany (zobacz Raporty - analiza danych).

  • zobacz podgląd wydruku rejestru

    Wyświetla podgląd wydruku rejestru. Podczas wyświetlania podglądu, można wywołać operację wydruku. Wykonanie wydruku poprzedza wybór ustawień wydruku, umożliwiający zmianę ustawień aktywnej drukarki. Przed wykonaniem wydruku można też określić numery stron jakie mają być wydrukowane.

  • drukuj rejestr

    Drukuje rejestr zgłoszeń przychodzących. Wykonanie wydruku poprzedza wybór ustawień wydruku umożliwiający zmianę ustawień aktywnej drukarki oraz określenie charakteru operacji wydruku i jej parametrów. By ograniczyć wydruk tylko do wybranych stron należy wywołać operację podglądu wydruku - tylko wywołanie operacji wydruku podczas wyświetlania podglądu wydruku umożliwia określenie numerów stron jakie mają być wydrukowane.

  • wydruki dokumentów

    Operacja pozwala na wydrukowanie dokumentów związanych z zestawem, który jest aktualnie wyróżniony w rejestrze (są to dokumenty powiązane z całym zestawem a nie dokumenty dotyczące pojedynczego zgłoszenia należącego do tego zestawu - dokumenty dotyczące pojedynczego zgłoszenia można wydrukować wykorzystując w tym celu polecenie wydruku dokumentów dostępne w menu podręcznym tabeli z zakładki /Specyfikacja zgłoszeń/). Jeśli przed wykonaniem wydruku ma być wyświetlony podgląd wydruku, polecenie należy wybrać przytrzymując naciśnięty klawisz [Shift].
    Aktywne formy wydruku dokumentów zależą od wariantu zgłoszeń zapisanych w zestawie. Przykładowo wydruk karty reklamacji jest możliwy tylko dla zestawów dotyczących zgłoszeń przekazanych przez partnera handlowego. Warto mieć na uwadze, że wydruk karty reklamacji wywołany z menu okna rejestru zgłoszeń oraz wywołany z menu podręcznego specyfikacji zgłoszeń nie są identyczne. W pierwszym przypadku wydruk karty reklamacji będzie zawierał informacje o wszystkich zgłoszeniach ujętych w zestawie a w drugim przypadku będzie zawierał informacje tylko o jednym zgłoszeniu. Ponadto wydruki te różnią się nie tylko układem graficznym ale również zakresem informacji o samym zgłoszeniu.
Zapisy rejestru opisujące zestawy, które nie zostały rozpatrzone (zatwierdzone lub zamknięte) i nie są anulowane, mają w tabeli wyświetlany numer zestawu na tle w kolorze innym (odcień żółtego) niż tło tabeli (standardowo białe).
Zobacz też: Rejestr zgłoszeń przychodzących (informacje ogólne)


Zestaw zgłoszeń przychodzących

Informacje opisujące zestaw zgłoszeń podzielone są na 3 bloki. Pierwszy blok zawiera dane ogólne dotyczące zestawu zgłoszeń takie jak numer zestawu i data rejestracji, data zamknięcia, oznaczenia dokumentów itp. Drugi blok zawiera informacje o zgłaszającym zestaw reklamacji lub niezgodności. Ostatni, trzeci blok zawiera szczegółowe informacje dotyczące reklamacji lub niezgodności należących do zestawu (oraz pole adnotacje, przeznaczone do wprowadzania dowolnych dodatkowych informacji). Informacje o zgłoszeniach ujętych w zestawie prezentowane są w formie specyfikacji zgłoszeń. Zakres informacji zawartych specyfikacji uzależniony jest od charakteru rejestrowanych zgłoszeń reklamacyjnych lub zgłoszeń niezgodności. Dany zestaw może zawierać wyłącznie zapisy jednego wariantu zgłoszeń reklamacyjnych lub niezgodności.
W programie NNR-Pro zgłoszenia reklamacyjne/niezgodności mogą być również rejestrowane pojedynczo (zobacz Rejestr zgłoszeń przychodzących - zgłoszenia). Warto wiedzieć, że pola edycyjne z pierwszego i drugiego bloku opisane etykietą o tej samej treści na formularzu przeznaczonym do edycji zestawów zgłoszeń i formularzach przeznaczonych do indywidualnej edycji zgłoszeń dotyczących reklamacji i zgłoszeń dotyczących niezgodności (tj. informujące o sposobie przekazania, numerach i datach dokumentów: RMA, NCR, listu przewozowego oraz identyfikujące zgłaszającego reklamację/niezgodność) są wspólne dla zestawu i zgłoszenia. Ich aktualizację można przeprowadzić zarówno podczas edycji informacji o poszczególnych zgłoszeniach zestawu jak i podczas edycji informacji ogólnych o zestawie. Wyjątkiem jest pole wskazujące osobę odpowiedzialną. Można wskazać osobę odpowiedzialną za cały zestaw i niezależnie osoby odpowiedzialne za każde ze zgłoszeń z zestawu. Na rysunkach przedstawiających dwie formy wyświetlania rejestru zgłoszeń przychodzących (zobacz Rejestr zgłoszeń przychodzących) pola opisujące identyczne informacje w każdej z form wyświetlania rejestru zgłoszeń przychodzących są otoczone czerwonym owalem o blado-czerwonym wypełnieniu lub należą do bloku, którego nazwa otoczona jest czerwonym owalem o blado-czerwonym wypełnieniu.
Podczas rejestracji zestawu zgłoszeń konieczne jest wskazanie nazwy albo wprowadzenie pełnej nazwy i adresu zgłaszającego reklamację/niezgodność (zależnie od wariantu zgłoszenia) oraz wprowadzenie przynajmniej jednego wpisu do specyfikacji zgłoszeń.
Program NNR-Pro automatycznie numeruje zestawy (a w ramach zastawu zgłoszenia) a także wprowadza datę rejestracji zestawu. Numery pojawiają się po zatwierdzeniu edycji (nadawanie numerów dopiero w chwili wprowadzenia zapisu do bazy danych, pozwala na uniknięcie luk w numeracji, występujących przy pracy wielostanowiskowej w sytuacji gdy na stanowisku, na którym operacja dopisania została wcześniej wywołana, ta operacja dopisania zostanie porzucona).
Dane zgłaszającego reklamację/niezgodność mogą być wprowadzone bezpośrednio na formularz lub wybrane z kartoteki kontrahentów). Dane te dodatkowo mogą być uzupełnione informacją, opisującą dane kontaktowe osoby wskazanej przez zgłaszającego reklamację/niezgodność w kontekście zarejestrowanego zestawu zgłoszeń.
Specyfikacja zgłoszeń umożliwia przeglądanie oraz edycję zgłoszeń przypisanych do zestawu
Menu podręczne tabeli (tj. wyświetlane po kliknięciu na tabeli prawym przyciskiem myszki) prezentującej specyfikację zgłoszeń umożliwia:

  • wprowadzenie zgłoszenia

    Dołącza do zestawu kolejne zgłoszenie. Edycja informacji przeprowadzana jest bezpośrednio w wierszu tabeli, za wyjątkiem sytuacji w których menu podręczne tabeli nie zawiera polecenia „Wprowadzenie zgłoszenia poprzez formularz”. Wówczas edycja informacji zawsze przeprowadzana jest na oddzielnym formularzu.

  • wprowadzenie zgłoszenia poprzez formularz

    Dołącza do zestawu kolejne zgłoszenie. Edycja informacji przeprowadzana jest na oddzielnym formularzu dedykowanym dla danego wariantu zgłoszeń.

  • poprawienie zgłoszenia

    Umożliwia edycję informacji o zgłoszeniu. Edycja informacji przeprowadzana jest bezpośrednio w wierszu tabeli, za wyjątkiem sytuacji w których menu podręczne tabeli nie zawiera polecenia „Poprawienie zgłoszenia poprzez formularz”. Wówczas edycja informacji zawsze przeprowadzana jest na oddzielnym formularzu.

  • poprawienie zgłoszenia poprzez formularz

    Umożliwia edycję informacji o zgłoszeniu. Edycja informacji przeprowadzana jest na oddzielnym formularzu dedykowanym dla danego wariantu zgłoszeń.

  • anulowanie zgłoszenia

    Anuluje zgłoszenie. Dla anulowanego zgłoszenia przestaje być dostępna operacja edycji informacji o zgłoszeniu. Operacji anulowania nie można wycofać.

  • przygotowanie zgłoszenia do dostawcy/serwisu

    „Przekierowuje” otrzymane zgłoszenie reklamacyjne do dostawcy towaru lub usługi (kooperanta) albo serwisu. Polecenie umożliwia przygotowanie zgłoszenia reklamacyjnego do dostawcy lub serwisu. Zgłoszenie zostanie odnotowane w dzienniku zgłoszeń wychodzących.

  • zamknięcie zgłoszenia

    Zamknięcie zgłoszenia reklamacji/niezgodności powoduje, że dany zapis przestaje być dostępny do dalszej edycji. Operacji zamknięcia nie można wycofać. Zamknięcie ustawia datę zamknięcia zgłoszenia. Operacja zamknięcia nie jest dostępna, jeśli nie podjęto decyzji dotyczącej nieuznania bądź uznania i sposobu zaspokojenia roszczenia reklamacyjnego. Po zamknięciu zgłoszenia, do czasu zamknięcia rozliczenia dotyczącego tego zgłoszenia, możliwe jest uaktualnianie informacji zamieszczonych na zakładce /Zestawienie kosztów/ formularza dedykowanego danemu wariantowi zgłoszenia.

  • zatwierdzenie rozliczenia

    Operacja jest dostępna tylko dla zgłoszeń, które zostały zamknięte lecz nie zostały jeszcze rozliczone i umożliwia zatwierdzenie (uznanie) rozliczenia. Operacji zatwierdzenia rozliczenia nie można wycofać. Przed zatwierdzeniem rozliczenia można wprowadzić bądź zaktualizować informacje dotyczące kosztów związanych z rozpatrzeniem (usunięciem skutków) reklamacji, daty rozliczenia, numeru noty obciążeniowej oraz danych sprawcy uchybienia.

  • wyświetlenie szczegółów zgłoszenia

    Wyświetla formularz zawierający szczegółowe dane dotyczące zgłoszenia.

  • wydruki dokumentów

    Operacja pozwala na wydrukowanie dokumentów związanych ze zgłoszeniem, które jest aktualnie wyróżnione w specyfikacji zgłoszeń. Jeśli przed wykonaniem wydruku ma być wyświetlony podgląd wydruku, polecenie należy wybrać przytrzymując naciśnięty klawisz [Shift].
    Aktywne formy wydruku dokumentów zależą od wariantu zgłoszenia. Przykładowo wydruk raportu 8D jest możliwy tylko dla zgłoszeń dotyczących niezgodności (dla których jako sposób rozwiązania wskazano „zespołowo, metodą 8D”), wydruk karty reklamacji jest możliwy tylko dla zgłoszeń dotyczących reklamacji wadliwego towaru.
Jeśli wprowadzenie lub poprawienie zgłoszenia nie jest możliwe bezpośrednio w wierszu tabeli a jedynie poprzez formularz (to czy możliwa jest edycja w wierszu tabeli zależy od wariantu zgłoszeń reklamacyjnych lub niezgodności rejestrowanych w zestawie), menu podręczne zawiera tylko jedno z pary poleceń związanych z edycją, zawsze wywołujące edycję poprzez formularz.


Rejestr zgłoszeń przychodzących - zgłoszenia

Ta forma wyświetlania rejestru zgłoszeń przychodzących umożliwia przyglądanie zgłoszeń bez podziału na zestawy, do których zgłoszenie zostało przypisane. Każde zgłoszenie zawsze przypisane jest do konkretnego zestawu zgłoszeń (gdy do rejestru wprowadzone zostanie pojedyncze zgłoszenie, program NNR-Pro utworzy nowy zestaw i dołączy do niego wprowadzone zgłoszenie). Tak więc dla tej formy wyświetlania rejestru zgłoszeń przychodzących, wprowadzenie nowego zapisu do rejestru każdorazowo tworzy kolejny zestaw, do którego przypisuje wprowadzony zapis. Jeśli chcemy, by zestaw zawierał więcej niż jedno zgłoszenie, należy zmienić formę wyświetlania rejestru zgłoszeń przychodzących z listy zgłoszeń na wyświetlanie listy zestawów zgłoszeń.
Lista zgłoszeń oprócz standardowych operacji edycyjnych związanych z wprowadzeniem, poprawieniem oraz anulowaniem zapisu, udostępnia dodatkowe operacje takie jak:

  • przygotowanie zgłoszenia do dostawcy/serwisu

    „Przekierowuje” otrzymane zgłoszenie reklamacyjne do dostawcy towaru lub usługi (kooperanta) albo serwisu. Polecenie umożliwia przygotowanie zgłoszenia reklamacyjnego do dostawcy lub serwisu. Zgłoszenie zostanie odnotowane w dzienniku zgłoszeń wychodzących.

  • zamknięcie zgłoszenia

    Zamknięcie zgłoszenia reklamacji/niezgodności powoduje, że dany zapis przestaje być dostępny do dalszej edycji. Operacji zamknięcia nie można wycofać. Zamknięcie ustawia datę rozpatrzenia zgłoszenia. Operacja zamknięcia nie jest dostępna, jeśli nie podjęto decyzji dotyczącej nieuznania bądź uznania i sposobu zaspokojenia roszczenia reklamacyjnego. Po zamknięciu zgłoszenia, do czasu zamknięcia rozliczenia dotyczącego tego zgłoszenia, możliwe jest uaktualnianie informacji zamieszczonych na zakładce /Zestawienie kosztów/ formularza dedykowanego danemu wariantowi zgłoszenia.

  • zatwierdzenie rozliczenia

    Operacja jest dostępna tylko dla zgłoszeń, które zostały zamknięte lecz nie zostały jeszcze rozliczone i umożliwia zatwierdzenie (uznanie) rozliczenia. Operacji zatwierdzenia rozliczenia nie można wycofać. Przed zatwierdzeniem rozliczenia można wprowadzić bądź zaktualizować informacje dotyczące kosztów związanych z rozpatrzeniem (usunięciem skutków) reklamacji, daty rozliczenia, numeru noty obciążeniowej oraz danych sprawcy uchybienia.
a także dodatkowe operacje nieedycyjne takie jak:

  • wybierz wariant zapisów

    Umożliwia wyselekcjonowania zapisów dotyczących wybranych sposobów rejestracji zgłoszeń a co za tym idzie np. wyświetlenia a następnie wydrukowania osobnych rejestrów dotyczących niezgodności zewnętrznych i niezgodności wewnętrznych, niezgodności wykrytych podczas audytu Systemu Zarządzania Jakością albo audytu procesu itp.. Warunki selekcji można swobodnie ustalać, co pozwala na np. uzyskanie wydruków rejestru zgłoszeń przychodzących odpowiadających bieżącym potrzebom (przykładowo wynikającym z konieczności udokumentowania spełnienia wymagań opisanych w Księdze jakości lub ogólniej, wymagań Normy ISO 9001).

  • raporty - analiza danych

    Polecenie wyświetla okno wyboru raportu, który ma być wygenerowany (zobacz Raporty - analiza danych).

  • zobacz podgląd wydruku rejestru

    Wyświetla podgląd wydruku rejestru. Podczas wyświetlania podglądu, można wywołać operację wydruku. Wykonanie wydruku poprzedza wybór ustawień wydruku, umożliwiający zmianę ustawień aktywnej drukarki. Przed wykonaniem wydruku można też określić numery stron jakie mają być wydrukowane.

  • drukuj rejestr

    Drukuje rejestr zgłoszeń przychodzących. Wykonanie wydruku poprzedza wybór ustawień wydruku umożliwiający zmianę ustawień aktywnej drukarki oraz określenie charakteru operacji wydruku i jej parametrów. By ograniczyć wydruk tylko do wybranych stron należy wywołać operację podglądu wydruku - tylko wywołanie operacji wydruku podczas wyświetlania podglądu wydruku umożliwia określenie numerów stron jakie mają być wydrukowane.

  • wydruki dokumentów

    Pozwala na wydrukowanie dokumentów związanych ze zgłoszeniem, które jest aktualnie wyróżnione w rejestrze. Jeśli przed wykonaniem wydruku ma być wyświetlony podgląd wydruku, polecenie należy wybrać przytrzymując naciśnięty klawisz [Shift].
    Aktywne formy wydruku dokumentów zależą od wariantu zgłoszenia. Przykładowo wydruk raportu 8D jest możliwy tylko dla zgłoszeń dotyczących niezgodności (dla których jako sposób rozwiązania wskazano „zespołowo, metodą 8D”), wydruk karty reklamacji jest możliwy tylko dla zgłoszeń dotyczących reklamacji wadliwego towaru.
W tabeli rejestru zgłoszeń przychodzących informacja o statusie zgłoszenia wyświetlana jest na tle w kolorze przypisanym aktualnej wartości statusu zgłoszenia. Są to kolory w odcieniach:
  • żółtym dla nieprzeterminowanych zgłoszeń nierozpoczętych lub w trakcie realizacji,
  • czerwonym dla przeterminowanych zgłoszeń nierozpoczętych lub w trakcie realizacji,
  • zielonym dla zgłoszeń zrealizowanych,
  • niebieskim dla zgłoszeń zamkniętych (tylko jeśli operacja rozliczenia jest dostępna - gdy operacja rozliczenia nie jest dostępna, kolor tła jest taki jak kolor tła tabeli).
Dla zgłoszeń anulowanych oraz rozliczonych kolor tła jest taki jak kolor tła tabeli (standardowo biały).
Dla zapisów rejestru, którym wkrótce upłynie termin realizacji, odcień koloru tła wiersza tabeli zmienia się wraz ze zbliżaniem się terminu realizacji od żółtego do czerwonego. Moment rozpoczęcia sygnalizacji zbliżania się terminu realizacji zależy od priorytetu zgłoszenia. W parametrach programu zdefiniowane są liczby dni sygnalizacji zbliżania się terminu w zależności od priorytetu zgłoszenia (zdarzenia).
Zobacz też: Rejestr zgłoszeń przychodzących (informacje ogólne) oraz warianty zgłoszeń reklamacyjnych (Zwyczajowa forma dokumentowania) lub niezgodności (Forma dokumentowania przystosowana do wymagań Normy ISO 9001)


Zwyczajowa forma dokumentowania

Zwyczajowa forma dokumentowania działań związanych z procesem reklamacji ogranicza zakres przetwarzanych w programie NNR-Pro informacji, do informacji dotyczących bezpośrednio rozpatrzenia reklamacji. Jeśli w programie NNR-Pro dodatkowo mają być gromadzone (i przetwarzane) informacje związane z innymi działaniami wynikającymi ze zgłoszonej reklamacji a dotyczącymi np. sposobu przeciwdziałania ponownemu wystąpieniu defektu (wady), należy zastosować alternatywną formę dokumentowania tj. formę dokumentowania przystosowaną do wymagań Normy ISO 9001.
Do dokumentowania zgłoszenia reklamacyjnego można wykorzystać uniwersalny formularz reklamacji wadliwego towaru. Jeśli charakter reklamacji odpowiada specyfice jednego z wymienionych poniżej wariantów, należy posłużyć się formularzem reklamacji dla tego wariantu. Aktualnie dokumentacja działań może odnosić się jednego z wymienionych poniżej, specyficznych wariantów zgłoszeń reklamacyjnych:
  • reklamacji wadliwego towaru u partnera handlowego,
  • zgłoszenia błędu w oprogramowaniu.
Lista wariantów nie jest zamknięta i może być rozbudowana o nowe warianty.


Reklamacja wadliwego towaru

Jest to standardowy formularz przeznaczony do rejestracji (w formie zwyczajowej) zgłoszeń dotyczących reklamacji klientów (wariant ogólny). Program NNR-Pro udostępnia także inne formularze rejestracji zgłoszeń dla zwyczajowej formy dokumentowania działań związanych z procesem rozpatrzenia reklamacji tj.:
  • formularz reklamacji wadliwego towaru u partnera handlowego,
  • formularz zgłoszenia błędu w oprogramowaniu.
Lista wariantów nie jest zamknięta i może być rozbudowana o nowe warianty.
Jeśli w programie NNR-Pro mają być przetwarzanie nie tylko informacje związane bezpośrednio z rozpatrzeniem reklamacji ale również inne działania wynikające ze zgłoszonej reklamacji a dotyczące np. sposobu przeciwdziałania ponownemu wystąpieniu defektu (wady), należy zastosować alternatywną do zwyczajowej formę dokumentowania tj. formę przystosowaną do wymagań Normy ISO 9001.
Informacje o zgłoszeniu podzielone są na 3 bloki. Pierwszy blok zawiera dane ogólne dotyczące zgłoszenia takie jak numer i data zgłoszenia, termin i data rozpatrzenia, oznaczenia dokumentów itp. Drugi blok zawiera informacje o zgłaszającym reklamację tj. kliencie, który przekazał zgłoszenia reklamacyjne. Ostatni, trzeci blok zawiera szczegółowe informacje dotyczące reklamacji w tym np. numer i datę dokumentu sprzedaży, nazwę reklamowanego towaru, reklamowaną ilość i jednostkę miary.
W programie NNR-Pro zgłoszenia reklamacyjne mogą być rejestrowane zarówno w zestawach jak i pojedynczo. W wariancie ogólnym raczej nie korzysta się z opcji rejestracji zestawów zgłoszeń reklamacyjnych (najczęściej klient zgłasza reklamację pojedynczego towaru). Tym niemniej warto wiedzieć, że pola edycyjne z pierwszego i drugiego bloku opisane etykietą o tej samej treści na opisywanym formularzu i ogólnym formularzu przeznaczonym do edycji zestawów zgłoszeń przychodzących (tj. informujące o sposobie przekazania, numerach i datach dokumentów: RMA, NCR, listu przewozowego oraz identyfikujące zgłaszającego reklamację) są wspólne dla zestawu i zgłoszenia. Ich aktualizację można przeprowadzić zarówno podczas edycji informacji o poszczególnych zgłoszeniach zestawu jak i podczas edycji informacji ogólnych o zestawie. Wyjątkiem jest pole wskazujące osobę odpowiedzialną. Można wskazać osobę odpowiedzialną za cały zestaw i niezależnie osoby odpowiedzialne za każde ze zgłoszeń z zestawu. Na rysunkach przedstawiających dwie formy wyświetlania rejestru zgłoszeń przychodzących (zobacz Rejestr zgłoszeń przychodzących) pola opisujące identyczne informacje w każdej z form wyświetlania rejestru zgłoszeń przychodzących są otoczone czerwonym owalem o blado-czerwonym wypełnieniu lub należą do bloku, którego nazwa otoczona jest czerwonym owalem o blado-czerwonym wypełnieniu.
Podczas rejestracji zgłoszenia reklamacyjnego konieczne jest wprowadzenie pełnej nazwy i adresu klienta oraz wskazanie reklamowanego towaru na liście towarów (w zależności od pola - indeks towaru lub nazwa towaru - z którego wywołana zostanie operacja wyświetlenia listy towarów, towary na liście będą uporządkowane zgodnie z kolejnością alfabetyczną indeksów lub nazw towarów).
Program NNR-Pro automatycznie numeruje zestawy i zgłoszenia a także wprowadza daty rejestracji zestawu oraz zgłoszenia. Numery pojawiają się po zatwierdzeniu edycji (nadawanie numerów dopiero w chwili wprowadzenia zapisu do bazy danych, pozwala na uniknięcie luk w numeracji, występujących przy pracy wielostanowiskowej w sytuacji gdy na stanowisku, na którym operacja dopisania została wcześniej wywołana, ta operacja dopisania zostanie porzucona). Jako data terminu rozpatrzenia zgłoszenia podpowiadana jest data wyznaczona z daty zgłoszenia i standardowej liczby dni rozpatrzenia zgłoszenia określonej parametrem programu NNR-Pro o identycznej nazwie.
Dane zgłaszającego reklamację (klienta) mogą być wprowadzone bezpośrednio na formularz lub wybrane z kartoteki kontrahentów). Dane te dodatkowo mogą być uzupełnione informacją, opisującą dane kontaktowe osoby wskazanej przez klienta w kontekście zarejestrowanego zgłoszenia reklamacyjnego.
Domyślnie przyjmowana jest jako ilość reklamowana jedna jednostka miary reklamowanego towaru.
O ile istnieje taka konieczność można wprowadzić informacje o dacie i numerze dokumentu sprzedaży. Można też określić miejsce sprzedaży tj. wskazać w kartotece kontrahentów dane sklepu, w którym klient kupił reklamowany towar.
W polu informacji dodatkowych można wprowadzić informacje identyfikujące np. model, nr seryjny, nr partii towaru.
Mimo, że wskazanie nazwy defektu w katalogu defektów nie jest wymagane, warto taką informację rejestrować chociażby dla celów analizy zgłoszeń.
Każde nowe zgłoszenie otrzymuje status informujący o tym, że żadne działania dotyczące rozpatrzenia zgłoszenia reklamacyjnego nie zostały podjęte. Zmiana statusu początkowo odbywa się automatycznie. Po zakończeniu operacji dopisania zgłoszenia reklamacyjnego nadawany jest mu status informujący, że zgłoszenie jest w trakcie realizacji. Wskazanie decyzji co do zgłoszenia reklamacyjnego, spowoduje że program NNR-Pro uzna zgłoszenie reklamacyjne za zrealizowane - wycofanie decyzji przywraca poprzedni status zgłoszenia. Poprzez polecenia menu, zgłoszenia zrealizowane dodatkowo mogą mieć zmieniony status na informujący o zamknięciu zgłoszenia a zgłoszenia zamknięte mogą mieć zmieniony status na informujący o rozliczeniu zgłoszenia.
By wizualnie wyróżnić informację o statusie zgłoszenia, jest ona wyświetlana na tle w kolorze przyporządkowanym na stałe do danego statusu.


Reklamacja wadliwego towaru u partnera handlowego

Formularz przeznaczony jest do rejestracji zgłoszeń dotyczących reklamacji klientów, otrzymanych od partnera handlowego (tj. dostarczonych z punktu sprzedaży).
Najczęściej partner handlowy nie przesyła oddzielnie zgłoszeń każdego z klientów, lecz w jednej przesyłce ujmuje więcej niż jedno zgłoszenie reklamacyjne. Jeśli w programie NNR-Pro ma być zachowana specyfika takiej metody przekazywania zgłoszeń, rejestrację zgłoszeń z przesyłki należy rozpocząć od utworzenia zestawu, a następnie należy dołączyć do zestawu wszystkie zgłoszenia z danej przesyłki. Operacja utworzenia zestawu zgłoszeń dostępna jest podczas wyświetlania rejestru zgłoszeń przychodzących w postaci listy zestawów zgłoszeń. W alternatywnej opcji wyświetlania rejestru zgłoszeń przychodzących w postaci listy zgłoszeń, wprowadzane kolejne zapisy dotyczące zgłoszeń, nie będą ze sobą powiązane.
Informacje o zgłoszeniu podzielone są na 3 bloki. Pierwszy blok zawiera dane ogólne dotyczące zgłoszenia takie jak numer i data zgłoszenia, termin i data rozpatrzenia, oznaczenia dokumentów itp. Drugi blok zawiera informacje o zgłaszającym reklamację tj. partnerze handlowym, który przekazał zgłoszenia reklamacyjne klientów. Ostatni, trzeci blok zawiera szczegółowe informacje dotyczące reklamacji klienta w tym np. numer i datę przyjęcia reklamacji klienta przez partnera handlowego (sklep), nazwę reklamowanego towaru, reklamowaną ilość i jednostkę miary.
Pola edycyjne z pierwszego i drugiego bloku opisane etykietą o tej samej treści na opisywanym formularzu i ogólnym formularzu przeznaczonym do edycji zestawów zgłoszeń przychodzących (tj. informujące o sposobie przekazania, numerach i datach dokumentów: RMA, NCR, listu przewozowego oraz identyfikujące zgłaszającego reklamację) są wspólne dla zestawu i zgłoszenia. Ich aktualizację można przeprowadzić zarówno podczas edycji informacji o poszczególnych zgłoszeniach zestawu jak i podczas edycji informacji ogólnych o zestawie. Wyjątkiem jest pole wskazujące osobę odpowiedzialną. Można wskazać osobę odpowiedzialną za cały zestaw i niezależnie osoby odpowiedzialne za każde ze zgłoszeń z zestawu. Na rysunkach przedstawiających dwie formy wyświetlania rejestru zgłoszeń przychodzących (zobacz Rejestr zgłoszeń przychodzących) pola opisujące identyczne informacje w każdej z form wyświetlania rejestru zgłoszeń przychodzących są otoczone czerwonym owalem o blado-czerwonym wypełnieniu lub należą do bloku, którego nazwa otoczona jest czerwonym owalem o blado-czerwonym wypełnieniu.
Podczas rejestracji zgłoszenia reklamacyjnego konieczne jest wskazanie danych partnera handlowego (o ile te dane nie zostały wskazane podczas rejestracji innego zgłoszenia z danego zestawu), podanie numeru reklamacji klienta oraz wskazanie reklamowanego towaru na liście towarów (w zależności od pola - indeks towaru lub nazwa towaru - z którego wywołana zostanie operacja wyświetlenia listy towarów, towary na liście będą uporządkowane zgodnie z kolejnością alfabetyczną indeksów lub nazw towarów).
Program NNR-Pro automatycznie numeruje zestawy i zgłoszenia a także wprowadza daty rejestracji zestawu oraz zgłoszenia. Numery pojawiają się po zatwierdzeniu edycji (nadawanie numerów dopiero w chwili wprowadzenia zapisu do bazy danych, pozwala na uniknięcie luk w numeracji, występujących przy pracy wielostanowiskowej w sytuacji gdy na stanowisku, na którym operacja dopisania została wcześniej wywołana, ta operacja dopisania zostanie porzucona). Jako data terminu rozpatrzenia zgłoszenia podpowiadana jest data wyznaczona z daty zgłoszenia i standardowej liczby dni rozpatrzenia zgłoszenia określonej parametrem programu NNR-Pro o identycznej nazwie.
Dane zgłaszającego reklamację (partnera handlowego) wybiera się z kartoteki kontrahentów. Dodatkowo mogą być one uzupełnione informacją, opisującą dane kontaktowe osoby powiązanej ze zgłoszeniem reklamacyjnym.
Domyślnie przyjmowana jest jako ilość reklamowana jedna jednostka miary reklamowanego towaru.
Ze względów formalnych (związanych z ustawowym okresem rozpatrzenia reklamacji klienta) zalecane jest wprowadzenie daty przyjęcia reklamacji klienta przez partnera handlowego (daty przyjęcia do sklepu), jednak program NNR-Pro nie wymusza wprowadzenia tej daty.
W polu informacji dodatkowych można wprowadzić informacje identyfikujące np. model, nr seryjny, nr partii towaru.
Mimo, że wskazanie nazwy defektu w katalogu defektów nie jest wymagane, warto taką informację rejestrować chociażby dla celów analizy zgłoszeń.
Każde nowe zgłoszenie otrzymuje status informujący o tym, że żadne działania dotyczące rozpatrzenia zgłoszenia reklamacyjnego nie zostały podjęte. Zmiana statusu początkowo odbywa się automatycznie. Po zakończeniu operacji dopisania zgłoszenia reklamacyjnego nadawany jest mu status informujący, że zgłoszenie jest w trakcie realizacji. Wskazanie decyzji co do zgłoszenia reklamacyjnego, spowoduje że program NNR-Pro uzna zgłoszenie reklamacyjne za zrealizowane - wycofanie decyzji przywraca poprzedni status zgłoszenia. Poprzez polecenia menu, zgłoszenia zrealizowane dodatkowo mogą mieć zmieniony status na informujący o zamknięciu zgłoszenia a zgłoszenia zamknięte mogą mieć zmieniony status na informujący o rozliczeniu zgłoszenia. By wizualnie wyróżnić informację o statusie zgłoszenia, jest ona wyświetlana na tle w kolorze przyporządkowanym na stałe do danego statusu.


Zgłoszenie błędu w oprogramowaniu

Formularz przeznaczony jest do rejestracji zgłoszeń dotyczących błędów w oprogramowaniu, Przy pomocy formularza można również rejestrować propozycje klientów (użytkowników oprogramowania) dotyczące rozbudowy funkcjonalności oprogramowania.
Informacje o zgłoszeniu podzielone są na 3 bloki. Pierwszy blok zawiera dane ogólne dotyczące zgłoszenia takie jak numer i data zgłoszenia, termin i data rozpatrzenia, oznaczenia dokumentów itp. Drugi blok zawiera informacje o zgłaszającym reklamację tj. kliencie, który przekazał zgłoszenia reklamacyjne (zgłosił błąd w oprogramowaniu). Ostatni, trzeci blok zawiera szczegółowe informacje dotyczące błędu w tym np. nazwę i wersję oprogramowania, opis środowiska pracy, dane osoby która odnotowała błąd.
W programie NNR-Pro zgłoszenia reklamacyjne mogą być rejestrowane zarówno w zestawach jak i pojedynczo. Warto wiedzieć, że pola edycyjne z pierwszego i drugiego bloku opisane etykietą o tej samej treści na opisywanym formularzu i ogólnym formularzu przeznaczonym do edycji zestawów zgłoszeń przychodzących (tj. informujące o sposobie przekazania, numerach i datach dokumentów oraz identyfikujące klienta zgłaszającego reklamację) są wspólne dla zestawu i zgłoszenia. Ich aktualizację można przeprowadzić zarówno podczas edycji informacji o poszczególnych zgłoszeniach zestawu jak i podczas edycji informacji ogólnych o zestawie. Wyjątkiem jest pole wskazujące osobę odpowiedzialną. Można wskazać osobę odpowiedzialną za cały zestaw i niezależnie osoby odpowiedzialne za każde ze zgłoszeń z zestawu. Na rysunkach przedstawiających dwie formy wyświetlania rejestru zgłoszeń przychodzących (zobacz Rejestr zgłoszeń przychodzących) pola opisujące identyczne informacje w każdej z form wyświetlania rejestru zgłoszeń przychodzących są otoczone czerwonym owalem o blado-czerwonym wypełnieniu lub należą do bloku, którego nazwa otoczona jest czerwonym owalem o blado-czerwonym wypełnieniu.
Podczas rejestracji zgłoszenia reklamacyjnego konieczne jest wprowadzenie pełnej nazwy i adresu klienta, wskazanie nazwy oprogramowania (reklamowanego towaru) na liście towarów (jako nazwa oprogramowania przyjmowana jest informacja opisująca indeks towaru) i wprowadzenie numeru wersji, sklasyfikowanie błędu pod kątem skutków oraz wprowadzenie danych osoby która odnotowała błąd. W celu ułatwienia umiejscowienia błędu w oprogramowaniu zaleca się również opisanie kroków niezbędnych do powtórzenia błędu. Jednak ponieważ nie zawsze zgłaszający błąd potrafi jednoznacznie opisać działania jakie wykonywał tuż przed sygnalizacją błędu, opisanie kroków niezbędnych do powtórzenia błędu nie jest wymagane do zarejestrowania zgłoszenia. Ponadto jeśli rejestrowane są informacje dotyczące błędu w działaniu oprogramowania lub propozycje zmiany działania oprogramowania, warto również opisać rzeczywisty i spodziewany efekt działania oprogramowania a w przypadku rejestracji propozycji dotyczących rozbudowy oprogramowania wskazane jest odnotowanie informacji opisujących spodziewany efekt działania oprogramowania.
W przypadku rejestracji kolejnego zgłoszenia z zestawu zgłoszeń, dla nowego zgłoszenia podpowiadane są informacje ze zgłoszenia które było wyróżnione w zestawie przed rozpoczęciem operacji dopisania a opisujące: nazwę i wersję oprogramowania, termin rozpatrzenia oraz dane osoby, która odnotowała błąd.
Program NNR-Pro automatycznie numeruje zestawy i zgłoszenia a także wprowadza daty rejestracji zestawu oraz zgłoszenia. Numery pojawiają się po zatwierdzeniu edycji (nadawanie numerów dopiero w chwili wprowadzenia zapisu do bazy danych, pozwala na uniknięcie luk w numeracji, występujących przy pracy wielostanowiskowej w sytuacji gdy na stanowisku, na którym operacja dopisania została wcześniej wywołana, ta operacja dopisania zostanie porzucona).
Dane klienta zgłaszającego błąd mogą być wprowadzone bezpośrednio na formularz lub wybrane z kartoteki kontrahentów). Dane te dodatkowo mogą być uzupełnione informacją, opisującą dane kontaktowe osoby wskazanej przez klienta w kontekście zarejestrowanego zgłoszenia reklamacyjnego.
Opisując środowisko pracy, szczególne w przypadku błędów krytycznych, warto podać nazwę i wersję systemu operacyjnego, rodzaj procesora, wielkość pamięci RAM, wielkość oraz wolne miejsce na dysku twardym, parametry karty graficznej (rozdzielczość), parametry karty sieciowej (prędkość), itp. Ponieważ oprogramowanie bazodanowe może korzystać z różnych serwerów (silników) zalecane jest także podanie nazwy i wersji serwera.
Mimo, że wskazanie nazwy błędu (defektu) w katalogu defektów nie jest wymagane, warto taką informację rejestrować chociażby dla celów analizy zgłoszeń. Ponadto po wskazaniu nazwy błędu (defektu), pole klasyfikacji błędu zostanie wypełnione zgodnie z informacją o kategorii defektu, przypisaną dla tego błędu (defektu). Treść pola klasyfikacji błędu można zmienić tylko, jeśli pole nazwy błędu jest puste.
Każde nowe zgłoszenie otrzymuje status informujący o tym, że żadne działania dotyczące rozpatrzenia zgłoszenia reklamacyjnego nie zostały podjęte. Zmiana statusu początkowo odbywa się automatycznie. Wprowadzenie opisu działania do tabeli z zakładki /Rozwiązanie problemu/, zmienia status na informujący o tym, że zgłoszenie jest w trakcie realizacji. Wskazanie decyzji co do zgłoszenia reklamacyjnego, spowoduje że program NNR-Pro uzna zgłoszenie reklamacyjne za zrealizowane - wycofanie decyzji przywraca status zgłoszenia informujący o tym, że zgłoszenie jest w trakcie realizacji. Poprzez polecenia menu, zgłoszenia zrealizowane dodatkowo mogą mieć zmieniony status na informujący o zamknięciu zgłoszenia a zgłoszenia zamknięte mogą mieć zmieniony status na informujący o rozliczeniu zgłoszenia. By wizualnie wyróżnić informację o statusie zgłoszenia, jest ona wyświetlana na tle w kolorze przyporządkowanym na stałe do danego statusu.
Program NNR-Pro, prezentuje informacje o działaniach prowadzących do rozwiązania problemu w formie tabeli. Edycja informacji o działaniach przeprowadzana jest na osobnym formularzu.
Menu podręczne tabeli (tj. wyświetlane po kliknięciu na tabeli prawym przyciskiem myszki) umożliwia:

  • wprowadzenie wpisu

    Dla każdego wpisu musi być wprowadzony opis działania. Alternatywnie można wprowadzić opis działania poufny (np. ze względu na ochronę informacji stanowiących „know-how” firmy) - opis działania poufny nie pojawia się na wydrukach oraz określić termin wprowadzenia i planowany koszt. Nowemu działaniu można nadać status działania planowanego lub wykonywanego (domyślnie działanie otrzymuje status działania planowanego). Tylko działania planowane mogą być usunięte. Ponadto działania planowane mogą być rozpoczęte lub jeśli nie zostały zaakceptowane - odrzucone. Działania wykonywane mogą być uznane za wprowadzone lub odrzucone (anulowane).

  • poprawienie wpisu

    Działania planowane lub wykonywane mogą mieć poprawione informacje o opisie działania, opisie działania poufnym, terminie wprowadzenia oraz planowanym koszcie. Ponadto działania planowane mogą mieć zmieniony status na informujący o tym, że działanie jest wykonywane.
    Działania wprowadzone (wdrożone) mogą mieć poprawione informacje o dacie i godzinie wprowadzenia, numerze i dacie raportu z wprowadzenia (wdrożenia) oraz wysokości rzeczywistych kosztów.
    Dla działań odrzuconych, zarówno niezaakceptowanych jak i anulowanych, można poprawić informację o powodzie odrzucenia.

  • usunięcie wpisu

    Usuwa planowane działanie.

  • przygotowanie zgłoszenia do dostawcy/serwisu

    Jeśli wykonanie działania wymaga przeprowadzenia czynności przez podmiot zewnętrzny (np. dostawcę bibliotek komponentów, podwykonawcę funkcjonalności, itp.), polecenie umożliwia przygotowanie takiego zgłoszenia. Zgłoszenie zostanie odnotowane w dzienniku zgłoszeń wychodzących.

  • odrzucenie niezaakceptowanego działania

    Odwołuje planowane działanie. Działanie otrzymuje status działania odrzuconego. Dla odrzuconego działania można wskazać powód odrzucenia.

  • rozpoczęcie działania

    Rozpoczyna planowane działanie (identyczny efekt uzyska się zmieniając podczas operacji poprawienia wpisu, status działania planowanego na działanie wykonywane). Dla rozpoczynanego działania można poprawić informacje o opisie działania, opisie działania poufnym, terminie wprowadzenia oraz planowanym koszcie.

  • wprowadzenie (wdrożenie) działania

    Kończy proces wdrożenia wykonywanego działania. Działanie otrzymuje status działania wprowadzonego. Dla wprowadzonego działania można podać datę i godzinę wprowadzenia (zakończenia wdrożenia) a także wskazać numer i datę raportu (dokumentu) potwierdzającego wykonanie np. raportu z testów. Można też wprowadzić informację o rzeczywistym koszcie wprowadzenia.

  • unieważnienie rozpoczętego działania

    Odwołuje działanie wykonywane. Działanie otrzymuje status działania unieważnionego. Dla unieważnionego działania można wskazać powód odrzucenia.

  • wyświetlenie szczegółów

    Wyświetla formularz zawierający szczegółowe dane dotyczące działania.
W programie NNR-Pro można zarejestrować każde potencjalne działanie. Nowe działanie otrzyma domyślnie status działania planowanego. Po zweryfikowaniu można mu nadać status działania wykonywanego, wybierając z menu podręcznego tabeli polecenie „Rozpoczęcie działania”. Planowanym działaniom, które nie będą wykonywane (nie zostały zaakceptowane) można nadać status działania odrzuconego, wybierając z menu podręcznego tabeli polecenie „Odrzucenie niezaakceptowanego działania” - alternatywnie można usunąć z tabeli informacje o takim działaniu. Jeśli proces wprowadzenia działania zostanie zakończony, można zmienić status działania na status działania wprowadzonego, wybierając z menu podręcznego tabeli polecenie „Wprowadzenie (wdrożenie) działania”. Jeśli już wykonywane działanie zostało odrzucone, można zmienić jego status na status działania unieważnionego, wybierając z menu podręcznego tabeli polecenie „Unieważnienie rozpoczętego działania”.
By odnieść działanie do dostawcy (kooperanta), należy wywołać z menu podręcznego tabeli polecenie „Przygotowanie zgłoszenia do dostawcy/serwisu”.


Forma dokumentowania przystosowana do wymagań Normy ISO 9001

Ta forma dokumentowania umożliwia nie tylko dokumentowanie działań związanych z rozpatrzeniem reklamacji, ale ogólnie wszystkich działań związanych z nadzorowaniem niezgodności wykrytych w systemie zarządzania jakością, zgodnie z wymaganiami Normy ISO 9001. Implikuje to szerszy zakres informacji gromadzonych (i przetwarzanych) w programie NNR-Pro w porównaniu ze zwyczajową formą dokumentowania działań związanych z procesem rozpatrzenia reklamacji.
W programie NNR-Pro zgłoszenia zostały podzielone na zgłoszenia dotyczące niezgodności zewnętrznych oraz zgłoszenia dotyczące niezgodności wewnętrznych. Najistotniejszą różnicą wynikającą z takiego podziału jest inna grupa klientów zgłaszających niezgodność, co w programie NNR-Pro objawia się udostępnieniem, do wyboru danych zgłaszającego niezgodność, kartoteki kontrahentów (klient zewnętrzny) lub listy działów (klient wewnętrzny). Ponieważ różnica pomiędzy formularzem dotyczącym niezgodności zewnętrznym i formularzem dotyczącym niezgodności wewnętrznym jest nieznaczna, poniżej opisane zostały informacje dotyczące obu formularzy z pominięciem różnic. Rożnie opisane zostały indywidualnie w sekcjach dokumentacji omawiających każdy z tych formularzy.
Informacje o zgłoszeniu podzielone są na 3 bloki. Pierwszy blok zawiera dane ogólne dotyczące zgłoszenia takie jak numer i data zgłoszenia, termin i data rozpatrzenia, oznaczenia dokumentów itp. Drugi blok zawiera informacje o zgłaszającym niezgodność tj. kliencie (zewnętrznym lub wewnętrznym), który przekazał zgłoszenie. Ostatni, trzeci blok zawiera szczegółowe informacje dotyczące niezgodności w tym np. numer i datę dokumentu wydania (dla niezgodności zewnętrznych) lub miejsce wykrycia (dla niezgodności wewnętrznych), nazwę reklamowanego towaru, reklamowaną ilość i jednostkę miary, nazwę defektu, opis symptomów/objawów.
W programie NNR-Pro zgłoszenia mogą być rejestrowane zarówno w zestawach jak i pojedynczo. Podczas rejestracji zgłoszeń dotyczących niezgodności raczej nie korzysta się z opcji rejestracji zestawów zgłoszeń (najczęściej klient zgłasza każdą niezgodność natychmiast po jej wykryciu, nie czekając na wykrycie kolejnej niezgodności). Tym niemniej warto wiedzieć, że pola edycyjne z pierwszego i drugiego bloku opisane etykietą o tej samej treści na opisywanym formularzu i ogólnym formularzu przeznaczonym do edycji zestawów zgłoszeń przychodzących (tj. informujące o sposobie przekazania, numerach i datach dokumentów: RMA, NCR, listu przewozowego oraz identyfikujące zgłaszającego niezgodność) są wspólne dla zestawu i zgłoszenia. Ich aktualizację można przeprowadzić zarówno podczas edycji informacji o poszczególnych zgłoszeniach zestawu jak i podczas edycji informacji ogólnych o zestawie. Wyjątkiem jest pole wskazujące osobę odpowiedzialną. Można wskazać osobę odpowiedzialną za cały zestaw i niezależnie osoby odpowiedzialne za każde ze zgłoszeń z zestawu.
Podczas rejestracji zgłoszenia zawsze wymagane jest wskazanie klienta zgłaszającego niezgodność (kontrahenta w kartotece kontrahentów lub działu na liście działów), wskazanie nazwy defektu w katalogu defektów oraz wybranie sposobu rozwiązania. W zależności od rodzaju niezgodności może być wymagane wprowadzenie innych informacji (zobacz sekcje dokumentacji omawiające: formularz dotyczący zgłoszeń zewnętrznych i formularz dotyczący zgłoszeń wewnętrznych).
Program NNR-Pro automatycznie numeruje zestawy i zgłoszenia a także wprowadza daty rejestracji zestawu oraz zgłoszenia. Numery pojawiają się po zatwierdzeniu edycji (nadawanie numerów dopiero w chwili wprowadzenia zapisu do bazy danych, pozwala na uniknięcie luk w numeracji, występujących przy pracy wielostanowiskowej w sytuacji gdy na stanowisku, na którym operacja dopisania została wcześniej wywołana, ta operacja dopisania zostanie porzucona). Jako data terminu rozpatrzenia zgłoszenia podpowiadana jest data wyznaczona z daty zgłoszenia i standardowej liczby dni rozpatrzenia zgłoszenia określonej parametrem programu NNR-Pro o identycznej nazwie.
Dane zgłaszającego niezgodność (klienta) mogą być dodatkowo uzupełnione informacją, opisującą dane kontaktowe osoby wskazanej przez klienta w kontekście zarejestrowanego zgłoszenia niezgodności.
Program NNR-Pro pozwala zarówno na udokumentowanie rozwiązania problemu ustalonego indywidualnie przez pojedynczą osobę jak i rozwiązania problemu ustalonego zespołowo przez powołany wyłącznie w tym celu zespół osób (zarówno pracowników jak i osób z zewnątrz). Pierwszy ze sposobów rozwiązania problemu (indywidualnie), stosowany jest jeśli znana jest przyczyna problemu a problem w swoim zakresie wiąże się tylko z jedną osobą oraz nie wymaga specjalistycznych środków, specyficznej wiedzy i wsparcia kierownictwa. W pozostałych przypadkach jak również w sytuacji gdy wymaga tego waga i pilność, opracowanie rozwiązania powinno odbywać się zespołowo. Program NNR-Pro umożliwia opracowanie rozwiązania problemu metodą 8D.
Każde nowe zgłoszenie otrzymuje status informujący o tym, że żadne działania dotyczące rozpatrzenia zgłoszenia reklamacyjnego nie zostały podjęte. Zmiana statusu początkowo odbywa się automatycznie. Wprowadzenie opisu działania do tabeli z zakładki /Rozwiązanie problemu/, zmienia status na informujący o tym, że zgłoszenie jest w trakcie realizacji. Wskazanie decyzji co do zgłoszenia reklamacyjnego (kolejno: zakładka /Rozwiązanie problemu/, zakładka /D8 - Podsumowanie, uhonorowanie wysiłków zespołu/), spowoduje że program NNR-Pro uzna zgłoszenie reklamacyjne za zrealizowane - wycofanie decyzji przywraca status zgłoszenia informujący o tym, że zgłoszenie jest w trakcie realizacji. Poprzez polecenia menu, zgłoszenia zrealizowane dodatkowo mogą mieć zmieniony status na informujący o zamknięciu zgłoszenia a zgłoszenia zamknięte mogą mieć zmieniony status na informujący o rozliczeniu zgłoszenia.
By wizualnie wyróżnić informację o statusie zgłoszenia, jest ona wyświetlana na tle w kolorze przyporządkowanym na stałe do danego statusu.


Zgłoszenie niezgodności - zewnętrzne

Formularz przeznaczony jest do rejestracji zgłoszeń przekazanych przez klientów zewnętrznych (kontrahentów).
Na potrzeby rejestracji zgłoszeń przekazanych przez klientów wewnętrznych (działy) należy stosować formularz opisany w sekcji zatytułowanej „Zgłoszenie niezgodności - wewnętrzne”.
Ogólne informacje związane z formularzem opisane zostały w sekcji zatytułowanej „Forma dokumentowania przystosowana do wymagań Normy ISO 9001”
W przypadku rejestracji niezgodności zewnętrznych wymagane jest wskazanie danych kontrahenta oraz wskazanie reklamowanego towaru na liście towarów (w zależności od pola - indeks towaru lub nazwa towaru - z którego wywołana zostanie operacja wyświetlenia listy towarów, towary na liście będą uporządkowane zgodnie z kolejnością alfabetyczną indeksów lub nazw towarów), podanie informacji o ilości w dostawie i ilości reklamowanej, wskazanie nazwy defektu w katalogu defektów oraz wybranie sposobu rozwiązania. Warto również wprowadzić informację o numerze i data dokumentu wydania (sprzedaży) klientowi reklamowanego towaru, chociażby dla celów analizy zgłoszeń.
W polu informacji dodatkowych można wprowadzić informacje identyfikujące np. model, nr seryjny, nr partii towaru.
Zobacz też: metoda 8D (raport 8D)


Zgłoszenie niezgodności - wewnętrzne

Formularz przeznaczony jest do rejestracji zgłoszeń przekazanych przez klientów wewnętrznych (działy).
Na potrzeby rejestracji zgłoszeń przekazanych przez klientów zewnętrznych (kontrahentów) należy stosować formularz opisany w sekcji zatytułowanej „Zgłoszenie niezgodności - zewnętrzne”.
Ogólne informacje związane z formularzem opisane zostały w sekcji zatytułowanej „Forma dokumentowania przystosowana do wymagań Normy ISO 9001”
W przypadku rejestracji niezgodności wewnętrznych wymagane jest wskazanie nazwy działu, nazwy defektu oraz wybranie sposobu rozwiązania. Warto również wprowadzić informację o miejscu wykrycia (tj. nazwie działu, którego dotyczy rejestrowana niezgodność - niekoniecznie musi pokrywać się ona z nazwą działu, który zgłosił niezgodność), chociażby dla celów analizy zgłoszeń.
Gdy niezgodność rejestrowana jest na podstawie wystawionej karty braków, dodatkowo wymagane jest wskazanie towaru na liście towarów (w zależności od pola - indeks towaru lub nazwa towaru - z którego wywołana zostanie operacja wyświetlenia listy towarów, towary na liście będą uporządkowane zgodnie z kolejnością alfabetyczną indeksów lub nazw towarów) oraz podanie informacji o ilości sprawdzonej i ilości niezgodnej.
W polu informacji dodatkowych można wprowadzić informacje identyfikujące np. model, nr seryjny, nr partii towaru.
Zobacz też: metoda 8D (raport 8D)


Metoda 8D - Raport 8D

Metoda 8D (Raport 8D)

Opracowanie rozwiązania problemu metodą 8D (ang. eight disciplines problem solving) powinno być przeprowadzane w sytuacjach, w których nie jest znana przyczyna problemu, problem w swoim zakresie przekracza możliwości jednej osoby, wymaga specjalistycznych środków, specyficznej wiedzy lub wsparcia kierownictwa albo wymaga tego waga i pilność problemu. Opracowania i udokumentowania w postaci raportu 8D rozwiązania problemu, może też wymagać od dostawcy klient.
Koncepcją metody 8D jest prawidłowe zidentyfikowanie przyczyny problemu oraz zastosowanie takich działań, które zapobiegną ponownemu pojawieniu się problemu. Metoda 8D wykorzystuje efekt synergii i opiera się na wspólnej wiedzy, doświadczeniu oraz różnych punktach widzenia osób zaangażowanych w rozwiązanie problemu. Metoda 8D kładzie nacisk na wskazanie zarówno doraźnych rozwiązań problemu - tymczasowych działań powstrzymujących i natychmiastowych działań osłonowych, izolujących klienta od dalszych skutków problemu, jak i ustalenie przyczyn źródłowych, a następnie określenie trwałych działań korekcyjnych i działań zapobiegawczych umożliwiających definitywne wyeliminowanie problemu. Metoda 8D, jest metodą opartą na analizie faktów (analizie przyczynowo-skutkowej).
Metoda 8D obejmuje 8 kroków prowadzących do rozwiązania problemu:
  1. Powołanie zespołu (ang. team).
  2. Opisanie (zdefiniowanie) problemu (ang. define problem) w tym ustalenie następstw dla klienta (ang. repercussions for the customer).
  3. Wskazanie tymczasowych działań powstrzymujących (ang. interim containment actions).
  4. Ustalenie przyczyn źródłowych (ang. root causes).
  5. Wskazanie trwałych działań korekcyjnych (ang. permanent corrective actions).
  6. Wprowadzenie trwałych działań korekcyjnych (ang. implement permanent corrective actions).
  7. Wskazanie działań zapobiegawczych (ang. actions to prevent recurrence).
  8. Podsumowanie i uhonorowanie wysiłków zespołu (ang. recognize team efforts).
Rejestrując zgłoszenie należy opisać symptomy/objawy niezgodności (problemu). Jeśli z opisu symptomów/objawów niezgodności wynika konieczność natychmiastowego odizolowania klienta od skutków problemu, należy wprowadzić natychmiastowe działania osłonowe (ang. emergency response actions). Działania osłonowe wprowadza się, zanim zainicjowany zostanie właściwy proces rozwiązania problemu metodą 8D. Dlatego czasami określa się je jako zerowy krok metody 8D.
Rezultat pracy zespołu dokumentowany jest w formie raportu 8D. Program NNR-Pro automatycznie generuje raport 8D, na podstawie informacji wprowadzonych do bazy danych programu NNR-Pro a dokumentujących czynności związane z rozpatrzeniem reklamacji lub niezgodności. W zależności od obszerności zarejestrowanych informacji, raport 8D będzie składał się z jednej lub wielu stron kartek papieru formatu A4.
Stosowanie metody 8D nie powinno być ograniczane tylko do procesu rozpatrywania reklamacji. Wykorzystując metodę 8D można identyfikować wszelkie problemy dotyczące różnych obszarów działalności firmy (zatrudnienia, finansów, zaopatrzenia, produkcji, sprzedaży itd.). Warto dążyć do tego, aby takie podejście stało się swoistą filozofią organizacji, znaną i stosowaną przez wszystkich pracowników.
Zobacz też: forma dokumentowania przystosowana do wymagań Normy ISO 9001


Metoda 8D - Natychmiastowe działania osłonowe

Rejestrując zgłoszenie należy opisać symptomy/objawy niezgodności (problemu). Jeśli z opisu symptomów/objawów niezgodności wynika konieczność natychmiastowego odizolowania klienta od skutków problemu, należy wprowadzić natychmiastowe działania osłonowe (ang. emergency response actions). Działania osłonowe wprowadza się, zanim zainicjowany zostanie właściwy proces rozwiązania problemu metodą 8D. Dlatego czasami określa się je jako zerowy krok metody 8D.
Program NNR-Pro prezentuje informacje o natychmiastowych działaniach osłonowych w formie tabeli. Edycja informacji o działaniach osłonowych przeprowadzana jest na osobnym formularzu.
Menu podręczne tabeli (tj. wyświetlane po kliknięciu na tabeli prawym przyciskiem myszki) umożliwia:

  • wprowadzenie wpisu

    Dla każdego wpisu musi być wprowadzony opis działania. Alternatywnie można wprowadzić opis działania poufny (np. ze względu na ochronę informacji stanowiących „know-how” firmy) - opis działania poufny nie pojawia się na wydrukach.

  • poprawienie wpisu

    Umożliwia poprawienie informacji o działaniu.

  • usunięcie wpisu

    Usuwa działanie.

  • wyświetlenie szczegółów

    Wyświetla formularz zawierający szczegółowe dane dotyczące działania.
Zobacz też: forma dokumentowania przystosowana do wymagań Normy ISO 9001 - wybór sposobu (metody) rozwiązania
Przejdź do pierwszego kroku: Zespół


Metoda 8D - Zespół

W pierwszym kroku metody 8D należy powołać zespół (ang. team) fachowców (najlepiej 7 osób +/- 3 osoby) znających produkt i proces (posiadających wiedzę, kompetencje i umiejętności niezbędne do rozwiązania problemu oraz wdrożenia trwałych działań korekcyjnych i działań zapobiegawczych). Rozmiar zespołu i jego skład zależy od charakteru problemu i podejmowanych działań. Ważne jest zapewnienie zespołowi odpowiednich uprawnień, które umożliwią mu uzyskiwanie i wykorzystywanie informacji dotyczących analizowanego problemu oraz podejmowanie koniecznych decyzji. Ponieważ ważnym składnikiem metody jest opracowanie raportu, w zespole musi być wyznaczona osoba lub osoby dokumentujące pracę zespołu. Zespół powinien posiadać odpowiednią strukturę wraz z liderem.
Role uczestników zespołu:
  • mentor - posiada uprawnienia do wprowadzania zmian, pomaga usuwać bariery organizacyjne oraz zdobywać odpowiednie środki, jest łącznikiem zespołu z firmą (organizacją), wspiera decyzje zespołu, monitoruje postępy pracy zespołu, w pracach zespołu uczestniczy gdy jest to konieczne;
  • lider - zarządza zespołem, koordynuje ustalenia celów i zadań, kieruje procesem podejmowania decyzji, reprezentuje zespół na zewnątrz, w dyskusjach jest równoprawnym uczestnikiem zespołu a nie jego szefem;
  • organizator - planuje spotkania zespołu, monitoruje czas pracy zespołu w odniesieniu do planu, dyscyplinuje uczestników zespołu, współpracuje z liderem zespołu;
  • sekretarz - dokumentuje pracę zespołu (wypowiedzi, decyzje itp.), przechowuje zapisy z pracy zespołu i udostępnia je uczestnikom zespołu;
  • moderator - skupia się na tym jak pracuje zespół, dążąc do jego efektywnej pracy, angażuje wszystkich uczestników zespołu;
  • uczestnik - dzieli się doświadczeniem i wiedzą, zgłasza pomysły.
Role w zespole powinny być jasno określone. Zwiększa to efektywność pracy zespołu. Należy dążyć do tego, aby każdy uczestnik zespołu wnosił wartość dodaną. Powinno się także unikać sytuacji, w której czas spotkań przeciąga się w nieskończoność. Odpowiedzialność za to wszystko ponosi głównie lider zespołu, jednak inne osoby mogą pełnić role organizatora, sekretarza lub moderatora. Skład zespołu może być uzupełniany wraz z postępem prac związanych z opracowaniem rozwiązania problemu.
W programie NNR-Pro informacje o uczestnikach zespołu wyświetlane są w tabeli. Edycja informacji zawartych w tabeli odbywa się bezpośrednio w wierszu tabeli (a nie na osobnym formularzu). Tabela posiada menu podręczne uaktywniające jedną z operacji edycji tj.:

  • wprowadzenie wpisu

    Wprowadzając wpis należy określić rolę oraz wprowadzić nazwisko i imię uczestnika zespołu. Dane uczestnika zespołu można wprowadzić do tabeli, poprzez wskazanie ich na liście pracowników (naciskając np. klawisz [F2]) lub wpisanie (np. gdy uczestnik jest osobą z zewnątrz firmy i nie chcemy by dane tej osoby były wprowadzone na listę pracowników).

  • poprawienie wpisu

    Uaktywnia operację poprawiania danych wyróżnionego uczestnika zespołu.

  • usunięcie wpisu

    Usuwa dane wyróżnionego uczestnika zespołu (nie można usunąć ze składu zespołu danych uczestnika, która jest odpowiedzialny, zatwierdził lub sprawdził jedno z działań dotyczących rozwiązania problemu).

  • wysłanie powiadomienia

    Wysyła powiadomienie (np. o wyznaczonym spotkaniu) do wszystkich uczestników zespołu (operacja wysłania powiadomienia jest aktywna do czasu zamknięcia zgłoszenia). Przed wysłaniem powiadomienia można określić zarówno jego temat jak i treść oraz wskazać jaką metodą powiadomienia będzie wysłane (jeśli w parametrach pracy programu NNR-Pro dana metoda wysyłania powiadomień nie jest aktywna, nie będzie jej można wybrać). Wszystkie wysyłane powiadomienia są rejestrowane w ewidencji powiadomień. Sposób przygotowania powiadomienia do wysłania (np. dołączenie w tytule informacji identyfikujących zgłoszenie, sformatowanie tekstu powiadomienia) jest taki sam jak w przypadku automatycznego generowania powiadomień.
Zobacz też: forma dokumentowania przystosowana do wymagań Normy ISO 9001 - wybór sposobu (metody) rozwiązania
Przejdź do następnego kroku: Opis (definicja) problemu
Zobacz też: Natychmiastowe działania osłonowe


Metoda 8D - Opis (definicja) problemu

W drugim kroku metody 8D należy opisać (zdefiniować) problem (ang. define problem), w tym ustalić jakie następstwa ma on dla klienta (ang. repercussions for the customer) oraz zebrać inne informacje dotyczące problemu (innymi słowy opisać problem przy pomocy mierzalnych określeń: kto?, co?, gdzie?, kiedy?, jak?, jak wiele?, itp. - istotne jest oddzielenie symptomów od właściwego problemu). Opisując np. proces realizacji wyrobu związany z reklamacją należy uwzględniać stan rzeczywisty a nie korzystać z dokumentacji procesu. Analizując zebrane informacje, nie należy zapomnieć o wprowadzonych natychmiastowych działaniach osłonowych. Prawidłowo opisany problem jest punktem wyjściowym do dalszych etapów analizy i trafnego zrozumienia istoty problemu.
Definicja problemu to prosty, zwięzły zwrot identyfikując obiekt i defekt, dla którego przyczyna nie jest znana.
W programie NNR-Pro do wprowadzenia tekstu opisującego zgłaszany problem przeznaczone zostało pole „Opis (definicja) problemu”. W polu tym można zapisać informację o tym, co i kiedy zostało zauważone lub zaszło w odniesieniu do wyrobu, procesu lub SZJ, czy dotyczy to bezpieczeństwa, wymagań prawnych itp.
Do opisania następstw dla klienta dodane zostało dodatkowe pole edycyjne. W opisie następstw warto odnotować informacje na temat szacunkowego znaczenia niezgodności (problemu) na klienta. W opisie następstw dla klienta warto również zamieścić informacje o tym jak niezgodność lub reklamacja może wpłynąć na obecnych i przyszłych klientów i jakie może powodować straty.
Zobacz też: forma dokumentowania przystosowana do wymagań Normy ISO 9001 - wybór sposobu (metody) rozwiązania
Przejdź do następnego kroku: Tymczasowe działania powstrzymujące
Przejdź do poprzedniego kroku: Zespół


Metoda 8D - Tymczasowe działania powstrzymujące

W kolejnym kroku metody 8D należy określić i wprowadzić w życie tymczasowe działania powstrzymujące (ang. interim containment actions). Są to działania doraźne (tymczasowe), których celem jest ochrona klientów przed dalszymi skutkami problemu do czasu wprowadzenia trwałych działań korekcyjnych. Działania powstrzymujące mają zapobiec eskalacji problemu, dalszemu wytwarzaniu wyrobów niezgodnych (braków) i co najgorsze przekazaniu wyrobów niezgodnych klientowi. W razie potrzeby należy uruchomić działalność serwisu.
Działania powstrzymujące powinny być skorelowane z natychmiastowymi działaniami osłonowymi i utrzymywane do czasu wprowadzenia trwałych działań korekcyjnych. Konieczna jest weryfikacja wyznaczanych działań powstrzymujących przed ich wprowadzeniem (sprawdzenie i potwierdzenie, że działania powstrzymujące osiągną założony cel i nie będą generować nowego problemu) oraz późniejsze walidacja skuteczności podjętych działań powstrzymujących wykonana po ich wprowadzeniu (potwierdzenie w oparciu o obiektywne dowody, że niepożądane skutki zostały wyeliminowane i nie występują żadne inne problemy). Zespół powinien ustalić odpowiednie mierniki w procesie i przeprowadzić test działań powstrzymujących. Wyniki testu stanowią podstawę do wyboru wykonywanych działań powstrzymujących.
Jest to jedyny opcjonalny krok metody 8D. Tymczasowe działania powstrzymujące nie muszą być wprowadzone gdy uzgodniono to z klientem lub gdy zidentyfikowano przyczyny źródłowe i trwałe działania korekcyjne zostaną wprowadzone szybciej niż tymczasowe działania powstrzymujące.
Przykłady działań powstrzymujących: wprowadzenie dodatkowej kontroli, selekcjonowanie towaru z podziałem na dobry i wadliwy, wstrzymanie wysyłki towaru, zatrzymanie produkcji.
Program NNR-Pro prezentuje informacje o tymczasowych działaniach powstrzymujących w formie tabeli. Edycja informacji o działaniach powstrzymujących przeprowadzana jest na osobnym formularzu. Dane osób: odpowiedzialnej za wprowadzenie działania, zatwierdzającej działanie i sprawdzającej skuteczność (odpowiedzialnej za sprawdzenie skuteczności) działania, wskazuje się wśród uczestników zespołu.
Menu podręczne tabeli (tj. wyświetlane po kliknięciu na tabeli prawym przyciskiem myszki) umożliwia:

  • wprowadzenie wpisu

    Dla każdego wpisu musi być wprowadzony opis działania. Alternatywnie można wprowadzić opis działania poufny (np. ze względu na ochronę informacji stanowiących „know-how” firmy) - opis działania poufny nie pojawia się na wydrukach, określić termin wprowadzenia i wskazać osobę odpowiedzialną za wprowadzenie działania oraz podać planowany koszt i wskazać osobę, która go zatwierdziła (powinna to być osoba z zespołu, której przypisano rolę mentora). Nowemu działaniu można nadać status działania planowanego lub wykonywanego (domyślnie działanie otrzymuje status działania planowanego). Tylko działania planowane mogą być usunięte. Ponadto działania planowane mogą być rozpoczęte lub jeśli nie zostały zaakceptowane - odrzucone. Działania wykonywane mogą być uznane za wprowadzone lub odrzucone (anulowane).

  • poprawienie wpisu

    Działania planowane lub wykonywane mogą mieć poprawione informacje o opisie działania, opisie działania poufnym, terminie wprowadzenia i osobie odpowiedzialnej oraz planowanym koszcie i osobie, która ten koszt zatwierdziła. Ponadto działania planowane mogą mieć zmieniony status na informujący o tym, że działanie jest wykonywane.
    Działania wprowadzone (wdrożone) mogą mieć poprawione informacje o dacie i godzinie wprowadzenia, numerze i dacie raportu z wprowadzenia (wdrożenia) oraz wysokości rzeczywistych kosztów.
    Dla działań odrzuconych, zarówno niezaakceptowanych jak i anulowanych, można poprawić informację o powodzie odrzucenia.

  • usunięcie wpisu

    Usuwa planowane działanie.

  • odrzucenie niezaakceptowanego działania

    Odwołuje planowane działanie. Działanie otrzymuje status działania odrzuconego. Dla odrzuconego działania można wskazać powód odrzucenia.

  • rozpoczęcie działania

    Rozpoczyna planowane działanie (identyczny efekt uzyska się zmieniając podczas operacji poprawienia wpisu, status działania planowanego na działanie wykonywane). Dla rozpoczynanego działania można poprawić informacje o opisie działania, opisie działania poufnym, terminie wprowadzenia i osobie odpowiedzialnej oraz planowanym koszcie i osobie, która ten koszt zatwierdziła.

  • wprowadzenie (wdrożenie) działania

    Kończy proces wdrożenia wykonywanego działania. Działanie otrzymuje status działania wprowadzonego. Dla wprowadzonego działania można podać datę i godzinę wprowadzenia (zakończenia wdrożenia) a także wskazać numer i datę raportu (dokumentu) potwierdzającego wykonanie np. raportu z testów. Można też wprowadzić informację o rzeczywistym koszcie wprowadzenia. Dodatkowo można odnotować informacje o weryfikowanej i zgodnej ilości oraz osobie, która sprawdziła lub była odpowiedzialna za sprawdzenie skuteczności działania. Na podstawie informacji o ilości weryfikowanej i ilości zgodnej wyliczany i prezentowany jest wynik obrazujący efektywność działania.

  • unieważnienie rozpoczętego działania

    Odwołuje działanie wykonywane. Działanie otrzymuje status działania unieważnionego. Dla unieważnionego działania można wskazać powód odrzucenia.

  • wyświetlenie szczegółów

    Wyświetla formularz zawierający szczegółowe dane dotyczące działania.
W programie NNR-Pro można zarejestrować każde potencjalne działanie powstrzymujące. Nowe działanie otrzyma domyślnie status działania planowanego. Po zweryfikowaniu można mu nadać status działania wykonywanego, wybierając z menu podręcznego tabeli polecenie „Rozpoczęcie działania”. Planowanym działaniom, które nie będą wykonywane (nie zostały zaakceptowane) można nadać status działania odrzuconego, wybierając z menu podręcznego tabeli polecenie „Odrzucenie niezaakceptowanego działania” - alternatywnie można usunąć z tabeli informacje o takim działaniu. jeśli proces wprowadzenia działania zostanie zakończony, można zmienić status działania na status działania wprowadzonego, wybierając z menu podręcznego tabeli polecenie „Wprowadzenie (wdrożenie) działania”. Jeśli już wykonywane działanie zostało odrzucone, można zmienić jego status na status działania unieważnionego, wybierając z menu podręcznego tabeli polecenie „Unieważnienie rozpoczętego działania”.
Informacje o sposobie weryfikacji działań planowanych oraz sposobie walidacji działań wprowadzonych należy zapisywać w polu opisu działania.
W raporcie 8D nie są drukowane informacje dotyczące działań planowanych, opisy działań odrzuconych drukowane są przekreśloną i podkreśloną czcionką a opisy działań anulowanych drukowane są czcionką przekreśloną.
Zobacz też: forma dokumentowania przystosowana do wymagań Normy ISO 9001 - wybór sposobu (metody) rozwiązania
Przejdź do następnego kroku: Przyczyny źródłowe
Przejdź do poprzedniego kroku: Opis (definicja) problemu


Metoda 8D - Przyczyny źródłowe

W tym kroku metody 8D należy sprawdzić i uaktualnić (jeśli zostały zidentyfikowane nowe informacje) opis problemu, przejrzeć informacje dotyczące wprowadzonych tymczasowych działań powstrzymujących, zebrać i przeanalizować dane statystyczne, przeanalizować sytuację oraz ustalić główne przyczyny (ang. root causes) problemu (z ich procentowym udziałem w spowodowaniu problemu i wskazaniem miejsc w procesie, w których problem mógł być wykryty wcześniej, ale nie został).
By skutecznie zlikwidować problem, należy zidentyfikować faktyczne przyczyny problemu. Nie jest to proste zadanie. Dlatego ważna jest praca zespołowa, która pozwala na analizę problemu z różnych perspektyw. Często rzeczywiste przyczyny wielu problemów leżą głęboko w zarządzaniu organizacją. Jeśli skład zespołu jest niewystarczający do identyfikacji przyczyn źródłowych wyjaśniających problem, należy go uzupełnić o dodatkowe osoby.
Przyczyny źródłowe można podzielić na dwie kategorie: przyczyny, które spowodowały wystąpienie problemu oraz przyczyny, które spowodowały ujawnienie się problemu. Dlatego w analizie przyczyn źródłowych należy zwrócić uwagę na dwa istotne aspekty analizy przyczyn źródłowych: dlaczego problem się ujawnił i dlaczego tego problemu nie wykryto natychmiast tam gdzie się aktualnie ujawnił. Podczas prac można wykorzystać analizę ryzyka (FMEA), diagram Ishikawy, metodę 80/20 (metoda Pareto), itp. Pomocna może być również analiza rozkładu w czasie zdarzeń związanych z problemem. W analizie koniecznie należy uwzględnić: ludzi, metody, materiał, maszyny i środowisko dla rozważanego problemu. Według metody 5Why trzeba przynajmniej pięć razy zadać sobie kolejne pytania „dlaczego”, aby dojść do właściwej, źródłowej przyczyny. Tylko wykrycie właściwych przyczyń źródłowych zapewni wprowadzenie skutecznych trwałych działań korekcyjnych i działań zapobiegawczych oraz pozwoli mieć pewność, że problem się więcej nie pojawi.
Program NNR-Pro prezentuje informacje o przyczynach źródłowych w formie tabeli. Edycja informacji o przyczynach źródłowych przeprowadzana jest na osobnym formularzu.
Menu podręczne tabeli (tj. wyświetlane po kliknięciu na tabeli prawym przyciskiem myszki) umożliwia:

  • wprowadzenie wpisu

    Wprowadzając informacje o przyczynie źródłowej należy podać opis przyczyny, określić procentowy udział przyczyny w powstaniu problemu (sumaryczny udział wszystkich przyczyn ujętych w tabeli w zaistnieniu problemu nie może przekroczyć 100%) oraz określić charakter źródła (sklasyfikować źródło) przyczyny.

  • poprawienie wpisu

    Umożliwia poprawienie informacji o przyczynie źródłowej.

  • usunięcie wpisu

    Usuwa informację o przyczynie źródłowej.

  • wyświetlenie szczegółów

    Wyświetla formularz zawierający szczegółowe dane dotyczące przyczyny źródłowej.
Zobacz też: forma dokumentowania przystosowana do wymagań Normy ISO 9001 - wybór sposobu (metody) rozwiązania
Przejdź do następnego kroku: Trwałe działania korekcyjne
Przejdź do poprzedniego kroku: Tymczasowe działania powstrzymujące


Metoda 8D - Trwałe działania korekcyjne

W piątym kroku metody 8D zespół powinien wykorzystać techniki poszukiwania koncepcji i wypracować rozwiązania. Zespół powinien rozważyć kilka rozwiązań opisanego problemu oraz ocenić, które z nich będzie najlepsze. Rozwiązania należy ocenić pod względem kosztów i sposobów wprowadzania (w kontekście analizy ryzyka, łatwości i szybkości wprowadzania, korzyści oraz wpływu na klienta). Powinno się dążyć do rozwiązań optymalnych i gwarantujących trwałe skutki. Należy unikać skutków ubocznych oraz rozwiązań tymczasowych. Podobnie jak ustalone w poprzednim kroku przyczyny źródłowe, również trwałe działania korekcyjne (ang. permanent corrective actions) można podzielić na dwie kategorie: działania korekcyjne, eliminujące przyczynę źródłową problemu oraz działania korekcyjne, które eliminują wystąpienie problemu (punkt ucieczki).
Z perspektywy rozwiązania problemu jest to najważniejszy krok metody 8D.
Przykłady działań korekcyjnych: wprowadzenie dodatkowej kontroli w proces, wprowadzenie dodatkowego procesu (np. testu oraz naprawy wykrytych wadliwych wyrobów), przekazanie dostawcy zgłoszenia o defektach w dostarczonym materiale i wymiana wadliwego materiału.
Program NNR-Pro prezentuje informacje o trwałych działaniach korekcyjnych w formie tabeli. Edycja informacji o działaniach korekcyjnych przeprowadzana jest na osobnym formularzu. Dane osób: odpowiedzialnej za wprowadzenie działania i zatwierdzającej działanie, wskazuje się wśród uczestników zespołu.
Menu podręczne tabeli (tj. wyświetlane po kliknięciu na tabeli prawym przyciskiem myszki) umożliwia:

  • wprowadzenie wpisu

    Dla każdego wpisu musi być wprowadzony opis działania. Alternatywnie można wprowadzić opis działania poufny (np. ze względu na ochronę informacji stanowiących „know-how” firmy) - opis działania poufny nie pojawia się na wydrukach, określić termin wprowadzenia i wskazać osobę odpowiedzialną za wprowadzenie działania oraz podać planowany koszt i wskazać osobę, która go zatwierdziła (powinna to być osoba z zespołu, której przypisano rolę mentora). Nowemu działaniu można nadać status działania planowanego lub wykonywanego (domyślnie działanie otrzymuje status działania planowanego). Tylko działania planowane mogą być usunięte. Ponadto działania planowane mogą być rozpoczęte lub jeśli nie zostały zaakceptowane - odrzucone.

  • poprawienie wpisu

    Działania planowane mogą mieć poprawione informacje o opisie działania, opisie działania poufnym, terminie wprowadzenia i osobie odpowiedzialnej oraz planowanym koszcie i osobie, która ten koszt zatwierdziła. Ponadto działania planowane mogą mieć zmieniony status na informujący o tym, że działanie jest wykonywane.
    Dla działań odrzuconych ze względu na brak akceptacji, można poprawić informację o powodzie odrzucenia.
    Operacja poprawianie informacji o działaniach wykonywanych, wprowadzonych (wdrożonych) lub odrzuconych (anulowanych), dostępna jest w menu podręcznym tabeli Wprowadzonych trwałych działań korekcyjnych (zobacz. następny krok metody 8D).

  • usunięcie wpisu

    Usuwa planowane działanie.

  • przygotowanie zgłoszenia do dostawcy/serwisu

    Jeśli wykonanie działania wymaga przeprowadzenia czynności przez podmiot zewnętrzny (np. dostawcę materiału), polecenie umożliwia przygotowanie zgłoszenia do dostawcy. Zgłoszenie zostanie odnotowane w dzienniku zgłoszeń wychodzących.

  • odrzucenie niezaakceptowanego działania

    Odwołuje planowane działanie. Działanie otrzymuje status działania odrzuconego. Dla odrzuconego działania można wskazać powód odrzucenia.

  • rozpoczęcie działania

    Rozpoczyna planowane działanie (identyczny efekt uzyska się zmieniając podczas operacji poprawienia wpisu, status działania planowanego na działanie wykonywane). Dla rozpoczynanego działania można poprawić informacje o opisie działania, opisie działania poufnym, terminie wprowadzenia i osobie odpowiedzialnej oraz planowanym koszcie i osobie, która ten koszt zatwierdziła.

  • wyświetlenie szczegółów

    Wyświetla formularz zawierający szczegółowe dane dotyczące działania.
W programie NNR-Pro można zarejestrować każde rozważane działanie korekcyjne. Nowe działanie otrzyma domyślnie status działania planowanego. Po ocenie działania można mu nadać status działania wykonywanego, wybierając z menu podręcznego tabeli polecenie „Rozpoczęcie działania”. Planowanym działaniom, które nie będą wykonywane (nie zostały zaakceptowane) można nadać status działania odrzuconego, wybierając z menu podręcznego tabeli polecenie „Odrzucenie niezaakceptowanego działania” - alternatywnie można usunąć z tabeli informacje o takim działaniu.
Informacje na temat wyznaczonej oceny rozważanych działań korekcyjnych można zapisywać w polu opisu działania.
W programie NNR-Pro można odnieść działanie korekcyjne do dostawcy (przyczyna niezgodności lub reklamacji klienta tkwi po stronie naszego dostawcy i teraz od niego oczekujemy wykonania i udokumentowania skuteczności działań, związanych z usunięciem problemu opisanego w przekazanym mu dokumencie zgłoszenia reklamacyjnego). By odnieść działanie korekcyjne do dostawcy, należy wywołać z menu podręcznego tabeli polecenie „Przygotowanie zgłoszenia do dostawcy/serwisu”.
W raporcie 8D nie są drukowane informacje dotyczące działań planowanych, opisy działań odrzuconych drukowane są przekreśloną i podkreśloną czcionką a opisy działań anulowanych drukowane są czcionką przekreśloną.
Zobacz też: forma dokumentowania przystosowana do wymagań Normy ISO 9001 - wybór sposobu (metody) rozwiązania
Przejdź do następnego kroku: Wprowadzone trwałe działania korekcyjne
Przejdź do poprzedniego kroku: Przyczyny źródłowe


Metoda 8D - Wprowadzone trwałe działania korekcyjne

W kolejnym kroku metody 8D należy przygotować plan działania (opisać podejmowane działania, wskazać osobę odpowiedzialną oraz określić termin wprowadzenia działania). Działania te mogą się wiązać np. ze zmianami konstrukcyjnymi, zmianami w zaopatrzeniu, zmianami procedur, przeszkoleniem odpowiednich pracowników, itp. Należy sprawdzić skuteczność wprowadzonych działań poprzez monitorowanie rezultatów osiąganych mierników (w procesie można wykorzystać np. badania laboratoryjne, analizy statystyczne itp.).
Przed wyprowadzeniem trwałych działań korekcyjnych (ang. implement permanent corrective actions) należy usunąć wprowadzone wcześniej tymczasowe działania powstrzymujące.
Jeśli nie można wdrożyć działań korekcyjnych lub wdrożenie wymaga dłuższego czasu, konieczna jest ponowna analiza, ewentualna modyfikacja i dalsze stosowanie wprowadzonych tymczasowych działań powstrzymujących.
W programie NNR-Pro informacje dotyczące realizowanych działań korekcyjnych (takie jak np. osoba odpowiedzialna, termin wprowadzenia, opis działania tj.: istota działania, sposób weryfikacji oraz sposób walidacji działania), można wprowadzić rejestrując rozważane planowane działania korekcyjne. Jeśli jednak któraś z tych informacji nie została wprowadzona na etapie rejestracji planowanych działań korekcyjnych lub jest nieaktualna, można ją dołączyć/zaktualizować wywołując operację poprawienia wpisu.
Program NNR-Pro prezentuje informacje o wprowadzonych trwałych działaniach korekcyjnych w formie tabeli. Edycja informacji o działaniach przeprowadzana jest na osobnym formularzu. Dane osób: odpowiedzialnej za wprowadzenie działania, zatwierdzającej działanie i sprawdzającej skuteczność (odpowiedzialnej za sprawdzenie skuteczności) działania, wskazuje się wśród uczestników zespołu.
Menu podręczne tabeli (tj. wyświetlane po kliknięciu na tabeli prawym przyciskiem myszki) umożliwia:

  • poprawienie wpisu

    Działania wykonywane może mieć poprawione informacje o opisie działania, opisie działania poufnym (np. ze względu na ochronę informacji stanowiących „know-how” firmy) - opis działania poufny nie pojawia się na wydrukach, terminie wprowadzenia i osobie odpowiedzialnej oraz planowanym koszcie i osobie, która ten koszt zatwierdziła.
    Działania wprowadzone (wdrożone) mogą mieć poprawione informacje o dacie i godzinie wprowadzenia, numerze i dacie raportu z wprowadzenia (wdrożenia) oraz wysokości rzeczywistych kosztów.
    Dla działań odrzuconych (anulowanych) można poprawić informację o powodzie odrzucenia.

  • wprowadzenie (wdrożenie) działania

    Kończy proces wdrożenia wykonywanego działania. Działanie otrzymuje status działania wprowadzonego. Dla wprowadzonego działania można podać datę i godzinę wprowadzenia (zakończenia wdrożenia) a także wskazać numer i datę raportu (dokumentu) potwierdzającego wykonanie np. raportu z testów. Można też wprowadzić informację o rzeczywistym koszcie wprowadzenia. Dodatkowo można odnotować informacje o weryfikowanej i zgodnej ilości oraz osobie, która sprawdziła lub była odpowiedzialna za sprawdzenie skuteczności działania. Na podstawie informacji o ilości weryfikowanej i ilości zgodnej wyliczany i prezentowany jest wynik obrazujący efektywność działania.

  • unieważnienie rozpoczętego działania

    Odwołuje działanie wykonywane. Działanie otrzymuje status działania unieważnionego. Dla unieważnionego działania można wskazać powód odrzucenia.

  • wyświetlenie szczegółów

    Wyświetla formularz zawierający szczegółowe dane dotyczące działania.
Jeśli proces wprowadzenia działania zostanie zakończony, można zmienić status działania na status działania wprowadzonego, wybierając z menu podręcznego tabeli polecenie „Wprowadzenie (wdrożenie) działania”. Jeśli już wykonywane działanie zostało odrzucone, można zmienić jego status na status działania unieważnionego, wybierając z menu podręcznego tabeli polecenie „Unieważnienie rozpoczętego działania”.
Informacje o sposobie weryfikacji działań planowanych oraz sposobie walidacji działań wprowadzonych należy zapisywać w polu opisu działania.
W raporcie 8D opisy wprowadzonych działań korekcyjnych, które zostały anulowane, drukowane są czcionką przekreśloną.
Zobacz też: forma dokumentowania przystosowana do wymagań Normy ISO 9001 - wybór sposobu (metody) rozwiązania
Przejdź do następnego kroku: Działania zapobiegawcze
Przejdź do poprzedniego kroku: Trwałe działania korekcyjne


Metoda 8D - Działania zapobiegawcze

Celem kolejnego kroku metody 8D jest ustalenie działań zapobiegawczych (ang. actions to prevent recurrence) jakie należy podjąć aby nie dopuścić do ponownego pojawienia się problemu. W tym kroku powinno się określić działania systemowe, które utrwalą, udoskonalą albo zastąpią trwałe działania korekcyjne.
Należy sprawdzić działanie zastosowanego rozwiązania pod kątem osiągania założonych celów. Powinno ono zapewnić, że problem się nie powtórzy. W skomplikowanych przypadkach może okazać się konieczne ponowne użycie metody 8D, np. w odniesieniu do metod zarządzania.
Przykłady działań zapobiegawczych: uszczegółowienie albo zmiana nieprawidłowej specyfikacji lub całej dokumentacji, zmiana parametrów procesu, modyfikacja lub wykonanie odpowiedniego oprzyrządowania, zmiana technologii lub narzędzi przez kooperanta, wprowadzenie czynników motywujących pracowników i zniechęcających do powrotu do starych praktyk, zmiana procedur organizacyjnych.
Program NNR-Pro prezentuje informacje o działaniach zapobiegawczych w formie tabeli. Edycja informacji o działaniach zapobiegawczych przeprowadzana jest na osobnym formularzu. Dane osób: odpowiedzialnej za wprowadzenie działania, zatwierdzającej działanie i sprawdzającej skuteczność (odpowiedzialnej za sprawdzenie skuteczności) działania, wskazuje się wśród uczestników zespołu.
Menu podręczne tabeli (tj. wyświetlane po kliknięciu na tabeli prawym przyciskiem myszki) umożliwia:

  • wprowadzenie wpisu

    Dla każdego wpisu musi być wprowadzony opis działania. Alternatywnie można wprowadzić opis działania poufny (np. ze względu na ochronę informacji stanowiących „know-how” firmy) - opis działania poufny nie pojawia się na wydrukach, określić termin wprowadzenia i wskazać osobę odpowiedzialną za wprowadzenie działania oraz podać planowany koszt i wskazać osobę, która go zatwierdziła (powinna to być osoba z zespołu, której przypisano rolę mentora). Nowemu działaniu można nadać status działania planowanego lub wykonywanego (domyślnie działanie otrzymuje status działania planowanego). Tylko działania planowane mogą być usunięte. Ponadto działania planowane mogą być rozpoczęte lub jeśli nie zostały zaakceptowane - odrzucone. Działania wykonywane mogą być uznane za wprowadzone lub odrzucone (anulowane).

  • poprawienie wpisu

    Działania planowane lub wykonywane mogą mieć poprawione informacje o opisie działania, opisie działania poufnym, terminie wprowadzenia i osobie odpowiedzialnej oraz planowanym koszcie i osobie, która ten koszt zatwierdziła. Ponadto działania planowane mogą mieć zmieniony status na informujący o tym, że działanie jest wykonywane.
    Działania wprowadzone (wdrożone) mogą mieć poprawione informacje o dacie i godzinie wprowadzenia, numerze i dacie raportu z wprowadzenia (wdrożenia) oraz wysokości rzeczywistych kosztów.
    Dla działań odrzuconych, zarówno niezaakceptowanych jak i anulowanych, można poprawić informację o powodzie odrzucenia.

  • usunięcie wpisu

    Usuwa planowane działanie.

  • przygotowanie zgłoszenia do dostawcy/serwisu

    Jeśli wykonanie działania wymaga przeprowadzenia czynności przez podmiot zewnętrzny (np. kooperanta), polecenie umożliwia przygotowanie takiego zgłoszenia. Zgłoszenie zostanie odnotowane w dzienniku zgłoszeń wychodzących.

  • odrzucenie niezaakceptowanego działania

    Odwołuje planowane działanie. Działanie otrzymuje status działania odrzuconego. Dla odrzuconego działania można wskazać powód odrzucenia.

  • rozpoczęcie działania

    Rozpoczyna planowane działanie (identyczny efekt uzyska się zmieniając podczas operacji poprawienia wpisu, status działania planowanego na działanie wykonywane). Dla rozpoczynanego działania można poprawić informacje o opisie działania, opisie działania poufnym, terminie wprowadzenia i osobie odpowiedzialnej oraz planowanym koszcie i osobie, która ten koszt zatwierdziła.

  • wprowadzenie (wdrożenie) działania

    Kończy proces wdrożenia wykonywanego działania. Działanie otrzymuje status działania wprowadzonego. Dla wprowadzonego działania można podać datę i godzinę wprowadzenia (zakończenia wdrożenia) a także wskazać numer i datę raportu (dokumentu) potwierdzającego wykonanie np. raportu z testów. Można też wprowadzić informację o rzeczywistym koszcie wprowadzenia. Dodatkowo można odnotować informacje o weryfikowanej i zgodnej ilości oraz osobie, która sprawdziła lub była odpowiedzialna za sprawdzenie skuteczności działania. Na podstawie informacji o ilości weryfikowanej i ilości zgodnej wyliczany i prezentowany jest wynik obrazujący efektywność działania.

  • unieważnienie rozpoczętego działania

    Odwołuje działanie wykonywane. Działanie otrzymuje status działania unieważnionego. Dla unieważnionego działania można wskazać powód odrzucenia.

  • wyświetlenie szczegółów

    Wyświetla formularz zawierający szczegółowe dane dotyczące działania.
W programie NNR-Pro można zarejestrować każde potencjalne działanie zapobiegawcze. Nowe działanie otrzyma domyślnie status działania planowanego. Po zweryfikowaniu można mu nadać status działania wykonywanego, wybierając z menu podręcznego tabeli polecenie „Rozpoczęcie działania”. Planowanym działaniom, które nie będą wykonywane (nie zostały zaakceptowane) można nadać status działania odrzuconego, wybierając z menu podręcznego tabeli polecenie „Odrzucenie niezaakceptowanego działania” - alternatywnie można usunąć z tabeli informacje o takim działaniu. jeśli proces wprowadzenia działania zostanie zakończony, można zmienić status działania na status działania wprowadzonego, wybierając z menu podręcznego tabeli polecenie „Wprowadzenie (wdrożenie) działania”. Jeśli już wykonywane działanie zostało odrzucone, można zmienić jego status na status działania unieważnionego, wybierając z menu podręcznego tabeli polecenie „Unieważnienie rozpoczętego działania”.
W programie NNR-Pro można odnieść działanie zapobiegawcze do kooperanta (przyczyna niezgodności lub reklamacji klienta wynika z niedoskonałej technologii lub narzędzi używanych przez kooperanta). By odnieść działanie zapobiegawcze do kooperanta, należy wywołać z menu podręcznego tabeli polecenie „Przygotowanie zgłoszenia do dostawcy/serwisu”.
W raporcie 8D nie są drukowane informacje dotyczące działań planowanych, opisy działań odrzuconych drukowane są przekreśloną i podkreśloną czcionką a opisy działań anulowanych drukowane są czcionką przekreśloną.
Zobacz też: forma dokumentowania przystosowana do wymagań Normy ISO 9001 - wybór sposobu (metody) rozwiązania
Przejdź do ostatniego kroku: Podsumowanie, uhonorowanie wysiłków zespołu
Przejdź do poprzedniego kroku: Wprowadzone trwałe działania korekcyjne


Metoda 8D - Podsumowanie, uhonorowanie wysiłków zespołu

Ostatni krok metody 8D wiąże się z podsumowaniem (ang. summary) i udokumentowaniem w postaci raportu 8D wyników pracy (ang. communicate results) zespołu oraz uhonorowaniem wysiłków zespołu (recognize team efforts). Jednym z elementów podsumowania powinna być ocena skuteczności wprowadzonych działań. Zaleca się aby ocena była wykonana poprzez porównanie opisu problemu i stanu bieżącego oraz by ocenę przeprowadził dział jakości klienta np. porównując parametry jakościowe kolejnych dostaw (przykładowo analizując liczbę braków z kolejnych partii produkcyjnych) albo opierając się na rezultatach audytów kontrolnych u dostawcy.
Dobrą zasadą jest wyrażenie uznania członkom zespołu (docenienie pracy zespołu). Można np. opublikować wyniki działania zespołu w formie artykułu. By członkowie zespołu odczuli ważność wykonanej pracy, zaleca się by uznanie było unikalne (nie było szablonowe) i adekwatne do wagi rozwiązanego problemu. Odpowiedzialnym za to „działanie” jest lider.
W programie NNR-Pro, w ostatnim kroku metody 8D można wskazać rodzaj decyzji oraz wybrać ocenę prezentującą skuteczność działań. Jak to zostało już opisane, ocenę skuteczności działań powinien przeprowadzić klient. W programie NNR-Pro wprowadzając ocenę skuteczności działań można również wskazać dane osoby, która oceniała skuteczność. Dane osoby wskazuje się na liście pracowników. Mogą to być np. dane pracownika opiekującego się klientem lub np. jeśli klient nie dokonał oceny skuteczności działań a przeprowadził ją wyznaczony pracownik, dane tego pracownika (można również nie podawać informacji o oceniającym).
Wskazanie decyzji co do zgłoszenia reklamacyjnego, spowoduje że program NNR-Pro uzna zgłoszenie reklamacyjne za zrealizowane (wycofanie decyzji przywraca status zgłoszenia informujący o tym, że zgłoszenie jest w trakcie realizacji).
Informacje o dacie ostatniej aktualizacji, decyzji, skuteczności i oceniającym skuteczność nie są drukowane w raporcie 8D a ich przeznaczeniem są funkcje organizacyjno statystyczne. Skalę oceny skuteczności oraz rodzaje decyzji można definiować w parametrach pracy programu.
Kończąc dokumentowanie procesu rozpatrzenia zgłoszenia niezgodności (zgłoszenia reklamacyjnego) warto również zaktualizować bazę wiedzy o problemach (defektach) udostępnianą przez program NNR-Pro. Tworzony katalog defektów może być bardzo przydatny podczas ustalania przyczyn dla nowych niezgodności/reklamacji.
Zobacz też: forma dokumentowania przystosowana do wymagań Normy ISO 9001 - wybór sposobu (metody) rozwiązania
Przejdź do poprzedniego kroku: Działania zapobiegawcze


Dziennik zgłoszeń wychodzących

Dziennik zgłoszeń wychodzących umożliwia przygotowanie zgłoszenia reklamacyjnego do dostawcy, kooperanta lub serwisu i zawiera informacje o zgłoszeniach przekazanych dostawcom, kooperantom lub do serwisu. Dziennik zgłoszeń wychodzących może być wyświetlony w jednej z dwóch form:
  • listy zestawów zgłoszeń, w której zgłoszenia prezentowane są w ramach zestawów do jakich zgłoszenie zostało przypisane podczas przygotowanie zgłoszenia reklamacyjnego, Dziennik zgłoszeń wychodzących - zestawy
  • listy zgłoszeń, w której zgłoszenia prezentowane są niezależnie od zestawów do jakich zgłoszenie zostało przypisane podczas przygotowanie zgłoszenia reklamacyjnego. Dziennik zgłoszeń wychodzących - zgłoszenia
By przypisać zgłoszenie do zestawu, należy je przygotować wówczas, gdy aktywną formą wyświetlania dziennika zgłoszeń wychodzących jest lista zestawów zgłoszeń. Po rozpoczęciu edycji informacji o zestawie i przeniesieniu skupienia do tabeli znajdującej się na zakładce /Specyfikacja zgłoszeń/, można wywołać operację przygotowania zgłoszenia. Wprowadzenie danych o zgłoszeniu może odbywać się bezpośrednio w wierszu tabeli albo na formularzu zawierającym panel edycji, identyczny z panelem prezentującym pełne dane podczas wyświetlania dziennika zgłoszeń wychodzących, gdy aktywną formą wyświetlania dziennika jest lista zgłoszeń.
Jeśli zgłoszenie jest przygotowane wówczas, gdy aktywną formą wyświetlania dziennika zgłoszeń wychodzących jest lista zgłoszeń, program automatycznie tworzy nowy zestaw, do którego przypisane zostanie przygotowane zgłoszenie. Utworzony zestaw będzie więc zawierał informacje tylko o jednym zgłoszeniu. Jeśli jednak po zakończeniu przygotowania zgłoszenia zmieniona zostanie forma wyświetlania dziennika zgłoszeń wychodzących z listy zgłoszeń na listę zestawów zgłoszeń, można do zestawu dołączyć informacje o kolejnych zgłoszeniach.
Na przedstawionych wyżej rysunkach pola otoczone czerwonym owalem o blado-czerwonym wypełnieniu oraz wszystkie pola bloku zawierającego informacje o adresacie reklamacji (nazwa bloku otoczona jest czerwonym owalem o blado-czerwonym wypełnieniu), przedstawiają identyczne informacje w każdej z form wyświetlania dziennika zgłoszeń wychodzących a ich edycja może być wykonywana w dowolnej z tych form wyświetlania dziennika.
Okno zakresu udostępnianych zapisów
W trakcie przeglądania dziennika zgłoszeń wychodzących można zmienić formę wyświetlania dziennika, o ile nie jest aktywna operacja chwilowo blokująca operacje zmiany formy wyświetlania (np. operacja edycji zapisu dziennika), np. naciskając klawisz [F12]. To w jakiej formie dziennik zgłoszeń zostanie wyświetlony po otwarciu dokumentu, zależy od stanu pola wyboru zatytułowanego Wyświetlaj zestawy (na rysunku obok pole wraz z nazwą otoczone są czerwonym owalem o blado-czerwonym wypełnieniu). Poprzez zaznaczenie bądź nie pola wyboru, można wybrać odpowiednią formę wyświetlania dziennika zgłoszeń po jego otwarciu.
Ponadto przed wyświetleniem dziennika można wskazać jakie zapisy będą widoczne. Ustalony zakres udostępnianej dokumentacji obejmuje rok i miesiąc wprowadzenia zapisów do dziennika, status zapisów stwierdzający czy zgłoszenia lub zestawy zgłoszeń (w zależności od aktywnej formy wyświetlania dziennika) zostały rozpatrzone oraz dane osoby odpowiedzialnej za zgłoszenie (gdy dziennik wyświetlany jest jako lista zgłoszeń) lub dane osoby odpowiedzialnej za zestaw zgłoszeń (gdy dziennik wyświetlany jest jako lista zestawów zgłoszeń). Jeśli wybrana zostanie opcja wyboru osoby odpowiedzialnej ale dane tej osoby nie zostaną wskazane, wyświetlony zostanie dziennik zawierający wyłącznie zapisy dotyczące zgłoszeń (gdy dziennik wyświetlany jest jako lista zgłoszeń) lub zestawów zgłoszeń (gdy dziennik wyświetlany jest jako lista zestawów zgłoszeń), którym nie zostały przypisane dane osoby odpowiedzialnej.
Uwaga: w programie NNR-Pro można przypisać dane osoby odpowiedzialnej za zastaw zgłoszeń i niezależnie, dla każdego ze zgłoszeń należących do zestawu dane osoby odpowiedzialnej za to zgłoszenie.
Ustalony zakres udostępnianej dokumentacji obowiązuje do czasu zamknięcia dziennika zgłoszeń wychodzących, tzn. by np. wyświetlić zapisy dotyczące zgłoszeń, za które odpowiedzialna jest inna osoba należy zamknąć i ponownie otworzyć dziennik zgłoszeń.
W tabeli dziennika zgłoszeń wychodzących jak również w tabelach wyświetlających dodatkowe informacje odnoszące się do zapisu dziennika np. specyfikacji zgłoszeń, informacje dotyczące zapisów anulowanych wyświetlane są czcionką przekreśloną.


Dziennik zgłoszeń wychodzących - zestawy zgłoszeń

Ta forma wyświetlania dziennika zgłoszeń wychodzących umożliwia przyglądanie zgłoszeń w podziale na zestawy, do których zgłoszenie zostało przypisane. W programie NNR-Pro każde zgłoszenie przypisane jest do konkretnego zestawu (jeśli zgłoszenie wprowadzone zostało gdy dziennik zgłoszeń wychodzących wyświetlany był w formie listy zgłoszeń, program NNR-Pro utworzy nowy zestaw i dołączy do niego wprowadzone zgłoszenie). Wyświetlenie dziennika zgłoszeń wychodzących w postaci listy zestawów zgłoszeń jest korzystne w przypadku gdy zamierzamy przygotować np.: komplet zgłoszeń dostarczonych jednocześnie, które dotyczą tego samego dostawcy, serwisu lub kooperanta.
Informacje o zgłoszeniach ujętych w zestawie zawiera tabela znajdująca się na zakładce /Specyfikacja zgłoszeń/ (zobacz Zestaw zgłoszeń wychodzących). By przypisać nowe zgłoszenie do zestawu należy je dołączyć do specyfikacji zgłoszeń, tzn uaktywnić tryb edycji zestawu, a następnie z menu podręcznego tabeli wywołać operację wprowadzenia zgłoszenia. Szczegółowe informacje o zgłoszeniu można wyświetlić wskazując zgłoszenie w specyfikacji zgłoszeń i np. naciskając klawisz [F3].
Ten widok dziennika zgłoszeń wychodzących, oprócz standardowych operacji edycyjnych związanych z wprowadzeniem, poprawieniem oraz anulowaniem zapisu dotyczącego zestawu zgłoszeń, udostępnia dodatkowe operacje takie jak:

  • zatwierdzenie zestawu

    Operacja umożliwia określanie zestawów, które są np. zrealizowane. Dla zestawów zatwierdzonych nie są dostępne operacje edycyjne (zarówno samego zestawu jak i zgłoszeń do niego należących). Edycję można przywrócić, korzystając z polecenia „Odwołanie zatwierdzenia zestawu”.

  • odwołanie zatwierdzenia zestawu

    Wycofuje operację zatwierdzenia zestawu zgłoszeń, przywracając możliwość edycji.

  • zamknięcie zestawu

    Operacja umożliwia określanie zestawów, które są np. zrealizowane i nie będą nigdy aktualizowane. Dla zestawów zamkniętych nie są dostępne operacje edycyjne (zarówno samego zestawu jak i zgłoszeń do niego należących). Operacji zamknięcia nie można wycofać.
Zapisy dziennika dotyczące zestawów, które nie zostały rozpatrzone (zatwierdzone lub zamknięte) i nie są anulowane, mają w tabeli wyświetlany numer zestawu na tle w kolorze innym (odcień żółtego) niż tło tabeli.
Zobacz też: Dziennik zgłoszeń wychodzących (informacje ogólne), Zestaw zgłoszeń wychodzących


Zestaw zgłoszeń wychodzących

Informacje opisujące zestaw zgłoszeń podzielone są na 3 bloki. Pierwszy blok zawiera dane ogólne dotyczące zestawu zgłoszeń takie jak numer zestawu i data rejestracji, data zamknięcia, oznaczenia dokumentów itp. Drugi blok zawiera informacje o adresacie reklamacji (np. dostawcy towarów albo materiałów, kooperancie lub serwisie). Ostatni, trzeci blok zawiera szczegółowe informacje dotyczące reklamacji należących do zestawu (oraz pole adnotacje, przeznaczone do wprowadzania dowolnych dodatkowych informacji). Informacje o zgłoszeniach reklamacyjnych ujętych w zestawie prezentowane są w formie specyfikacji zgłoszeń.
W programie NNR-Pro zgłoszenia reklamacyjne mogą być również przygotowane pojedynczo (zobacz Dziennik zgłoszeń wychodzących - zgłoszenia). Warto wiedzieć, że pola edycyjne z pierwszego i drugiego bloku opisane etykietą o tej samej treści na formularzu przeznaczonym do edycji zestawów zgłoszeń i formularzu przeznaczonym do indywidualnej edycji zgłoszeń (tj. informujące o sposobie przekazania, numerach i datach dokumentów: RMA, NCR, listu przewozowego oraz identyfikujące adresata reklamacji) są wspólne dla zestawu i zgłoszenia. Ich aktualizację można przeprowadzić zarówno podczas edycji informacji o poszczególnych zgłoszeniach zestawu jak i podczas edycji informacji ogólnych o zestawie. Wyjątkiem jest pole wskazujące osobę odpowiedzialną. Można wskazać osobę odpowiedzialną za cały zestaw i niezależnie osoby odpowiedzialne za każde ze zgłoszeń z zestawu. Na rysunkach przedstawiających dwie formy wyświetlania dziennika zgłoszeń wychodzących (zobacz Dziennik zgłoszeń wychodzących) pola opisujące identyczne informacje w każdej z form wyświetlania dziennika zgłoszeń wychodzących są otoczone czerwonym owalem o blado-czerwonym wypełnieniu lub należą do bloku, którego nazwa otoczona jest czerwonym owalem o blado-czerwonym wypełnieniu.
Podczas przygotowania zestawu zgłoszeń konieczne jest wskazanie nazwy adresata reklamacji oraz wprowadzenie przynajmniej jednego wpisu do specyfikacji zgłoszeń.
Program NNR-Pro automatycznie numeruje zestawy (a w ramach zastawu zgłoszenia) a także wprowadza datę rejestracji zestawu. Numery pojawiają się po zatwierdzeniu edycji (nadawanie numerów dopiero w chwili wprowadzenia zapisu do bazy danych, pozwala na uniknięcie luk w numeracji, występujących przy pracy wielostanowiskowej w sytuacji gdy na stanowisku, na którym operacja dopisania została wcześniej wywołana, ta operacja dopisania zostanie porzucona).
Dane adresata reklamacji są wybierane z kartoteki kontrahentów). Dane te dodatkowo mogą być uzupełnione informacją, opisującą dane kontaktowe osoby wskazanej przez adresata reklamacji do udzielania informacji na temat stanu przekazanego zestawu zgłoszeń reklamacyjnych.
Specyfikacja zgłoszeń umożliwia przeglądanie oraz edycję zgłoszeń przypisanych do zestawu
Menu podręczne tabeli (tj. wyświetlane po kliknięciu na tabeli prawym przyciskiem myszki) prezentującej specyfikację zgłoszeń umożliwia:

  • wprowadzenie zgłoszenia

    Dołącza do zestawu kolejne zgłoszenie. Edycja informacji przeprowadzana jest bezpośrednio w wierszu tabeli.

  • wprowadzenie zgłoszenia poprzez formularz

    Dołącza do zestawu kolejne zgłoszenie. Edycja informacji przeprowadzana jest na oddzielnym formularzu.

  • poprawienie zgłoszenia

    Umożliwia edycję informacji o zgłoszeniu. Edycja informacji przeprowadzana jest bezpośrednio w wierszu tabeli.

  • poprawienie zgłoszenia poprzez formularz

    Umożliwia edycję informacji o zgłoszeniu. Edycja informacji przeprowadzana jest na oddzielnym formularzu.

  • anulowanie zgłoszenia

    Anuluje zgłoszenie. Dla anulowanego zgłoszenia przestaje być dostępna operacja edycji informacji o zgłoszeniu. Operacji anulowania nie można wycofać.

  • zamknięcie zgłoszenia

    Zamknięcie zgłoszenia powoduje, że dany zapis przestaje być dostępny do dalszej edycji. Operacji zamknięcia nie można wycofać. Zamknięcie ustawia datę zamknięcia zgłoszenia. Operacja zamknięcia nie jest dostępna, jeśli nie wprowadzono informacji o decyzji podjętej przez dostawcę (serwis) a dotyczącej nieuznania bądź uznania i sposobu zaspokojenia roszczenia reklamacyjnego. Po zamknięciu zgłoszenia, do czasu zamknięcia rozliczenia dotyczącego tego zgłoszenia, możliwe jest uaktualnianie informacji zamieszczonych na zakładce /Zestawienie kosztów/.

  • zatwierdzenie rozliczenie

    Operacja jest dostępna tylko dla zgłoszeń, które zostały zamknięte lecz nie zostały jeszcze rozliczone i umożliwia zatwierdzenie (uznanie) rozliczenia. Operacji zatwierdzenia rozliczenia nie można wycofać. Przed zatwierdzeniem rozliczenia można wprowadzić bądź zaktualizować informacje dotyczące kosztów związanych z rozpatrzeniem (usunięciem skutków) reklamacji, daty rozliczenia oraz numeru noty obciążeniowej.

  • wyświetlenie szczegółów zgłoszenia

    Wyświetla formularz zawierający szczegółowe dane dotyczące zgłoszenia.

  • wydruki dokumentów

    Pozwala na wydrukowanie dokumentów związanych ze zgłoszeniem, które jest aktualnie wyróżnione w specyfikacji zgłoszeń. Jeśli przed wykonaniem wydruku ma być wyświetlony podgląd wydruku, polecenie należy wybrać przytrzymując naciśnięty klawisz [Shift].


Dziennik zgłoszeń wychodzących - zgłoszenia

Ta forma wyświetlania dziennika zgłoszeń wychodzących umożliwia przyglądanie zgłoszeń bez podziału na zestawy, do których zgłoszenie zostało przypisane. Każde zgłoszenie zawsze przypisane jest do konkretnego zestawu zgłoszeń (gdy do dziennika wprowadzone zostanie pojedyncze zgłoszenie, program NNR-Pro utworzy nowy zestaw i dołączy do niego wprowadzone zgłoszenie). Tak więc dla tej formy wyświetlania dziennika zgłoszeń wychodzących, wprowadzenie nowego zapisu do dziennika każdorazowo tworzy kolejny zestaw, do którego przypisuje wprowadzony zapis. Jeśli chcemy, by zestaw zawierał więcej niż jedno zgłoszenie, należy zmienić formę wyświetlania dziennika zgłoszeń wychodzących z listy zgłoszeń na wyświetlanie listy zestawów zgłoszeń.
Lista zgłoszeń oprócz standardowych operacji edycyjnych związanych z wprowadzeniem, poprawieniem oraz anulowaniem zapisu, udostępnia dodatkowe operacje takie jak:

  • zamknięcie zgłoszenia

    Zamknięcie zgłoszenia powoduje, że dany zapis przestaje być dostępny do dalszej edycji. Operacji zamknięcia nie można wycofać. Zamknięcie ustawia datę rozpatrzenia zgłoszenia. Operacja zamknięcia nie jest dostępna, jeśli nie wprowadzono informacji o decyzji podjętej przez dostawcę (kooperanta lub serwis) a dotyczącej nieuznania bądź uznania i sposobu zaspokojenia roszczenia reklamacyjnego. Po zamknięciu zgłoszenia, do czasu zamknięcia rozliczenia dotyczącego tego zgłoszenia, możliwe jest uaktualnianie informacji zamieszczonych na zakładce /Zestawienie kosztów/.

  • zatwierdzenie rozliczenia

    Operacja jest dostępna tylko dla zgłoszeń, które zostały zamknięte lecz nie zostały jeszcze rozliczone i umożliwia zatwierdzenie (uznanie) rozliczenia. Operacji zatwierdzenia rozliczenia nie można wycofać. Przed zatwierdzeniem rozliczenia można wprowadzić bądź zaktualizować informacje dotyczące kosztów związanych z rozpatrzeniem (usunięciem skutków) reklamacji, daty rozliczenia oraz numeru noty obciążeniowej.
a także dodatkowe operacje nieedycyjne takie jak:

  • wydruki dokumentów

    Pozwala na wydrukowanie dokumentów związanych ze zgłoszeniem, które jest aktualnie wyróżnione w dzienniku. Jeśli przed wykonaniem wydruku ma być wyświetlony podgląd wydruku, polecenie należy wybrać przytrzymując naciśnięty klawisz [Shift].
W tabeli dziennika zgłoszeń wychodzących informacja o statusie zgłoszenia wyświetlana jest na tle w kolorze przypisanym aktualnej wartości statusu zgłoszenia. Są to kolory w odcieniach:
  • żółtym dla nieprzeterminowanych zgłoszeń nierozpoczętych lub w trakcie realizacji,
  • czerwonym dla przeterminowanych zgłoszeń nierozpoczętych lub w trakcie realizacji,
  • zielonym dla zgłoszeń zrealizowanych,
  • niebieskim dla zgłoszeń zamkniętych (tylko jeśli operacja rozliczenia jest dostępna - gdy operacja rozliczenia nie jest dostępna, kolor tła jest taki jak kolor tła tabeli).
Dla zgłoszeń anulowanych oraz rozliczonych kolor tła jest taki jak kolor tła tabeli (standardowo biały).
Dla zapisów dziennika, którym wkrótce upłynie termin realizacji, odcień koloru tła wiersza tabeli zmienia się wraz ze zbliżaniem się terminu realizacji od żółtego do czerwonego. Moment rozpoczęcia sygnalizacji zbliżania się terminu realizacji zależy od priorytetu zgłoszenia. W parametrach programu zdefiniowane są liczby dni sygnalizacji zbliżania się terminu w zależności od priorytetu zgłoszenia (zdarzenia).
Zobacz też: Dziennik zgłoszeń wychodzących (informacje ogólne), Zgłoszenie reklamacyjne do dostawcy/serwisu


Zgłoszenie reklamacyjne do dostawcy/serwisu

Informacje o zgłoszeniu podzielone są na 3 bloki. Pierwszy blok zawiera dane ogólne dotyczące zgłoszenia takie jak numer i data zgłoszenia, termin i data rozpatrzenia, oznaczenia dokumentów itp. Drugi blok zawiera informacje o adresacie reklamacji (np. dostawcy towarów albo materiałów, kooperancie lub serwisie). Ostatni, trzeci blok zawiera szczegółowe informacje dotyczące reklamacji w tym np. numer i datę dokumentu wydania (sprzedaży), nazwę reklamowanego towaru, reklamowaną ilość i jednostkę miary.
W programie NNR-Pro zgłoszenia reklamacyjne mogą być przygotowane zarówno w zestawach jak i pojedynczo. Warto wiedzieć, że pola edycyjne z pierwszego i drugiego bloku opisane etykietą o tej samej treści na opisywanym formularzu i formularzu przeznaczonym do edycji zestawów zgłoszeń wychodzących (tj. informujące o sposobie przekazania, numerach i datach dokumentów: RMA, NCR, listu przewozowego oraz identyfikujące adresata reklamacji są wspólne dla zestawu i zgłoszenia. Ich aktualizację można przeprowadzić zarówno podczas edycji informacji o poszczególnych zgłoszeniach zestawu jak i podczas edycji informacji ogólnych o zestawie. Wyjątkiem jest pole wskazujące osobę odpowiedzialną. Można wskazać osobę odpowiedzialną za cały zestaw i niezależnie osoby odpowiedzialne za każde ze zgłoszeń z zestawu. Na rysunkach przedstawiających dwie formy wyświetlania dziennika zgłoszeń wychodzących (zobacz Dziennik zgłoszeń wychodzących) pola opisujące identyczne informacje w każdej z form wyświetlania dziennika zgłoszeń wychodzących są otoczone czerwonym owalem o blado-czerwonym wypełnieniu lub należą do bloku, którego nazwa otoczona jest czerwonym owalem o blado-czerwonym wypełnieniu.
Podczas przygotowania zgłoszenia konieczne jest wskazanie nazwy adresata reklamacji (o ile te dane nie zostały wskazane podczas przygotowania innego zgłoszenia z danego zestawu), wskazanie reklamowanego towaru na liście towarów (w zależności od pola - indeks towaru lub nazwa towaru - z którego wywołana zostanie operacja wyświetlenia listy towarów, towary na liście będą uporządkowane zgodnie z kolejnością alfabetyczną indeksów lub nazw towarów) oraz podanie ilości reklamowanej.
Program NNR-Pro automatycznie numeruje zestawy i zgłoszenia a także wprowadza daty rejestracji zestawu oraz zgłoszenia. Numery pojawiają się po zatwierdzeniu edycji (nadawanie numerów dopiero w chwili wprowadzenia zapisu do bazy danych, pozwala na uniknięcie luk w numeracji, występujących przy pracy wielostanowiskowej w sytuacji gdy na stanowisku, na którym operacja dopisania została wcześniej wywołana, ta operacja dopisania zostanie porzucona). Jako data terminu rozpatrzenia zgłoszenia podpowiadana jest data wyznaczona z daty zgłoszenia i standardowej liczby dni rozpatrzenia zgłoszenia określonej parametrem programu NNR-Pro o identycznej nazwie.
Dane adresata reklamacji są wybierane z kartoteki kontrahentów). Dane te dodatkowo mogą być uzupełnione informacją, opisującą dane kontaktowe osoby wskazanej przez adresata reklamacji do udzielania informacji na temat stanu przekazanego zgłoszenia reklamacyjnego.
Domyślnie przyjmowana jest jako ilość reklamowana jedna jednostka miary reklamowanego towaru.
O ile istnieje taka konieczność można wprowadzić informacje o dacie i numerze dokumentu wydania (sprzedaży).
W polu informacji dodatkowych można wprowadzić informacje identyfikujące np. model, nr seryjny, nr partii towaru.
Mimo, że wskazanie nazwy defektu w katalogu defektów nie jest wymagane, warto taką informację rejestrować chociażby dla celów analizy zgłoszeń.
Każde nowe zgłoszenie otrzymuje status informujący o tym, że żadne działania dotyczące rozpatrzenia zgłoszenia reklamacyjnego nie zostały podjęte. Zmiana statusu początkowo odbywa się automatycznie. Po zakończeniu operacji dopisania zgłoszenia reklamacyjnego nadawany jest mu status informujący, że zgłoszenie jest w trakcie realizacji. Wskazanie decyzji co do zgłoszenia reklamacyjnego, spowoduje że program NNR-Pro uzna zgłoszenie reklamacyjne za zrealizowane - wycofanie decyzji przywraca poprzedni status zgłoszenia. Poprzez polecenia menu, zgłoszenia zrealizowane dodatkowo mogą mieć zmieniony status na informujący o zamknięciu zgłoszenia a zgłoszenia zamknięte mogą mieć zmieniony status na informujący o rozliczeniu zgłoszenia.
By wizualnie wyróżnić informację o statusie zgłoszenia, jest ona wyświetlana na tle w kolorze przyporządkowanym na stałe do danego statusu.


Ewidencja powiadomień

W ewidencji powiadomień zapisywane są wszystkie wygenerowane w programie NNR-Pro powiadomienia, przeznaczone do wysłania. Mogą to być zarówno powiadomienia wygenerowane automatycznie, w oparciu o zdefiniowane w parametrach pracy programu NNR-Pro schematy powiadomień, jak też i powiadomienia wygenerowane wskutek wybrania przez użytkownika polecenia menu programu wywołującego operację wysłania powiadomienia.
Bezpośrednio po otwarciu dokumentu widoczny jest u góry ekranu panel filtrowania. Ustawione w nim warunki filtrowania powodują wyświetlanie w ewidencji powiadomień wyłącznie zapisów dotyczących niewysłanych powiadomień (za niewysłane i to bez względu na wskazany w warunkach filtrowania sposób wysłania powiadomienia, uznawane są również powiadomienia, dla których nie został wskazany żaden ze sposobów wysłania powiadomienia). Jeśli zamierzamy zobaczyć pozostałe zapisy należy odpowiednio zaktualizować warunki filtrowania i wywołać operację odświeżenia zawartości tabeli zapisów.
Uwaga: zaleca się ustawianie warunków filtrowania możliwe wąsko ograniczających zakres i jednocześnie zaleca się rezygnację z dostępnej opcji wyłączenia warunków filtrowania. W zależności od intensywności pracy i liczby aktywnych w programie NNR-Pro rodzajów powiadomień, na przestrzeni czasu liczba zapisów w ewidencji powiadomień może być znacząco duża, by w przypadku wyłączenia filtrowania istotnie obciążyć serwer SQL bądź motor bazy danych oraz sieć do czasu pobrania wszystkich zapisów.
W ewidencji powiadomień użytkownik może zaktualizować treść niewysłanych lub „częściowo” wysłanych powiadomień a także anulować powiadomienia jeszcze niewysłane. Bezpośrednie wprowadzanie do ewidencji powiadomień, przez użytkownika nowych powiadomień nie jest możliwe (nowe zapisy ewidencji powiadomień są wynikiem innych działań użytkownika w programie NNR-Pro np. związanych z aktualizacją treści zgłoszenia lub posłużenia się przez użytkownika operacją rozesłania powiadomienia do uczestników zespołu powołanego do rozwiązania danego problemu metodą 8D).
Edycja zapisu powiadomienia ogranicza się wyłącznie do aktualizacji treści powiadomienia oraz wskazania metod wysłania powiadomienia i aktualizacji informacji o adresie e-mail (gdy powiadomienie ma być przesłane na adres poczty elektronicznej) lub numerze telefonu (gdy powiadomienie ma być przesłane jako wiadomość SMS). Jeśli aktywne są obie metody wysyłania, a powiadomienie zostało już wysłanie za pomocą jednej z nich, zmiana aktywności tej metody wysyłania i związanej z nią treści informującej o adresie e-mail bądź numerze telefonu nie jest już możliwa. Nie jest również możliwe anulowanie takiego powiadomienia. Natomiast jeśli chcemy zrezygnować z przesłania powiadomienia niewykorzystaną metodą wysyłania, należy w trakcie edycji tego powiadomienia wyłączyć opcję wysłania powiadomienia dla tej metody wysyłania.
Ewidencja powiadomień zawiera dwa dodatkowe polecenia związane z wysyłaniem powiadomień:

  • wyślij powiadomienie

    Wysyła powiadomienia. W przypadku powiadomień wysłanych tylko jedną z metod wysyłania i aktywną alternatywną metodą wysyłania, powiadomienie zostanie wysłane wyłącznie metodą alternatywną. Polecenie wysłania powiadomienia nie jest aktywne jeśli powiadomienie zostało już wysłane każdą z aktywnych metod wysyłania bądź zostało anulowane.

  • wyślij wszystkie powiadomienia

    Wysyła wszystkie, dotychczas niewysłane oraz nie anulowane powiadomienia. W przypadku powiadomień wysłanych tylko jedną z metod wysyłania i aktywną alternatywną metodą wysyłania, powiadomienie będzie wysłane wyłącznie metodą alternatywną.


Generowanie powiadomień

Program NNR-Pro generuje powiadomienia w odpowiedzi na zaistniałe w programie zdarzenia. Wygenerowane powiadomienie jest wprowadzane do ewidencji powiadomień a następnie wysyłane. By powiadomienie zostało wprowadzone do ewidencji powiadomień, w parametrach pracy programu NNR-Pro musi być skonfigurowania i uaktywniona przynajmniej jedna z metod wysyłania powiadomień. Gdy żadna z metod wysyłania powiadomień nie jest aktywna, generowane powiadomienia nie będą zapisywane w ewidencji powiadomień a w konsekwencji nie będą wysyłane. Natomiast by powiadomienie zostało wygenerowane musi być włączone wysyłanie powiadomień związanych z danym zdarzeniem. Włączanie oraz konfigurowanie różnego rodzaju powiadomień umożliwiają parametry pracy programu NNR-Pro. Poniżej przedstawione zostały szczegóły dotyczące generowania powiadomień.
Temat wygenerowanego powiadomienia zostanie wyznaczony na podstawie definicji danego rodzaju powiadomienia, opisanej w parametrach pracy programu. Na początku tematu wstawiony zostanie, ujęty w nawiasy kwadratowe, identyfikator powiadomienia. Identyfikator powiadomienia składa się z identyfikatora źródła powiadomienia oraz ujętego w nawiasy okrągłe oznaczenia rodzaju powiadomienia (w przypadku powiadomień wysyłanych przez użytkownika, identyfikator powiadomienia nie zawiera ujętego w nawiasy okrągłe oznaczenia rodzaju powiadomienia). Identyfikator źródła powiadomienia opisuje:
  • numer zestawu (jeśli powiadomienie dotyczy całego zestawu),
  • numer zgłoszenia (jeśli powiadomienia dotyczy wyłącznie jednego zgłoszenia),
  • numer zgłoszenia i identyfikator działania (jeśli powiadomienie dotyczy działania), przy czym numeru zgłoszenia oddzielony jest od identyfikatora działania znakiem dwukropka a identyfikator działania składa się z oznaczenia kroku metody 8D w jakim działanie jest realizowane, ukośniej kreski „/” i numeru działania (liczby porządkowej przypisanej danemu działaniu w danym kroku metody 8D).
Oznaczenie rodzaju powiadomienia opisane jest jedną z poniższych wartości:
  • 102 - powiadamianie osoby odpowiedzialnej za zestaw o zbliżaniu się terminu rozpatrzenia zgłoszenia,
  • 103 - powiadamianie osoby odpowiedzialnej za zgłoszenie o zbliżaniu się terminu rozpatrzenia zgłoszenia,
  • 104 - powiadamianie osoby odpowiedzialnej za działanie o zbliżaniu się terminu wprowadzenia działania,
  • 111 - powiadamianie osoby odpowiedzialnej za zestaw o zmianie statusu zestawu,
  • 112 - powiadamianie osoby odpowiedzialnej za zestaw o zmianie statusu zgłoszenia,
  • 113 - powiadamianie osoby odpowiedzialnej za zgłoszenie o zmianie statusu zgłoszenia,
  • 114 - powiadamianie osoby odpowiedzialnej za działanie o zmianie statusu działania,
  • 115 - powiadamianie zgłaszającego (kontrahenta, dział) o zmianie statusu zgłoszenia,
  • 122 - powiadamianie osoby odpowiedzialnej za zestaw o ustaleniu decyzji dla zgłoszenia,
  • 123 - powiadamianie osoby odpowiedzialnej za zgłoszenie o ustaleniu decyzji dla zgłoszenia,
  • 125 - powiadamianie zgłaszającego (kontrahenta, dział) o ustaleniu decyzji dla zgłoszenia,
  • 135 - powiadamianie zgłaszającego (kontrahenta, dział) o sporządzeniu NCR/wysyłce (numerze listu przewozowego),
  • 161 - powiadamianie sprawcy uchybienia o wskazaniu go jako sprawcy uchybienia,
  • 261 - powiadamianie osoby, która odnotowała błąd w oprogramowaniu o jego poprawieniu,
  • 361 - powiadamianie oceniającego skuteczność o zakończeniu wszystkich działań,
  • 362 - powiadamianie oceniającego skuteczność o zakończeniu wszystkich tymczasowych działań powstrzymujących,
  • 363 - powiadamianie oceniającego skuteczność o zakończeniu wszystkich trwałych działań korekcyjnych,
  • 364 - powiadamianie oceniającego skuteczność o zakończeniu wszystkich działań zapobiegawczych,
  • 501 - powiadamianie uczestników zespołu o zaktualizowaniu informacji o zgłoszeniu.
Ponadto, na podstawie definicji danego rodzaju powiadomienia, opisanej w parametrach pracy programu NNR-Pro ustalane zostaną: treść wygenerowanego powiadomienia, jego typ (a na podstawie typu powiadomienia, w oparciu o dane z zestawu, zgłoszenia lub działania wyznaczone zostaną: nazwa, numer telefonu oraz adres e-mail odbiorcy lub odbiorców powiadomienia) oraz sposób wysłania powiadomienia (w tym metoda wysłania wiadomości e-mail).
W tytule bądź treści powiadomienia każdy symbol rozpoczynający się od znaku zapytania, wymienionego poniżej słowa i zakończony znakiem zapytania zostanie zastąpiony ujętą w cudzysłów, adekwatną, rzeczywista informacją:
  • termin - terminem rozpatrzenia zgłoszenia (w przypadku powiadomień dotyczących zbliżania się terminu rozpatrzenia zgłoszenia),
  • termin - terminem wprowadzenia działania (w przypadku powiadomień dotyczących zbliżania się terminu wprowadzenia działania),
  • status - statusem zestawu (w przypadku powiadomień dotyczących zmiany statusu zestawu),
  • status - statusem zgłoszenia (w przypadku powiadomień dotyczących zmiany statusu zgłoszenia),
  • status - statusem działania (w przypadku powiadomień dotyczących zmiany statusu działania),
  • decyzja - decyzją (w przypadku powiadomień dotyczących zmiany decyzji),
  • numer - NCR/numerem listu przewozowego (w przypadku powiadomień dotyczących sporządzenia NCR/wysyłki).
W przypadku powiadomień dotyczących zakończenia wszystkich działań, umieszczona w tytule sekwencja rozpoczynająca się od znaku nawiasu kwadratowego „[”i zakończona znakiem nawiasu kwadratowego „]”, zawierająca wewnątrz oddzielone znakiem ukośniej kreski „/” zwroty opisujące kolejno działania: wszystkie, powstrzymujące, korekcyjne i zapobiegawcze, zostanie przekształcona w taki sposób by treść tytułu była zgodna wartością liczbową opisującą oznaczenie rodzaju powiadomienia.
Powiadomienia dotyczące terminu generowane są podczas zakończenia działania programu NNR-Pro na dowolnym ze stanowisk (w dniu, w którym program NNR-Pro nie był uruchomiony na żadnym stanowisku, nie zostanie wygenerowane żadne powiadomienie dotyczące terminu). Podczas zamykania programu, dla wszystkich zgłoszeń nierozpatrzonych, program sprawdza czy liczba dni pozostałych do wykonania zdarzenia jest równa lub mniejsza od liczby dni sygnalizacji zbliżania się terminu dla danej kategorii zdarzenia. Liczba dni pozostałych do wykonania zdarzenia to w przypadku zgłoszeń - liczba dni pozostałych do terminu rozpatrzenia zgłoszenia a w przypadku działań - liczba dni pozostałych do terminu wprowadzenia działania. Liczbę dni sygnalizacji zbliżania się terminu dla danej kategorii zdarzenia, program ustala w oparciu o priorytet zgłoszenia na podstawie wartości parametrów pracy programu (w parametrach pracy programu NNR-Pro można ustalić liczbę dni sygnalizacji zbliżania się terminu dla każdej z trzech kategorii zdarzenia: tj. zwykłego, pilnego i krytycznego). Powiadomienie zostanie wygenerowane, jeśli przytoczony powyżej warunek jest prawdziwy a powiadomienie dotychczas nie zostało jeszcze wygenerowane. Powiadomienia przestaną być generowane, jeśli termin już upłynie. W zależności od ustawień programu NNR-Pro powiadomienia mogą być generowane codziennie w całym okresie sygnalizacji zbliżania się terminu zdarzenia (ostatni raz powiadomienie będzie mogło być wygenerowane w dniu, w którym termin upływa) lub jednokrotnie w dniu, w którym po raz pierwszy przytoczony powyżej warunek zostanie spełniony.
Pozostałe powiadomienia (tzn. nie dotyczące terminu) są generowane po zakończeniu edycji zgłoszenia, jeśli w trakcie tej edycji ulegnie zmianie informacja wymagająca wysłania powiadomienia:
  • zmieni się status zestawu, zgłoszenia lub działania,
  • zakończone zostały wszystkie tymczasowe działania powstrzymujące, trwałe działania korekcyjne lub działania zapobiegawcze, zgodnie z definicją powiadomienia w ramach tych grup lub ogólnie (jeśli po wygenerowaniu powiadomienia, zostaną wprowadzone jakieś dodatkowe działania i następnie zostaną one zakończone, powiadomienie zostanie ponownie wygenerowane),
  • ustalona lub zmieniona zostanie decyzja (wycofanie decyzji również spowoduje wygenerowania powiadomienia),
  • wprowadzony lub zmieniony zostanie numer listu przewozowego albo data jego sporządzeniu (skasowanie numeru listu przewozowego lub daty jego sporządzenia nie spowoduje wygenerowania powiadomienia),
  • ustalona lub zmienione zostaną dane sprawcy uchybienia (usunięcie danych sprawcy uchybienia nie spowoduje wygenerowania powiadomienia),
  • wskazane lub zmienione zostaną dane osoby, która poprawiła błąd (usunięcie danych osoby, która poprawiła błąd nie spowoduje wygenerowania powiadomienia),
  • zmienione zostaną jakiekolwiek dane ze zgłoszenia dotyczącego niezgodności usuwanej metodą 8D.


Wysyłanie powiadomień

Każde powiadomienie wprowadzane do ewidencji powiadomień, np. przez operację generowania powiadomień, jest natychmiast wysyłane. Jeśli wysłanie powiadomienia się powiedzie, w ewidencji powiadomień odnotowana zostanie data wysłania powiadomienia. Jeśli wysłanie powiadomienia nie powiedzie się, można korzystając z odpowiednich poleceń menu ewidencji powiadomień, wymusić ponowną próbę wysłania powiadomienia. Wcześniej jednak należy ustalić przyczynę niepowodzenia operacji wysłania powiadomienia. Jeśli wysłanie powiadomienia nie mogło być wykonane z powodu braku bądź niewłaściwej informacji o adresie e-mail (gdy powiadomienie ma być przesłane na adres poczty elektronicznej) lub braku bądź niewłaściwej informacji o numerze telefonu (gdy powiadomienie ma być przesłane jako wiadomość SMS) należy wprowadzić lub poprawić adres e-mail bądź numer telefonu. W pozostałych przypadkach należy sprawdzić parametry dotyczące wysyłania np. parametry programu NNR-Pro definiujące wewnętrznego klienta pocztowego.
Jeśli powiadomienie ma być przesłane zarówno za pomocą poczty elektronicznej jak i wiadomości SMS, data wysłania powiadomienia odnotowywana jest osobno dla każdej z tych metod wysyłania. Wówczas powiadomienie, które zostało wysłane tylko za pomocą jednej z tych metod wysyłania, może być w dalszym ciągu wysłane przy użyciu alternatywnej metody wysyłania.
Przesłanie powiadomienia na adres poczty elektronicznej może być wykonane za pomocą domyślnego programu pocztowego lub za pomocą wewnętrznego klienta pocztowego. Jeśli w programie NNR-Pro obie metody są aktywne, wówczas program w pierwszej kolejności spróbuje wysłać powiadomienie za pomocą wewnętrznego klienta pocztowego. Tylko, jeśli ta próba się nie powiedzie, program wykona operację wysłania powiadomienia za pomocą domyślnego programu pocztowego. Wysyłanie powiadomień na adres poczty elektronicznej tylko za pomocą jednej z wymienionych metod, zapobiega powielaniu wiadomości, które w takim przypadku mogło by być odebrane przez adresata wiadomości jako spam.
Operacja przesyłania powiadomienia za pomocą domyślnego programu pocztowego, spowoduje uruchomienie programu pocztowego a w nim wywołana zostanie operacja utworzenia nowej wiadomości, w której dane odbiorcy (adresata wiadomości), temat oraz treść zostaną wypełnione przez program NNR-Pro. Tylko od użytkownika zależy czy zapisze taką wiadomość w programie pocztowym, a następnie ją wyśle. Ponadto przed zapisaniem wiadomości, użytkownik może dowolnie zmienić dane adresata, temat oraz treść wiadomości. Program NNR-Pro nie ma możliwości monitorowania pracy użytkownika w programie pocztowym. Dlatego bez względu na dalszą akcję użytkownika w programie pocztowym, program NNR-Pro uzna taką wiadomość za wysłaną i odnotuje datę wysłania oraz informację o metodzie wysłania wiadomości e-mail.
Jeśli z jakiś powodów chcemy mieć gwarancję przesłania powiadomienia na adres poczty elektronicznej, w postaci wygenerowanej w programie NNR-Pro albo nie chcemy by powiadomienia były zapisywane w programie pocztowym lub też chcemy by stwierdzenie przez program NNR-Pro faktu wysłania powiadomienia opierało się na informacji o wysłaniu wiadomości przekazanej przez serwer poczty, należy w programie NNR-Pro uaktywnić wysyłanie powiadomień za pomocą wewnętrznego klienta pocztowego. Użycie wewnętrznego klienta pocztowego wymaga wprowadzania w parametrach pracy programu NNR-Pro informacji o konfiguracji serwera poczty wychodzącej takich jak: nazwa serwera, port, ustawienia zabezpieczeń (metoda uwierzytelniania). Wysyłanie powiadomień za pomocą wewnętrznego klienta pocztowego odbywa się bez udziału użytkownika, poprzez bezpośrednią komunikację programu NNR-Pro z serwerem poczty wychodzącej.
Również wysyłanie wiadomości SMS nie wymaga udziału użytkownika a odbywa się poprzez bezpośrednią komunikację programu NNR-Pro z bramką SMS. Tekst wiadomości składa się z nazwy nadawcy (podpisu), ukośnej kreski „/” i tematu powiadomienia. Jeśli w parametrach pracy programu NNR-Pro opisujących wysyłanie powiadomień za pomocą wiadomości SMS, uaktywniono dołączanie pierwszej linii treści powiadomienia, do tekstu wiadomości, po spacji, dołączona zostanie pierwsza linia treści powiadomienia. Mając to na uwadze można w parametrach pracy NNR-Pro odpowiednio zdefiniować temat i treść każdego powiadomienia w kontekście wysłania powiadomienia na adres poczty elektronicznej oraz za pomocą wiadomości SMS. Całkowita długość tekstu wysyłanej wiadomości SMS zostanie ograniczona do maksymalnej liczby znaków określonej w parametrach pracy programu NNR-Pro opisujących wysyłanie powiadomień za pomocą wiadomości SMS (domyślnie 160 znaków). Ponadto jeżeli parametr opisujący wysyłanie powiadomień za pomocą wiadomości SMS ma uaktywnioną opcję zamiany znaków narodowych na łacińskie, wszystkie znaki narodowe (np. ą, ę) zostaną zastąpione ich odpowiednikami łacińskimi (czyli: ą zostanie zastąpione a, ę zostanie zastąpione e itd.) - uaktywnienie tej opcji może wynikać ze specyfikacji interfejsu bramki SMS lub też być wprowadzone przez użytkownika w celu zagwarantowania wysyłania powiadomienia tylko przy użyciu jednego SMS-a (standardowo w postaci jednego SMS-a przesyłane są wiadomości tekstowe nie większe niż 160 znaków, natomiast użycie w wiadomości SMS znaków narodowych zwiększa liczbę przesyłanych bajtów informacji tzn. jest ona większa od liczby znaków).


Dokumentacja pomocnicza

Dokumentacja pomocnicza zawiera informacje ułatwiające wypełnianie innych dokumentów i analizę danych. Program NNR-Pro w ramach tej dokumentacji udostępnia:

  • kartotekę kontrahentów,
  • katalog defektów
oraz listy:
  • towarów,
  • działów,
  • pracowników.

Lista różni się od pozostałych dokumentów przeznaczonych do prezentacji informacji z bazy danych sposobem edycji (edycja zapisów listy odbywa się bezpośrednio w wierszu tabeli prezentującej informacje z bazy danych).


Kartoteka kontrahentów

Kartoteka kontrahentów przeznaczona jest do gromadzenia danych dotyczących zarówno klientów zgłaszających reklamację - niezgodność (zob. rejestr zgłoszeń przychodzących) jak i dostawców, kooperantów, serwisów którym zgłaszamy reklamację (zob. dziennik zgłoszeń wychodzących).
Dane do kartoteki kontrahentów można zaimportować z zewnątrz (z innych programów np. arkusza kalkulacyjnego) co może przyśpieszyć i ułatwić wdrożenie programu NNR-Pro.

Podczas wprowadzania danych nowego kontrahenta wymagane jest podanie nazwy (nazwy skróconej - ułatwia ona identyfikację kontrahenta w programie NNR-Pro) oraz pełnej nazwy (nazwy w oficjalnym brzmieniu - pojawia się ona na wydrukach dokumentów). Wprowadzenie pozostałych informacji nie jest wymagane.
Program umożliwia wprowadzanie numerów NIP kontrahentów (numerów identyfikacyjnych VAT) zarówno w formacie krajowym (gdy kontrahent jest zarejestrowany jako „podatnik podatku od towarów i usług oraz podatku akcyzowego”), jak i obowiązującym w Unii Europejskiej (gdy kontrahent jest zarejestrowany jako „podatnik VAT UE”). Gdy numer NIP wprowadzany jest w formacie krajowym, jego forma musi być zgodna z jednym z formatów: „999-99-99-999”, „999-99-999-99” lub „999-999-99-99” (zgodnie z przyjętą w Polsce przez urzędy skarbowe formą zapisywania numeru NIP), gdzie znak „9” odpowiada dowolnej cyfrze. Program akceptuje również wprowadzenie krajowego numeru NIP z pominięciem wszystkich myślników.
Wprowadzając numer NIP dla kontrahentów będących podatnikami VAT UE, należy wskazać kod kraju i następnie wprowadzić numer NIP. Wprowadzony numer NIP jest sprawdzany przez program. Reguły jakie wykorzystywane są podczas sprawdzania numerów NIP, opisuje poniższa tabela.

Kod kraju | Nazwa kraju | Format | Dodatkowe uwagi
PL | Polska | PL9999999999 | 10 cyfr
 | inne kraje | format nie jest zaimplementowany | nie więcej niż 12 cyfr

Weryfikację numerów identyfikacyjnych VAT kontrahentów państw członkowskich Unii Europejskiej, można przeprowadzić np. na stronie internetowej Dyrekcji Generalnej Komisji Europejskiej ds. podatków i unii celnej. Jeśli numer NIP został wprowadzony w formacie krajowym, to po uzupełnieniu numeru NIP o kod kraju, program NNR-Pro będzie wyświetlał ten numer z pominięciem znaków myślnika. Usunięcie dla takiego numeru, informacji o kodzie kraju (poprzez naciśnięcie klawisza [Backspace]), przywraca wcześniejszą formę wyświetlania numeru NIP.

Poprawienie pełnej nazwy lub danych adresowych kontrahenta w kartotece kontrahentów, nie zmieni analogicznych informacji o kontrahencie zachowanych w rejestrze zgłoszeń przychodzących lub dzienniku zgłoszeń wychodzących, o ile dany zapis rejestru lub dziennika nie zostanie poddany edycji, podczas której dane kontrahenta będą ponownie wybrane z kartoteki.
Natomiast poprawienie nazwy kontrahenta, wpłynie na wszystkie zapisy bazy danych. Będą one wyświetlały zaktualizowaną nazwę kontrahenta. Ułatwia to prawidłową identyfikację kontrahenta np. w wynikach analiz - bez względu na aktualną nazwę (która np. obecnie brzmi nieco inaczej niż w przeszłości przykładowo ABC Spółka Cywilna obecnie ABC SA) zapisy odnoszące się do danego kontrahenta będą łatwo identyfikowalne.
Nie można usunąć z kartoteki informacji o kontrahencie, jeśli w rejestrze zgłoszeń przychodzących lub dzienniku zgłoszeń wychodzących, są zapisy odwołujące się do danego kontrahenta.


Lista działów

Lista działów zawiera informacje wykorzystywane podczas rejestracji zgłoszeń niezgodności wewnętrznych. Informacje o działach mogą być również wykorzystane na potrzeby edycji listy pracowników.
Podczas wprowadzania danych o dziale wymagane jest podanie jedynie nazwy działu. Wprowadzenie pozostałych informacji nie jest wymagane.
Poprawienie nazwy działu na liście działów, wpłynie na wszystkie zapisy rejestru zgłoszeń przychodzących i listy pracowników - będą one wyświetlały zaktualizowaną nazwę działu.
Nie można usunąć informacji o dziale z listy działów, jeśli w rejestrze zgłoszeń przychodzących są zapisane zgłoszenia przekazane przez ten dział lub na liście pracowników odnotowane są dane pracownika z tego działu.
Zobacz też: edycja zapisów listy


Lista pracowników

Lista pracowników pozwala na przechowywanie podstawowych danych na temat pracownika. Zadaniem listy jest ułatwienie edycji pól innych dokumentów przeznaczonych do przechowywania informacji opisującej pracownika.
W programie NNR-Pro informacje o pracownikach zawarte na liście pracowników wykorzystywane są podczas wskazywania danych pracownika:
  • odpowiedzialnego za rozpatrzenie całego zestawu zgłoszeń,
  • odpowiedzialnego za rozpatrzenie pojedynczego zgłoszenia,
  • będącego sprawcą uchybienia,
  • oceniającego skuteczność rozwiązania niezgodności.
Lista pracowników jest też pomocna podczas ustalania składu zespołu powołanego do rozwiązania niezgodności metodą 8D.
Podczas wprowadzania danych pracownika wymagane jest podanie jedynie nazwiska i imienia pracownika. Wprowadzenie pozostałych informacji nie jest wymagane. Numer (ewidencyjny) pracownika musi być unikalny. Jeśli podczas wyprowadzania danych pracownika nie zostanie podany numer pracownika, program przypisze do wprowadzanych danych kolejny wolny numer (tj. numer o 1 większy od największego numeru dotychczas odnotowanego na liście pracowników).
Mimo, że lista pracowników przeznaczona jest do przechowywania informacji o pracownikach, by ułatwić ustalanie składu zespołu powołanego do rozwiązania niezgodności metodą 8D (w skład zespołu mogą być np. powołani eksperci z zewnątrz), uwzględniono możliwość przechowywania na liście pracowników, informacji o osobach nie będących pracownikami z zachowaniem podziału na pracowników i osoby z zewnątrz. By wyróżnić na liście pracowników osoby z zewnątrz należy przydzielić im ujemny numer ewidencyjny. Numer ten można wprowadzić samemu lub skorzystać z funkcji wyznaczającej kolejny numer ujemny (numer o 1 mniejszy od najmniejszego niedodatniego numeru dotychczas odnotowanego na liście pracowników). By wywołać funkcję wyznaczającą kolejny numer, należy w trakcie dopisania danych osoby z zewnątrz, gdy kursor znajduje się w polu numeru pracownika, nacisnąć klawisz [F11].
Poprawienie nazwiska lub imienia pracownika na liście pracowników, wpłynie na wszystkie zapisy bazy danych programu NNR-Pro - będą one wyświetlały zaktualizowane dane pracownika.
Numer pracownika można zmienić tylko jeśli pozostałe informacje w bazie danych nie zawierają odwołania do aktualnego numeru pracownika.
Nie można usunąć z listy pracowników informacji o pracowniku, jeśli baza danych zawiera zapisy odwołujące się do danych tego pracownika.
Zobacz też: edycja zapisów listy


Katalog defektów

Katalog defektów zawiera informacje dotyczące zidentyfikowanych defektów (wad). Identyfikacja defektów ułatwia późniejszą analizę zgłoszeń w kontekście defektów. Ponadto tworzony katalog defektów może być bardzo przydatny podczas ustalania przyczyn dla nowych niezgodności lub reklamacji odnotowywanych w rejestrze zgłoszeń przychodzących.
By zwiększyć efektywność analizy, defekty mogą być usystematyzowane poprzez podanie kategorii oraz podkategorii defektu. Opis kategorii oraz podkategorii można ustalić w parametrach programu NNR-Pro.
Defekt może być przypisany do jednego z towarów pamiętanych na liście towarów (w zależności od pola - indeks towaru lub nazwa towaru - z którego wywołana zostanie operacja wyświetlenia listy towarów, towary na liście będą uporządkowane zgodnie z kolejnością alfabetyczną indeksów lub nazw towarów).
Ponadto na informacje o defekcie składają się: opis problemu, opis następstw defektu, informacje o przyczynach defektu i wykaz załączników zawierający np. zdjęcia defektu, wydruki z rejestratorów prezentujące stan obiektu w chwili wystąpienia defektu, dokumenty tekstowe zawierające raporty (wykaz zawiera nazwy dokumentów, nazwy plików w których dokument jest przechowywany wraz ze ścieżką dostępu, daty dołączenia dokumentów do wykazu oraz jeśli z rozszerzenia nazwy pliku nie wynika nazwa programu, w którym dokument może być wyświetlony, nazwy plików programów - przeglądarek dokumentów wraz ze ścieżką dostępu).
Podczas wprowadzania danych o defekcie wymagane jest podanie krótkiego opisu (nazwy) defektu i określenie kategorii oraz podkategorii defektu (domyślnie jako kategoria i podkategoria defektu przyjmowane są pierwsze zdefiniowane w parametrach programu opisy kategorii i podkategorii). Wprowadzenie pozostałych informacji nie jest wymagane.
Poprawienie opisu (nazwy) defektu w katalogu defektów, wpłynie na wszystkie zapisy bazy danych - będą one wyświetlały zaktualizowany opis (nazwę) defektu.
Nie można usunąć z katalogu informacji o defekcie, jeśli baza danych zawiera zapisy odwołujące się do usuwanego defektu.
Informacje o przyczynach wyświetlane są w tabeli. Operacje możliwe do wykonania na tej tabeli można zobaczyć wyświetlając jej menu podręczne (tj. klikając na tabeli prawym przyciskiem myszki). Menu podręczne tabeli umożliwia:

  • wprowadzenie wpisu

    Wprowadzając informacje o przyczynie defektu należy podać opis przyczyny, określić procentowy udział przyczyny w powstaniu defektu (sumaryczny udział wszystkich przyczyn ujętych w tabeli w zaistnieniu defektu nie może przekroczyć 100%) oraz określić charakter źródła (sklasyfikować źródło) przyczyny. Klasyfikacja przyczyn defektów umożliwia późniejszą analizę zgłoszeń w tym kontekście.

  • poprawienie wpisu

    Umożliwia poprawienie informacji o przyczynie defektu.

  • usunięcie wpisu

    Usuwa informację o przyczynie defektu.

  • wyświetlenie szczegółów

    Wyświetla formularz zawierający szczegółowe dane dotyczące przyczyny.


Lista towarów

Lista towarów zawiera podstawowe informacje o reklamowanych towarach (usługach) i jest wykorzystywana podczas wprowadzania informacji o zgłoszeniu niezgodności lub reklamacji. Informacje o towarze mogą być również przypisane do zapisów katalogu defektów.
Podczas wprowadzania danych o towarze wymagane jest podanie jedynie indeksu i nazwy towaru. Wprowadzenie pozostałych informacji nie jest wymagane. Listę używanych jednostek miar można ustalić w parametrach programu NNR-Pro. Domyślną jednostką miary jest pierwsza zdefiniowana jednostka miary
Indeks towaru można zmienić tylko jeśli pozostałe informacje w bazie danych nie zawierają odwołania do aktualnego indeksu.
Poprawienie nazwy towaru na liście towarów, wpłynie na wszystkie zapisy bazy danych - będą one wyświetlały poprawioną nazwę towaru.
Zmiana jednostki miary na liście towarów nie wpływa na zapisy rejestru zgłoszeń przychodzących i dziennika zgłoszeń wychodzących , o ile dany zapis rejestru lub dziennika nie zostanie poddany edycji, podczas której dane towaru będą ponownie wybrane z listy towarów.
Nie można usunąć informacji o towarze z listy towarów, jeśli baza danych zawiera zapisy odwołujące się do danych usuwanego towaru.
Zobacz też: edycja zapisów listy


Raporty - analiza danych

Istotnym aspektem gromadzenia danych jest możliwość ich analizy. W programie NNR-Pro raporty (wyniki analiz) prezentowane są tabelarycznie oraz na wykresie. Raport można wydrukować (można wydrukować pełen raport lub sam wykres). Lista analiz udostępnianych w programie NNR-Pro nie jest zamknięta i może być rozbudowana.
Przed wykonaniem analizy należy ustalić warunki jej wykonania, tj. zakres, ograniczenia oraz sposób prezentacji.
Zakres opisuje jakie dane będą analizowane. Mogą być analizowane dane z aktualnie wyświetlanej dokumentacji lub dane wczytane z bazy danych wyłącznie w celu ich analizy. W pierwszym przypadku analiza uwzględnia nałożone warunki filtrowania ograniczające zakres aktualnie wyświetlanych zgłoszeń (tj. określony podczas otwierania dokumentacji zakres udostępnianej dokumentacji oraz nałożone podczas przeglądania dokumentacji warunki selekcji informacji i aktualnie wskazany wariant wyświetlanych zapisów). W drugim przypadku analizowane będą wszystkie zapisy z bazy danych dotyczące zgłoszeń, dla których data zgłoszenia należy do zadanego przedziału (jeśli jedna z dat okresu nie ma być określona, należy odhaczyć pole wyboru występujące przed tą datą).
Ograniczenia pozwalają uściślić analizę do wybranego defektu, towaru, kontrahenta albo działu, aktualnego statusu zgłoszenia lub podjętej decyzji. Ocena zgodności (identyfikacja) danych wybranego kontrahenta i danych kontrahenta ze zgłoszenia może być przeprowadzana w oparciu numer NIP. Taki sposób identyfikacji danych kontrahenta umożliwia analizę zgłoszeń dotyczących różnych kontrahentów będących w rzeczywistości oddziałami (lub innymi jednostkami terenowymi) jednego kontrahenta (podmiotu gospodarczego). By ograniczyć analizę zgłoszeń do danych tego kontrahenta, wystarczy wskazać w kartotece kontrahentów dane dowolnego oddziału (lub innej jednostki terenowej) i zaznaczyć opcję identyfikacji danych kontrahenta w oparciu o numer NIP. Niektóre z analiz mają szerszy zakres ograniczeń np. dodatkowo umożliwiają przeanalizowanie wyłącznie zgłoszeń przeterminowanych. Ograniczenia agregują się, tzn analizowane zgłoszenia muszą spełniać wszystkie nałożone ograniczenia.
Prezentacja wyników może uwzględniać podział na okresy odnoszące się do kolejnych lat, kwartałów, miesięcy, tygodni albo dni lub też być przedstawiona bez podziału na okresy. W zależności od wybranego wariantu, podział wyników na okresy może być wykonany w oparciu o datę zgłoszenia, datę dokumentu na podstawie którego zgłoszenie zostało przyjęte lub też datę dokumentu sprzedaży albo wydania reklamowanego towaru.
Wyniki analizy przedstawiane są tabelarycznie lub na wykresie.
Tabelarycznie wyniki prezentowane są za pomocą dwóch tabel: tabeli głównej zawierającej zasadnicze informacje oraz tabeli dodatkowej zawierającej informacje szczegółowe dotyczące wybranego zapisu tabeli głównej. Zapisy tabeli głównej mogą być uporządkowane (rosnąco lub malejąco) wg każdej z kolumn tabeli. Ponadto gdy prezentacja wyników uwzględnia podział na okresy, a kolumną wskazaną do uporządkowania wyników nie jest kolumna informująca o okresie, informacja o okresie przyjmowana jest jako uzupełniające kryterium uporządkowania zapisów tabeli głównej. Menu podręczne tabeli głównej zawiera polecenia:

  • zobacz podgląd wydruku

    Wyświetla podgląd wydruku raportu. Podczas wyświetlania podglądu, można wywołać operację wydruku. Wykonanie wydruku poprzedza wybór ustawień wydruku, umożliwiający zmianę ustawień aktywnej drukarki. Przed wykonaniem wydruku można też określić numery stron jakie mają być wydrukowane.

  • drukuj

    Drukuje raport. Wykonanie wydruku poprzedza wybór ustawień wydruku umożliwiający zmianę ustawień aktywnej drukarki oraz określenie charakteru operacji wydruku i jej parametrów. By ograniczyć wydruk tylko do wybranych stron należy wywołać operację podglądu wydruku - tylko wywołanie operacji wydruku podczas wyświetlania podglądu wydruku umożliwia określenie numerów stron jakie mają być wydrukowane.

  • pokaż dane szczegółowe

    Polecenia umożliwia ukrycie lub wyświetlenie tabeli zawierającej dane szczegółowe.
W oparciu o dane prezentowane w tabeli głównej, generowany jest wykres. Pozycje na wykresie uporządkowane tak jak w tabeli głównej (zmiana porządku wyświetlania danych w tabeli głównej spowoduje ponowne wygenerowanie wykresu, na którym kolejność pozycji odpowiada aktualnemu porządkowi wyświetlania danych w tabeli głównej). Na potrzeby operacji generowania wykresów, można określić wartość graniczną ustalającą, które zapisy tabeli głównej będą uwidocznione na wykresie jako jedna pozycja (zmiana wartości granicznej spowoduje ponowne wygenerowanie wykresu). Taka pozycja wykresu sumuje informacje z zapisów tabeli głównej, które nie przekraczają wartości granicznej (są mniejsze lub równe wartości granicznej) co poprawia czytelność wykresu. Wyświetlony może zostać wykres słupkowy lub kołowy. Na wykresie kołowym można zmienić kąt obrotu, celem poprawienia czytelności wykresu. Menu podręczne wykresu zawiera polecenia:

  • zobacz podgląd wydruku wykresu

    Wyświetla podgląd wydruku wykresu. Podczas wyświetlania podglądu, można wywołać operację wydruku. Wykonanie wydruku poprzedza wybór ustawień wydruku, umożliwiający zmianę ustawień aktywnej drukarki.

  • drukuj wykres

    Drukuje wykres. Wykonanie wydruku poprzedza wybór ustawień wydruku umożliwiający zmianę ustawień aktywnej drukarki oraz określenie charakteru operacji wydruku i jej parametrów.

  • ukryj pasek właściwości wykresu

    Polecenia umożliwia ukrycie lub wyświetlenie paska właściwości wykresu. Ukrycie paska wykresu zwiększa obszar ekranu przeznaczony na wyświetlenie wykresu i może poprawić czytelność wykresu. Ukrycie paska właściwości wykresu można również wykonać poprzez podwójne kliknięcie na pasku właściwości wykresu (podwójne kliknięcie w obszarze wyświetlania paska właściwości wykresu, przywraca wyświetlanie paska właściwości wykresu).

  • wykres słupkowy

    Przestawia rodzaj wykresu na wykres słupkowy.

  • wykres kołowy

    Przestawia rodzaj wykresu na wykres kołowy.
W programie NNR-Pro analizy są pogrupowane i przypisane są do jednej z trzech kategorii:
  • analiza ilości reklamowanej,
  • analiza kosztów,
  • analiza zgłoszeń.
Efekt pogrupowania analiz widoczny jest na liście wyboru, na której dla każdej z kategorii nazwy analiz wyświetlane są na tle w innym kolorze. Jednak zasadniczym następstwem przypisana analizy do danej kategorii, jest właściwa tylko dla danej kategorii prezentacja wyników.
Jeśli nazwa analizy na liście wyświetlana jest w kolorze szarym, analiza jest nieaktywna w użytkowanej wersji programu.


Analiza ilości reklamowanej

Analiza ilości reklamowanej umożliwia ocenę problemów związanych z reklamacjami (niezgodnościami) w skali ilościowej. Zasadniczym celem analiz przypisanych do tej kategorii jest ocena ilości reklamowanej w odniesieniu do kolejnych okresów czasowych. Program NNR-Pro umożliwia dodatkowo ocenę ilości reklamowanej w kontekście ilości dostarczonej (sprawdzonej) tj. wyliczenie udziału ilości reklamowanej w ilości dostarczonej lub sprawdzonej (udział w dostawach) i wyznaczenie współczynnika Ppm (parts per million).
Podczas analizy pomijane są zapisy, dla których informacja o ilości reklamowanej nie została odnotowana (niektóre formy rejestracji zgłoszeń reklamacyjnych, np. dotyczące usług takie jak zgłoszenie błędu w oprogramowaniu lub dotyczące zgłoszeń niezgodności wewnętrznych innych niż karta braków, nie umożliwiają wprowadzania informacji o ilości, w ich przypadku raporty dotyczące analiz ilości reklamowanej będą puste i w takich okolicznościach zamiast analiz dotyczących ilości reklamowanej należy korzystać z analiz dotyczących zgłoszeń).
Analiza ilości reklamowanej może być dodatkowo ograniczona wyłącznie do zgłoszeń z odnotowaną ilością dostarczoną. W takiej sytuacji tabela główna zawiera kolumnę z informacją o ilości dostarczonej, a w tabeli dodatkowej widoczna jest kolumna z informacją o ilości w dostawie.
Dołączenie do wyników analizy informacji o udziale ilości reklamowanej w ilości dostarczonej (sprawdzonej) i współczynniku Ppm wymaga wyznaczenia sumarycznej (całkowitej) ilości dostarczonej. Sumaryczna ilość dostarczona określana jest odrębnie dla każdej jednostki miary i może być wyliczona na podstawie ilości w dostawie odnotowanej podczas rejestracji informacji o zgłoszeniu lub też wprowadzona podczas wyświetlenia podsumowania dla przygotowywanego raportu.
By wprowadzić lub zmienić informację o sumarycznej ilości dostarczonej należy przestawić tryb wyświetlania raportu na tabelę wyników i wywołać funkcję wyświetlenia podsumowania (np. poprzez naciśnięcie sekwencji klawiszy [Ctrl] + [S]), wskazać zapis podsumowania dotyczący jednostki miary, dla której informacja o sumarycznej ilości dostarczonej ma być zaktualizowana, włączyć operację poprawiania poprzez naciśnięcie sekwencji klawiszy [Ctrl] + [Enter], wprowadzić właściwą wartość sumarycznej ilości dostarczonej i zakończyć edycję poprzez naciśnięcie klawisza [Enter]. Po zatwierdzeniu zmiany zaktualizowane zostaną informacje dotyczące wartości udziału w dostawie i współczynnika Ppm.
Informacja o wartości współczynnika Ppm nanoszona jest na wykres, który jest też uzupełniany o dodatkowe elementy graficzne obrazujące wielkości sumarycznej ilości reklamowanej i sumarycznej ilości dostarczonej. By nie pogarszać czytelności całego wykresu, do wykresu kołowego legenda będzie dołączana tylko wówczas, gdy nie jest dołączana do wykresów informacja o współczynniku Ppm.
Ilość może być określona w różnych jednostkach miary. By nie pogarszać czytelności wykresu, wykres dotyczy tylko ilości w jednej jednostce miary. Na wykresie prezentowane są wyniki w takiej jednostce miary, w jakiej opisana jest ilość dla aktualnie wyróżnionego zapisu tabeli głównej raportu (zobacz informacje ogólne dotyczące raportów). Zmiana jednostki miary wynikająca z przestawienia wyróżnienia w tabeli głównej, spowoduje ponowne wygenerowanie wykresu.
Aktualnie program NNR-Pro udostępnia wymienione poniżej analizy dotyczące ilości reklamowanej:
  • ilość reklamowana w ujęciu ogólnym,
  • ilość reklamowana w rozbiciu na defekty,
  • ilość reklamowana w rozbiciu na towary,
  • ilość reklamowana w rozbiciu na zgłaszających.
Oprócz analiz dotyczących ilości reklamowanej w programie NNR-Pro dostępne są inne kategorie analiz: analizy dotyczące kosztów i analizy dotyczące zgłoszeń.


Ilość reklamowana w ujęciu ogólnym

Jest to podstawowa analiza należąca do kategorii analiz ilości reklamowanej. Przedstawia ona wyniki bez rozbicia na grupy identyfikowane w oparciu o pewne „cechy szczególne” zgłoszeń.
Jeśli wymagana jest dokładniejsza identyfikacja w wynikach niektórych „cech szczególnych” zgłoszeń, w programie NNR-Pro zaimplementowane zostały wymienione poniżej analizy dotyczące ilości reklamowanej, rozszerzające funkcjonowanie analizy podstawowej:
  • ilość reklamowana w rozbiciu na defekty,
  • ilość reklamowana w rozbiciu na towary,
  • ilość reklamowana w rozbiciu na zgłaszających.
Przedstawiona lista analiz ilości reklamowanej nie jest zamknięta i może być rozbudowana.
Jak przytoczono w informacjach ogólnych dotyczących analiz, zapisy tabeli głównej mogą być uporządkowane (rosnąco lub malejąco) wg każdej z kolumn tabeli, a uzupełniającym kryterium przyjętym do uporządkowania zapisów tabeli głównej może być informacja o okresie. Jeśli kryterium uzupełniające nie jest określone, a kolumną wskazaną do uporządkowania wyników nie jest kolumna informująca o ilości reklamowanej, informacja o ilości reklamowanej przyjmowana jest jako uzupełniające kryterium uporządkowania zapisów tabeli głównej.


Ilość reklamowana w rozbiciu na defekty

Analiza należy do kategorii analiz ilości reklamowanej i jest rozszerzeniem funkcjonowania analizy ilości reklamowanej w ujęciu ogólnym rozbijającym wyniki tej analizy na poszczególne defekty.
Zobacz też informacje ogólne dotyczące analiz.


Ilość reklamowana w rozbiciu na towary

Analiza należy do kategorii analiz ilości reklamowanej i jest rozszerzeniem funkcjonowania analizy ilości reklamowanej w ujęciu ogólnym rozbijającym wyniki tej analizy na poszczególne towary (usługi). Rozróżnianie towarów przeprowadzane jest w oparciu o indeks towaru.
Jak przytoczono w informacjach ogólnych dotyczących analiz, zapisy tabeli głównej mogą być uporządkowane (rosnąco lub malejąco) wg każdej z kolumn tabeli i dodatkowego kryterium uzupełniającego. Jeśli kryterium uzupełniające nie jest określone (prezentacja wyników nie uwzględnia podziału na okresy a kolumną wskazaną do uporządkowania wyników jest kolumna informująca o ilości reklamowanej), wówczas jeśli podczas wskazania kolumny informującej o ilości reklamowanej jako kolumny, wg której informacje w tabeli głównej będą uporządkowane został naciśnięty klawisz [Shift], kryterium uzupełniającym stanie się informacja o indeksie towaru, a jeśli klawisz [Shift] nie został naciśnięty, informacja o nazwie towaru.


Ilość reklamowana w rozbiciu na zgłaszających

Analiza należy do kategorii analiz ilości reklamowanej i jest rozszerzeniem funkcjonowania analizy ilości reklamowanej w ujęciu ogólnym rozbijającym wyniki tej analizy na poszczególnych kontrahentów i działy.
Ponieważ rejestrowane zgłoszenia mogą dotyczyć oddziału (lub innej jednostki terenowej) kontrahenta, raport może przypisywać do wspólnej grupy zgłoszenia dotyczące różnych oddziałów kontrahenta. By opisana sytuacja miała miejsce ocena zgodności (identyfikacja) danych wybranego kontrahenta i danych kontrahenta ze zgłoszenia musi być przeprowadzana w oparciu numer NIP (zobacz stosowny przełącznik w sekcji ograniczeń, dotyczący identyfikacji danych kontrahenta w oparciu o numer NIP). Jeśli identyfikacja danych kontrahenta przeprowadzana jest w oparciu o numer NIP, wówczas wszystkie zgłoszenia z odnotowanym takim samym numerem NIP, co prawda dotyczące różnych kontrahentów (w kontekście kartoteki kontrahentów) będących w rzeczywistości oddziałami (lub innymi jednostkami terenowymi) jednego kontrahenta (podmiotu gospodarczego), uznawane są za zgłoszenia dotyczące jednego kontrahenta. Jeśli opcja identyfikacji danych kontrahenta w oparciu o numer NIP nie będzie aktywna, wówczas raport będzie rozróżniał zgłoszenia dotyczące oddziałów traktując każdy oddział jako odrębnego kontrahenta.
Jak przytoczono w informacjach ogólnych dotyczących analiz, zapisy tabeli głównej mogą być uporządkowane (rosnąco lub malejąco) wg każdej z kolumn tabeli i dodatkowego kryterium uzupełniającego. Jeśli kryterium uzupełniające nie jest określone (prezentacja wyników nie uwzględnia podziału na okresy a kolumną wskazaną do uporządkowania wyników jest kolumna informująca o ilości reklamowanej), wówczas jeśli podczas wskazania kolumny informującej o ilości reklamowanej jako kolumny, wg której informacje w tabeli głównej będą uporządkowane został naciśnięty klawisz [Shift], kryterium uzupełniającym stanie się informacja o numerze NIP, a jeśli klawisz [Shift] nie został naciśnięty, informacja o nazwie kontrahenta lub działu.


Analiza kosztów

Analiza kosztów umożliwia ocenę problemów związanych z reklamacjami (niezgodnościami) w skali wartościowej. Zasadniczym celem analiz przypisanych do tej kategorii jest ocena kosztów reklamacji w odniesieniu do kolejnych okresów czasowych. Podczas analizy pomijane są zapisy, dla których żadna z informacji o: kosztach wadliwych towarów, kosztach transportu, kosztach przepakowania, kosztach selekcji wewnętrznej, kosztach selekcji zewnętrznej lub kosztach innych nie została odnotowane (adekwatne pole jest puste - pole nie jest puste gdy w polu wpisana jest dowolna wartość łącznie z zerem).
Aktualnie program NNR-Pro udostępnia wymienione poniżej analizy dotyczące kosztów:
  • koszty w ujęciu ogólnym,
  • koszty w rozbiciu ma wariant decyzji (oszacowanie strat),
  • koszty w rozbiciu na sprawców uchybienia.
Oprócz analiz dotyczących kosztów w programie NNR-Pro dostępne są inne kategorie analiz: analizy dotyczące ilości reklamowanej i analizy dotyczące zgłoszeń (zobacz też informacje ogólne dotyczące raportów).


Koszty w ujęciu ogólnym

Jest to podstawowa analiza należąca do kategorii analiz kosztów. Przedstawia ona wyniki bez rozbicia na grupy identyfikowane w oparciu o pewne „cechy szczególne” zgłoszeń.
Jeśli wymagana jest dokładniejsza identyfikacja w wynikach niektórych „cech szczególnych” zgłoszeń, w programie NNR-Pro zaimplementowane zostały wymienione poniżej analizy dotyczące kosztów, rozszerzające funkcjonowanie analizy podstawowej:
  • koszty w rozbiciu ma wariant decyzji (oszacowanie strat),
  • koszty w rozbiciu na sprawców uchybienia.
Przedstawiona lista analiz kosztów nie jest zamknięta i może być rozbudowana.
Zobacz też informacje ogólne dotyczące analiz.


Koszty w rozbiciu ma wariant decyzji (oszacowanie strat)

Analiza należy do kategorii analiz kosztów i jest rozszerzeniem funkcjonowania analizy kosztów w ujęciu ogólnym rozbijającym wyniki tej analizy na poszczególne decyzje dotyczące uznania (lub nie) roszczeń reklamacyjnych. Raport pozwala na oszacowanie strat wynikających z zaspokojenia roszczeń reklamacyjnych.
Jak przytoczono w informacjach ogólnych dotyczących analiz, zapisy tabeli głównej mogą być uporządkowane (rosnąco lub malejąco) wg każdej z kolumn tabeli, a uzupełniającym kryterium przyjętym do uporządkowania zapisów tabeli głównej może być informacja o okresie. Jeśli kryterium uzupełniające nie jest określone, a kolumną wskazaną do uporządkowania wyników nie jest kolumna informująca o decyzji, informacja o decyzji przyjmowana jest jako uzupełniające kryterium uporządkowania zapisów tabeli głównej.


Koszty w rozbiciu na sprawców uchybienia

Analiza należy do kategorii analiz kosztów i jest rozszerzeniem funkcjonowania analizy kosztów w ujęciu ogólnym rozbijającym wyniki tej analizy na poszczególnych sprawców uchybienia. Raport może być użytecznym składnikiem polityki płac motywującym pracowników do poprawienia jakości swojej pracy.
Jak przytoczono w informacjach ogólnych dotyczących analiz, zapisy tabeli głównej mogą być uporządkowane (rosnąco lub malejąco) wg każdej z kolumn tabeli, a uzupełniającym kryterium przyjętym do uporządkowania zapisów tabeli głównej może być informacja o okresie. Jeśli kryterium uzupełniające nie jest określone, a kolumną wskazaną do uporządkowania wyników nie jest kolumna informująca o sprawcy uchybienia, informacja o sprawcy uchybienia przyjmowana jest jako uzupełniające kryterium uporządkowania zapisów tabeli głównej.


Analiza zgłoszeń

Analiza zgłoszeń umożliwia ocenę ilości odnotowanych zgłoszeń dotyczących reklamacji (niezgodności). Zasadniczym celem analiz przypisanych do tej kategorii jest ocena ilości zgłoszeń w odniesieniu do kolejnych okresów czasowych.
Analiza zgłoszeń może być dodatkowo ograniczona wyłącznie do zgłoszeń przeterminowanych.
Aktualnie program NNR-Pro udostępnia wymienione poniżej analizy dotyczące zgłoszeń:
  • zgłoszenia w ujęciu ogólnym,
  • zgłoszenia w rozbiciu na status,
  • zgłoszenia w rozbiciu na osoby odpowiedzialne,
  • zgłoszenia w rozbiciu na rodzaj dokumentu,
  • zgłoszenia wg kategorii defektów,
  • zgłoszenia wg klasyfikacji błędów.
Oprócz analiz dotyczących zgłoszeń w programie NNR-Pro dostępne są inne kategorie analiz: analizy dotyczące ilości reklamowanej i analizy dotyczące kosztów (zobacz też informacje ogólne dotyczące raportów).


Zgłoszenia w ujęciu ogólnym

Jest to podstawowa analiza należąca do kategorii analiz zgłoszeń. Przedstawia ona wyniki bez rozbicia na grupy identyfikowane w oparciu o pewne „cechy szczególne” zgłoszeń.
Jeśli wymagana jest dokładniejsza identyfikacja w wynikach niektórych „cech szczególnych” zgłoszeń, w programie NNR-Pro zaimplementowane zostały wymienione poniżej analizy dotyczące zgłoszeń, rozszerzające funkcjonowanie analizy podstawowej:
  • zgłoszenia w rozbiciu na status,
  • zgłoszenia w rozbiciu na osoby odpowiedzialne,
  • zgłoszenia w rozbiciu na rodzaj dokumentu,
  • zgłoszenia wg kategorii defektów,
  • zgłoszenia wg klasyfikacji błędów.
Przedstawiona lista analiz zgłoszeń nie jest zamknięta i może być rozbudowana.
Zobacz też informacje ogólne dotyczące analiz.


Zgłoszenia w rozbiciu na status

Analiza należy do kategorii analiz zgłoszeń i jest rozszerzeniem funkcjonowania analizy zgłoszeń w ujęciu ogólnym rozbijającym wyniki tej analizy zgodnie z aktualnym statusem zgłoszenia. Raport pozwala na ocenę postępu prac związanych z rozpatrywaniem zgłoszeń oraz ułatwia nadzór nad zagadnieniem dotyczącym dotrzymania terminów rozpatrzenia zgłoszeń.
Jak przytoczono w informacjach ogólnych dotyczących analiz, zapisy tabeli głównej mogą być uporządkowane (rosnąco lub malejąco) wg każdej z kolumn tabeli, a uzupełniającym kryterium przyjętym do uporządkowania zapisów tabeli głównej może być informacja o okresie. Jeśli kryterium uzupełniające nie jest określone, a kolumną wskazaną do uporządkowania wyników nie jest kolumna informująca o statusie zgłoszenia, informacja o statusie zgłoszenia przyjmowana jest jako uzupełniające kryterium uporządkowania zapisów tabeli głównej.


Zgłoszenia w rozbiciu na osoby odpowiedzialne

Analiza należy do kategorii analiz zgłoszeń i jest rozszerzeniem funkcjonowania analizy zgłoszeń w ujęciu ogólnym rozbijającym wyniki tej analizy na osoby odpowiedzialne za rozpatrzenie zgłoszenia. Raport pozwala na ustalenie przydziału odpowiedzialności za rozpatrzenie zgłoszenia poszczególnym osobom i ułatwia np. w przypadku dłuższej nieobecności pracownika z powodu choroby, przekazanie krytycznych zgłoszeń innym osobom.
Jak przytoczono w informacjach ogólnych dotyczących analiz, zapisy tabeli głównej mogą być uporządkowane (rosnąco lub malejąco) wg każdej z kolumn tabeli, a uzupełniającym kryterium przyjętym do uporządkowania zapisów tabeli głównej może być informacja o okresie. Jeśli kryterium uzupełniające nie jest określone, a kolumną wskazaną do uporządkowania wyników nie jest kolumna informująca o osobie odpowiedzialnej, informacja o osobie odpowiedzialnej przyjmowana jest jako uzupełniające kryterium uporządkowania zapisów tabeli głównej.


Zgłoszenia w rozbiciu na rodzaj dokumentu

Analiza należy do kategorii analiz zgłoszeń i jest rozszerzeniem funkcjonowania analizy zgłoszeń w ujęciu ogólnym rozbijającym wyniki tej analizy adekwatnie do rodzaju dokumentu, na podstawie którego zgłoszenie zostało zarejestrowane. Raport pozwala na zmianę układu rejestru zgłoszeń przychodzących umożliwiającą np. przeglądanie wszystkich zgłoszeń dotyczących niezgodności wykrytych podczas audytu systemu zarządzania jakością oraz wyznaczenie wartości różnych wskaźników dotyczących zgłoszeń np. liczby zgłoszeń zewnętrznych w odniesieniu do liczby zgłoszeń wewnętrznych. Zobacz też opcję „Ustalenie bieżącego wariantu zapisów” w rejestrze zgłoszeń przychodzących.
Jak przytoczono w informacjach ogólnych dotyczących analiz, zapisy tabeli głównej mogą być uporządkowane (rosnąco lub malejąco) wg każdej z kolumn tabeli, a uzupełniającym kryterium przyjętym do uporządkowania zapisów tabeli głównej może być informacja o okresie. Jeśli kryterium uzupełniające nie jest określone, a kolumną wskazaną do uporządkowania wyników nie jest kolumna informująca o rodzaju dokumentu, informacja o rodzaju dokumentu przyjmowana jest jako uzupełniające kryterium uporządkowania zapisów tabeli głównej.


Zgłoszenia wg kategorii defektów

Analiza należy do kategorii analiz zgłoszeń i jest rozszerzeniem funkcjonowania analizy zgłoszeń w ujęciu ogólnym rozbijającym wyniki tej analizy na kategorie defektów. Kategoria defektu określana jest na podstawie aktualnych informacji zawartych w katalogu defektów, dotyczących defektu przypisanego do danego zgłoszenia (jeśli zgłoszenie nie ma przypisanej informacji o defekcie lub też informacje o defekcie nie zostały odnalezione w katalogu defektów, zgłoszeniu przyporządkowana zostanie „nieokreślona” kategoria defektu).
Jak przytoczono w informacjach ogólnych dotyczących analiz, zapisy tabeli głównej mogą być uporządkowane (rosnąco lub malejąco) wg każdej z kolumn tabeli, a uzupełniającym kryterium przyjętym do uporządkowania zapisów tabeli głównej może być informacja o okresie. Jeśli kryterium uzupełniające nie jest określone, a kolumną wskazaną do uporządkowania wyników nie jest kolumna informująca o kategorii defektu, informacja o kategorii defektu przyjmowana jest jako uzupełniające kryterium uporządkowania zapisów tabeli głównej.


Zgłoszenia wg klasyfikacji błędów

Analiza należy do kategorii analiz zgłoszeń i jest rozszerzeniem funkcjonowania analizy zgłoszeń w ujęciu ogólnym rozbijającym wyniki tej analizy zgodnie z klasyfikacją błędu odnotowaną na zgłoszeniu. Raport dotyczy wyłącznie zgłoszeń błędów w oprogramowaniu i może być użyteczny np. podczas przygotowywania planów dotyczących opracowania kolejnej wersji oprogramowania.
Jak przytoczono w informacjach ogólnych dotyczących analiz, zapisy tabeli głównej mogą być uporządkowane (rosnąco lub malejąco) wg każdej z kolumn tabeli, a uzupełniającym kryterium przyjętym do uporządkowania zapisów tabeli głównej może być informacja o okresie. Jeśli kryterium uzupełniające nie jest określone, a kolumną wskazaną do uporządkowania wyników nie jest kolumna informująca o klasyfikacji błędu, informacja o klasyfikacji błędu przyjmowana jest jako uzupełniające kryterium uporządkowania zapisów tabeli głównej.


Administracja

Moduł „Administracja” udostępnia dokumentację dotyczącą działania oprogramowania np. ewidencję zdarzeń, listę użytkowników oraz operacje pomocnicze takie jak np. zmiana hasła użytkownika, aktywacja oprogramowania.


Aktywacja

Program wymaga aktywacji. Można ją wykonać w momencie uruchomienia programu lub wywołując operację aktywacji z menu programu. Aktywacja polega na wypełnieniu i przesłaniu formularza opublikowanego w serwisie http://www.dms-komputery.pl. Formularz zawiera:
  • informacje identyfikującej właściciela licencji: nazwa, (nazwisko i imię - jeśli są umieszczone w umowie licencyjnej), numer NIP i dane adresowe;
  • informacje identyfikującej wersję i egzemplarz programu (numer wersji i identyfikator produktu);
  • treść wyświetlanego klucza rejestracyjnego.
W odpowiedzi przesłany zostanie e-mailem klucz aktywacyjny, który należy wprowadzić do programu. Trzecia kolejna nieudana próba aktywacji wymusza ponowną instalację programu. Przez pewien okres program może być uruchamiany bez aktywowania. W takiej sytuacji mogą być niedostępne niektóre operacje (np. edycji bazy danych). Warunki ponownego uzyskania klucza aktywacyjnego opisane są w umowie licencyjnej.

UWAGA: ponowna instalacja programu wymaga ponownej aktywacji !

Copyright © DMS-Komputery, 2005..


Lista użytkowników

Lista zawiera informacje o użytkownikach posiadających uprawnienia do pracy w programie.
Po zainstalowaniu programu na liście widnieje jeden użytkownik o nazwie „Administrator”, którego konto nie jest chronione hasłem. Zaleca się podczas pierwszego uruchomienia programu, nałożenie hasła na to konto oraz ustalenie listy użytkowników mających prawo do pracy z programem. W programie można przypisać użytkownikowi uprawnienia równorzędne uprawnieniom „Administratora” (uprawnienia administratora). Edycja listy użytkowników wymaga uprawnień administratora. Użytkownicy nie posiadający uprawnień administratora na liście użytkowników mogą tylko zobaczyć swoje dane.
Do listy można dopisać dane nowego użytkownika. Można również poprawić dane użytkownika lub je usunąć z listy (danych „Administratora” nie można usunąć a operacja edycji tych danych, umożliwia jedynie zmianę imienia i nazwiska oraz usunięcie hasła).
Podczas edycji danych użytkownika aktywne są pola wiersza listy wyświetlające: nazwę użytkownika, poziom uprawnień, nazwisko i imię użytkownika, hasło oraz termin ważności uprawnień. Pozostałe pola widoczne na liście nie podlegają edycji i służą jedynie przekazaniu informacji o istnieniu hasła, dacie ostatniej zmiany hasła (patrz zmiana hasła) oraz datach zalogowania i wylogowania. Data zalogowania opisuje datę i czas ostatniego zalogowania się użytkownika do programu. Data wylogowania, jeśli jest widoczna opisuje datę i czas ostatniego wylogowania się użytkownika. Jeśli data wylogowania nie jest widoczna oznacza to, że użytkownik aktualnie jest zalogowany do programu (pracuje w programie), bądź niepoprawnie zakończył pracę programu - można to sprawdzić np. w ewidencji zdarzeń.
Użytkownicy o uprawnieniach administratora nie mogą usunąć własnego konta, a edytując własne dane mogą tylko zmienić informacje o nazwisku i imieniu.
Nazwa użytkownika musi być unikalna a w bazie danych przechowywana jest wyłącznie przy użyciu małych liter. Poziom uprawnień może być liczbą z zakresu od 0 do 9 (poziom 9 odpowiada uprawnieniom administratora). Hasła nie można zmienić na liście użytkowników ale administrator może usunąć hasło użytkownikowi, który zapomniał swoje hasło. Jeśli nie podany zostanie termin ważności uprawnień, użytkownik w każdej chwili będzie mógł zalogować się do programu.
Ogólne uprawnienia użytkownika definiuje się poprzez określenie poziomu uprawnień (zobacz ograniczenia wynikające z poziomu uprawnień). Dodatkowo można zdefiniować uprawnienia szczegółowe zgodnie z przypisanym, do każdej pozycji listy użytkowników, wykazem uprawnień.
Dostęp do funkcjonalności (zasobu) programu wymaga więc by użytkownik zarówno posiadał wymagany dla danej funkcjonalności (zasobu) poziom uprawnień ustalony w kodzie programu jak i miał przyznane w wykazie uprawnień, uprawnienia do skorzystania z tej funkcjonalności (zasobu).
Zobacz też: edycja zapisów listy


Ograniczenia wynikające z poziomu uprawnień

W obecnej wersji programu zdefiniowane zostały jedynie ograniczenia wynikające z poziomu uprawnień związane z edycją listy użytkowników oraz edycją parametrów programu. Edycja listy użytkowników lub edycja parametrów programu wymaga uprawnień administratora.


Wykaz uprawnień

Wykaz uprawnień umożliwia określenie szczegółowych uprawnień użytkownika do skorzystania z funkcjonalności (zasobów) programu. Ma on postać tabeli. W wykazie zawarte są informacje o nazwie uprawnienia oraz statusie wskazującym czy uprawnienie jest przyznane (znak odhaczenia) czy też nie (puste pole).
Uprawnienia podzielone są na grupy i możliwe jest przyznanie uprawnień dla całej grupy lub oddzielnie dla niektórych uprawnień wybranych w ramach danej grupy. Każda grupa rozpoczyna się od wiersza tabeli zawierającego nazwę grupy i jest wyświetlana na żółtym tle. W ramach grupy, podgrupy uprawnień np. dotyczących tego samego dokumentu, mogą być poprzedzone komentarzem informującym o nazwie dokumentu. Linie komentarzy rozpoczynają się od ciągu znaków „===== ” i zakończone są ciągiem znaków „ =====”.
Domyślny wykaz uprawnień, automatycznie przypisywany do każdej nowej pozycji listy użytkowników, nie przyznaje żadnych uprawnień.
Zmianę stanu pola zawierającego status uprawnienia uzyskuje się poprzez odpowiednie polecenie menu listy użytkowników, poprzez podwójne kliknięcie na tym polu lub też naciśnięcie spacji gdy to pole jest wyróżnione w całym wierszu.
UWAGA: w grupie uprawnień dotyczących menu modułów nie można aktualizować statusu dla poleceń menu, które posiadają podpolecenia - w tej sytuacji należy aktualizować indywidualnie status każdego z podpoleceń (nie można też zmieniać statusu niezaimplementowanych jeszcze w programie poleceń menu).
Definiowanie wykazu uprawnień wymaga posiadania uprawnień administratora. Należy też pamiętać, że użytkownik nie może sam sobie zmieniać wykazu uprawnień.
By użytkownik miał dostęp do danej funkcjonalności (zasobu) programu, musi posiadać odpowiedni poziom uprawnień i mieć przyznane uprawnienie do skorzystania danej funkcjonalności (zasobu).


Zmiana hasła

Każdy zdefiniowany w programie użytkownik (zobacz lista użytkowników) powinien mieć hasło zabezpieczające przed nieautoryzowanym zalogowaniem się do programu nieuprawnionej osoby. Operacja zmiany hasła umożliwia zmianę hasła użytkownika zalogowanego do programu. Poprawne wykonanie operacji wymaga wprowadzenia aktualnego hasła (zabezpiecza to przed zmianą hasła przez osobę nieposiadającą uprawnień do pracy w programie jako zalogowany użytkownik np. w przypadku pozostawienia uruchomionego programu bez kontroli) oraz dwukrotnego wprowadzenia nowego hasła. Podanie prawidłowego aktualnego hasła oraz poprawnie wprowadzenie nowego hasła (wprowadzone hasło oraz powtórzone hasło muszą być identyczne) spowoduje zmianę hasła użytkownika. W przeciwnym przypadku program zasygnalizuje błąd wykonania operacji. Równocześnie ze zmianą hasła na liście użytkowników odnotowana zostanie data jego zmiany. W haśle rozróżniane są wielkie i małe litery.


Ewidencja zdarzeń

Ewidencja zdarzeń zawiera wszystkie wyświetlane komunikaty błędów, jakie pojawią się w trakcie pracy programu. Komunikaty uporządkowane są chronologicznie od najstarszego do najświeższego. Każdy komunikat rozpoczyna się sekwencją informującą o dacie i czasie jego zgłoszenia. Oprócz komunikatów błędów ewidencja zdarzeń zawiera informacje o niektórych operacjach wykonanych w programie, takich jak: uruchomienie i zamknięcie programu, wykonanie i odtworzenie kopii, zmiana hasła itp.
Dla każdego stanowiska komputerowego tworzony jest osobna ewidencja zdarzeń. Jedyną operacją dostępną na tym dokumencie jest operacja wyszukiwania tekstu, ułatwiająca znalezienie danej informacji np. o wykonaniu kopii.


Określanie układu kolumn

Dla niektórych dokumentów użytkownik może wskazać, jakie informacje mają być widoczne w poszczególnych kolumnach tabeli prezentującej zawartość dokumentu oraz które kolumny mają być widocznych i jaka jest szerokość każdej z kolumn. Określony przez użytkownika układ kolumn może być zapamiętany jako globalny układ kolumn dla tego dokumentu. Wówczas po uruchomieniu programu na innym stanowisku, dane z dokumentu wyświetlone zostaną zgodnie z zapamiętanym globalnym układem kolumn.

By uaktywnić operację określania układu kolumn, należy z menu kontekstowego tabeli wybrać polecenie "Określ układ kolumn". Jeśli przed wybraniem polecenia, z prawej strony tabeli wyświetlane były dane szczegółowe dotyczące wyróżnionego zapisu tabeli, zostaną one ukryte na czas określania układu kolumn, a po prawej stronie tabeli pojawi się lista odzwierciedlająca układ kolumn. By dezaktywować operację określania układu kolumn, należy z menu kontekstowego tabeli ponownie wybrać polecenie "Określ układ kolumn".
Zmiana układu kolumn jest możliwa zarówno poprzez: operacje na pasku nazw kolumn tabeli, operacje na liście odzwierciedlającej układ kolumn jak i polecenia dostępne w menu kontekstowym listy odzwierciedlającej układ kolumn.

Na pasku nazw kolumn tabeli można zmieniać kolejność oraz szerokość kolumn.

By przestawić kolumnę w inne miejsce należy wskazać ją myszką i trzymając naciśnięty jej lewy przycisk (po wykonaniu tej operacji, z lewej strony kolumny pojawi się pogrubiona linia symbolizująca tę kolumnę w trakcie operacji przestawiania), przesunąć myszką kolumnę w docelowe miejsce.

By zmienić szerokość kolumny należy na pasku nazw kolumn tabeli wskazać myszką prawą krawędź kolumny, której szerokość zmieniamy (w pasku nazw kolumn tabeli, po obu stronach tej krawędzi pojawią się dwie pionowe linie, od których poprowadzone będą prostopadle do tych linii małe strzałki) i trzymając naciśnięty lewy przycisk myszki, przesunąć myszką prawą krawędź kolumny tak by kolumna uzyskała pożądaną szerokość.

Na liście odzwierciedlającej układ kolumn można zmieniać kolejność kolumn oraz ustalić, które kolumny mają być widoczne. Dodatkowo za pomocą menu kontekstowego tej listy można:

  • przywróć pierwotny układ kolumn, to jest układ kolumn, który został zaprogramowany,
  • przywróć domyślny układ kolumn, to jest układ kolumn, który wcześniej został zdefiniowany przez użytkownika i zapamiętany,
  • zapamiętać aktualny układ kolumn jako domyślny,
  • włączyć lub wyłączyć opcję zapamiętywania aktualnego układu kolumn przy zamykaniu okna, jeśli był on modyfikowany przez użytkownika,
  • wskazać czy na danym stanowisku domyślny układ kolumn jest określony globalnie, czy też odnosi się wyłącznie do tego stanowiska.

By zmienić kolejność kolumn, należy na liście odzwierciedlającej układ kolumn wskazać myszką nazwę kolumny (nazwa zostanie ujęta w prostokątną ramkę, której wnętrze będzie miało inny kolor tła niż lista) i trzymając naciśnięty lewy przycisk myszki, przesunąć na liście nazwę w docelowe miejsce (w chwili rozpoczęcia przesuwania zmieni się wskaźnik myszki na strzałkę z prostokątem, sygnalizując tym samym, że jest wykonywana operacja przesuwania). Po zwolnieniu przycisku myszki, kolumna której nazwa na liście była przesuwana, zostanie przestawiona w tabeli, w miejsce wynikające z położenia jej nazwy na liście odzwierciedlającej układ kolumn.

Na liście odzwierciedlającej układ kolumn, obok każdej nazwy znajduje się pole wyboru pozwalające na ustalenie, czy kolumna o tej nazwie ma być widoczna czy nie. Klikniecie na polu wyboru (lub naciśnięcie spacji gdy nazwa kolumny jest ujęta w prostokątną ramkę, której wnętrze ma inny kolor tła niż lista), przestawia znacznik na przeciwną wartość.


Edycja zapisów listy

Edycja zapisów listy odbywa się bezpośrednio w wierszu tabeli prezentującej informacje z bazy danych.

Operacja dopisania nowych informacji wyświetli kursor w pustym wierszu w pierwszej kolumnie, której treść może być zmieniana a operacja poprawienia informacji wyświetli kursor w bieżącej kolumnie bieżącego wiersza. Po naciśnięciu klawisza [Enter] kursor zostanie przemieszczony do kolejnej kolumny, której treść może być edytowana (kolumny z treścią nie podlegającą edycji są przeskakiwane). Jeśli edytowana była ostatnia kolumna naciśnięcie klawisza [Enter] zakończy edycję a wprowadzone informacje zostaną zapisane w bazie danych. Innym sposobem zakończenia edycji jest naciśnięcie klawiszy [Ctrl] + [End] (ten sposób zakończenia edycji może być zastosowany w dowolnym momencie).
Naciśnięcie klawisza [Esc] spowoduje porzucenie edycji. Jeśli informacja została dopisana lub zmodyfikowana, wyświetlone zostanie pytanie dotyczące potwierdzenia operacji porzucenia edycji.
W trakcie edycji można przestawić kursor do innej kolumny wykonując następujące czynności:

  • naciśnięcie klawiszy [Alt] + [Enter] ukryje kursor (jednocześnie nie zostanie przerwany tryb edycji),
  • klawisze strzałek „prawo”, „lewo” pozwolą na przemieszczenie kursora do wybranej kolumny (sam kursor jest niewidoczny - przestawiane jest wyróżnienie bieżącej kolumny),
  • naciśnięcie klawisza [Enter] odsłoni kursor

W przypadku niektórych kolumn, informacja może być wprowadzana operacją wyboru zapisu z innej listy (listy wyboru). Kolumny takie w trakcie edycji mają dołączony przycisk wielokropka. Kliknięcie tego przycisku spowoduje wyświetlenie listy wyboru. Alternatywnym sposobem wyświetlenia listy wyboru jest naciśnięcie klawisza [F2] lub sekwencji klawiszy [Ctrl] + [Enter].
Lista może również zawierać kolumny umożliwiające wybór informacji z ustalonego zestawu opisów. Kolumny takie w trakcie edycji mają dołączony przycisk wyboru (trójkąt skierowany jednym wierzchołkiem w dół). Wówczas naciśnięcie klawiszy strzałek „góra”, „dół” umożliwia wyszukanie właściwej informacji, którą wybieramy naciskając klawisz [Enter].


Dokument niezdefiniowany

W aktualnej wersji programu dokument nie jest zdefiniowany.


Określanie formy wydruku

W przypadku niektórych dokumentów użytkownik może samodzielnie ustalić, jakie informacje ma zawierać drukowana dla tego dokumentu tabela. Zdefiniowany przez użytkownika wydruk może być zapamiętany jako szablon globalny dla tego dokumentu. Wówczas po uruchomieniu programu na innym stanowisku, będzie można do wydruku tego dokumentu zastosować przygotowany szablon. Jeśli dokument dopuszcza definiowanie szablonu wydruku, po wywołaniu operacji wydruku lub podglądu wydruku, wyświetlone zostanie okno umożliwiające określenie formy wydruku zawierające kontrolki przeznaczone do definicji szablonu. Gdy dla aktualnych ustawień dotyczących orientacji i zasięgu szablonu (szablon globalny lub nie), szablon jest zdefiniowany, zostanie on automatycznie wczytany i zaznaczony jako aktywny.

Przed każdym wydrukiem (podglądem) użytkownik może wskazać aktywny szablon, to jest określić czy ma być wykonany wydruk, który został zaprogramowany (predefiniowany), czy też wydruk wg szablonu zdefiniowanego przez użytkownika. Może też zmienić szablon i nie zachowując go, wykonać wydruk wg tego szablonu. By ułatwić użytkownikowi rozróżnianie faktu wykonania wydruku wg predefiniowanego lub własnego szablonu, ten ostatni ma drukowane nieco grubsze boczne krawędzie tabeli.

Operacja definiowania szablonu obejmuje określenie liczby rzędów składających się na jeden wiersz oraz liczby kolumn, a także ustalenie szerokości każdej z kolumn i wskazanie nazwy pola, którego treść/wartość będzie drukowana w komórce identyfikowanej numerem rzędu i kolumny. Dla niektórych wydruków możliwe jest również definiowanie podsumowania tabeli, to jest wskazanie pól, które zostaną podsumowane (a wynik zostanie wydrukowany pod tabelą).

By ułatwić definiowanie szablonu wyświetlana jest tabela z siatką przedstawiająca informacje opisujące strukturę wiersza tabeli wydruku.

Każdorazowa zmiana przez użytkownika liczby rzędów lub liczby kolumn, automatycznie powoduje przebudowę tabeli z siatką. Pierwszy wiersz tabeli z siatką prezentuje kolejne numery kolumn i nie może być edytowany. Informacje z pozostałych wierszy można edytować (zasady edycji są identyczne jak w przypadku edycji dokumentów realizowanej bezpośrednio w tabeli przedstawiającej dane np. na liście użytkowników).
W drugim wierszu wyświetlana jest informacja o szerokości danej kolumny. W każdej kolumnie tego wiersza można wprowadzić liczbę całkowitą odpowiadającą szerokości (w mm) kolumny na wydruku. Kolejne wiersze tabeli z siatką przeznaczone są do wskazywania nazw pól, których treść/wartość składa się na jeden wiersz wydruku (jak już wspomniano wyżej może on składać się z kilku rzędów). Nazwę pola wskazuje się poprzez wybór nazwy z listy rozwijanej, która zostanie wyświetlona po rozpoczęciu edycji dane komórki siatki (jednocześnie w komórce siatki będzie widoczny kursor). Gdy wartość z danego pola może być naliczana i ujęta w podsumowaniu wydruku, korzystając z menu kontekstowego tabeli z siatką, można zaznaczy wybór tej opcji. W tabeli z siatką nazwy pól, których wartość będzie naliczona i ujęta w podsumowaniu, wyróżnione są poprzez wyświetlenie nazwy pola na żółtym tle.

Definiowanie szablonu należy rozpocząć od określenia orientacji oraz ustalenia czy definiowany jest szablon globalny. W trakcie zmiany tych ustawień, automatycznie jest wczytywany (o ile istnieje) szablon dotyczący tych ustawień. Gdy taki szablon nie został jeszcze zdefiniowany, stan tabeli z siatką nie ulega zmianie (jednocześnie aktywny jest przycisk przywracający tabelę z siatką do pierwotnego stanu). Pozwala to w łatwy sposób utworzyć szablon dla innej orientacji wydruku bądź dla innego zasięgu szablonu. A jeśli korzystniej jest zdefiniować szablon wydruku od nowa, można przywrócić pierwotny stan tabeli z siatką (jeden rząd, jedna kolumna o domyślnej szerokości i nieokreślonej nazwie pola).